Fairphone 3 with up-to-date MicroG?

Dear Community,

my girlfriend has the Fairphone 3 from the /e/ foundation since a few months. She would like to use the german Corona Warn App, but it only runs with a current MicroG version.
We already tried to update MicroG via F-Droid, but it fails.
Unfortunately the e software has not been updated since the end of August.
Can anyone help us?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

The last update around the 03.10 was removed as it caused some severe bugs and it was announced to release a new update end of October. This new update should also include an update for microG which should enable the usage of the corona apps. Normally, the system apps (like microG) can’t be updated via an appstore but there are some workarounds. For the FP3 however, it is quite difficult to update the microG version manually.
I am also waiting desperatly for the update so I might use the CoronaApp eventually :wink:


Okay, thanks. Then we hope that the update will be released soon!

1 Like


the update of MicroG was planned for the end of October. Though the issue with the 0.12 update might have delayed this.
Furthermore, customers on stable branch will receive the update at least two weeks later than the dev branch.


Btw, is it also possible to install the microg apk from https://github.com/microg/android_packages_apps_GmsCore/releases?

No you cant update system apps…

1 Like

Any updates on this? The covid counts getting higher and higher and we need both (me and my gf) to took a google phone seperatively to work. :smiley:

I think its better to handle this with microG instead of letting google get all thoose data.


Unfortunately, my girlfriend’s smartphone has still not received the update.

1 Like

I installed today an update. But at the normal place in Settings, System, Advanced there is no mention of updates, so I can’t tell on which version of /e/ I am.
(The Build-nummer is: e_FP3-userbug 9 PQ3A 190801.002 eng root.20201208.023554 dev-keys)
It says microG Service Core
Still the Dutch coronamelder is telling Google Play Service is still being updated. So I can’t use it.
So I am wondering if microG is up to date.


I’m fairly sure this is the microG version without Exposure Notification support … “noen”.
You will have to install the version with EN support yourself, the OS update just enables you to do that now …

I found the updater. Oeps, It’s the first option in the Settings.
I am at /e/OS 0.13-2020120889008,

It says:

  • Open Apps
  • Go to Categories » System apps » microG Exposure Notifications version

I go to Settings, Apps & notifications,
then I tap on > See all 87 apps
I tap on the three dots on the top right of the screen
tap on Show system
And then I can’t find microG Exposure Notifications version
Do you happen to know what I do wrong?
I really appreciate your help very much.

1 Like

You are supposed to open the “Apps” installer (/e/'s own App Store), not the Settings :wink: .

Oh, that’s stupid of me.

Because of health problems I take much care not to get corona.
Now the Dutch coronamelder is working.
Thank you so much for your help.

1 Like

Just blame them for naming the thing “Apps” :wink: .

1 Like

My “Apps” always crashes when I select the microG exposure extension. Why could that be? I’m rooted and using Magisk.