Fairphone - FP4 - FP4 - Documentation Suggestions

i do have that issue, too (as described by admat). Everything worked fine until step 6.
adb recognizes the phone, fastboot won’t. (fastboot = )

after entering recovery mode and selecting ‘enter fastboot’ the command fastboot devices -l shows the device. unfortunately fastboot flashing unlock is not possible, i get

FAILED (remote: ‘Unrecognized command flashing unlock’)

then I tried fastboot oem unlock and got

FAILED (remote: ‘Command not supported in default implementation’)

after executing adb reboot bootloader ‘Fastboot Mode’ is in red letters (as DEVICE STATE - locked).
Is Fastboot Mode disabled?? How to enable it? It would be very helpful to have some comments on this within the manual as well.

very confusing… any ideas how to get this working?
thanks for any help in advance.

using macos montery + homebrew

1 Like

I tried another cable - and it worked.

First try was using the cable from my macbook.

Now I used a cable for external SDD and everything worked fine.

Maybe helpful information, how to check wheather the cable is suitable…

1 Like

Hello Everyone,
Same issue here, I am not able to unlock the bootloader. Everything worked fine until step 6.

I’ve already tried two different cables. One of them is the following brand new, fast, expensive and original Fairphone cable: USB-C 3.2 Long Life Cable - Fairphone 3/3+ | Fairphone

Unfortunately I don’t have more cables to try :neutral_face:

hi there, i am just a regular bloke, so don´t ask me technical questions :slight_smile:

i had the problem too, where i couldn´t get past the fastboot commands.

the problem lies, sorry to say, in the documentation:

Install /e/ on a Fairphone FP4 - “FP4”

under requirements the 3rd points link leads when you follow the rabbit after some steps to a link
where you have to download the drivers for adb and fastboot:

Tip: Windows users also will need the proper drivers installed on their computer. You can check the options available here

BUT there is only the driver for “adb”, the driver for “fastboot” is missing.

the irony is, that, by wanting to get rid of google i had to use it to get that missing bit, the most sources have the driver for fastboot on google drive…

I stuck at the same step “Flash /e/ with the following commands”, terminal (I’m on mac), when I tried the command, terminal say “command not found”. I understand that you give a solution who seems to work for people, but I don’t understand at all what you are saying. Maybe because I’m French, I don’t know, but can you explain your solution to me like I was really really dum? Thanks

Hi all with the < waiting for any device > issue in step 6 of “Unlocking the bootloader”: I had the same issue and using another USB cable did not resolve it.

For me the issue was that I had to run the fastboot commands as root. i.e. sudo fastboot ... in Linux

→ if you have the same issue in Linux, make sure to make yourself su during the installation, as there are a lot of fastboot commands and it would be a pain to add sudo before all of them → enter sudo su in the terminal before using the first fastboot command.

Kodus to @Lidwien who figured this out here :+1:

@Manoj : this should probably be mentioned in the installation instructions!

@roland.polster , @admat see previous post.

I would have mentioned you directly there, but apparently new users are only allowed two mentions per post :thinking:
(so the measure to avoid spam resulted in an additional post. nice :stuck_out_tongue:)

@Manoj more feedback on the instructions:

  • In “Downloads for the FP4” it says “Try the /e/ Recovery (limited functionality)” – this is very confusing and made me look for the “proper” download. Rephrase or remove?
  • In “How to Boot into bootloader mode” you could change the first sentence to “Note: This section will only be relevant later throughout the guide, when you need to reboot into bootloader mode.” to make it more clear what you mean (bold to highlight my suggestion, not to keep ;))
  • “Unlocking the bootloader”, Step 5., rephrase suggestion: Reboot [on fastboot]/[into the bootloader] by running the following command in the terminal/console: adb reboot bootloader
  • Please remove the tip below Step 5. It is in fact misleading, as pointed out by @AnotherElk! You already asked the user to have current adb and fastboot installed, so asking to do this in terminal is enough and avoids confusion.
  • Step 7: Careful, it is very easy to select the wrong option by staying on Volume+ a little too long. → suggestion, rephrase to sth. like: “Select […insert name (“Unlock Bootloader”?) …] using the Volume Buttons and confirm with the Power button.” (same for the other 3 times this is needed)
  • Step 8: you could remind the user to “… (see above)”
  • in “Installing /e/”, see my 2nd-last post: Please mention that fastboot might need sudo (/root) and if yes, do sudo su before running all the commands (on Linux, of course)
  • in “Locking the Bootloader”, step 3, you could again remind to “… (see above).”

Thanks a lot for the guide. The sudo needed for fastboot almost got me, but luckily I found the solution in this very forum :wink:

1 Like

Hello. New here.
I just got my fairphone 4 and was so looking forward to having a de-googled ethical phone!

I followed the guide but it did not work somehow. I read through this thread but did not find the answer.
I believe my problem comes up when I try and copy paste the many lines of code to flash and install. A am in bootloader mode, I have activated USB debug and unlocked the OEM with the code from the fairphone website.

I red about the “navigate to the folder where you extracted the IMG-file”- I have tried pasting all the lines when I start CMD in this folder, I have tried it in the platform-tools folder, and I have nevigated to the IMG-file using commands (cd… etc)

When I do it in the IMG file folder it says “‘fastboot’ is not recognized as an internal or external command, operatable program or batch file”
But when I run it in the platform tools folder it says "fastboot: error: cannot load (the inserted command - of course it cant find it).

I am a noob and I don’t know what I’m doing.
Windows 10.
I don’t know what version of adb

Can you see what I’m doing wrong? I think there could be some more clarity here in the instructions.
The best thing would have been a video.

Thank you in advance!

1 Like

What if you copy everything from your image file folder to the platform-tools folder and try again?

From your description it looks like the command line can’t find the fastboot command in your image folder, which would be normal if you didn’t either add the platform-tools folder to the PATH system variable or add the full path to the fastboot command everytime you use the fastboot command.
The other way around, like you mentioned, the command line wouldn’t find the images in the platform-tools folder if you don’t add the full path to your image folder before every image filename.
Just putting everything into the platform-tools folder and running the commands there should take care of that in an easy way.

1 Like

Thank you THAT WORKED!
Thank you so much!

As I said, this portion of the guide should be clarified for noobs like me :slight_smile:


Hi @junkston
Your post has entirely solved my problem :smiley: Thank you so much for sharing this information.

For all the others with the issue at point 6 “waiting for any device” on windows machines: Fastboot Not Detecting Device on Windows 10? Here's the Fix | Beebom

@Manoj Could you you please check this issue? I think the requirement of the installation of fastboot driver for Windows user is an essential (but missing) point in the installation instruction!


Did you install the driver to confirm this?

https://github.com/koush/UniversalAdbDriver says it’s “a single Windows driver that supports the ADB (and fastboot) interface for most Android phones.”

1 Like

yes, i installed the driver after a google search (blaarg) from a google drive (blaarg*2)

exactly where @roland.polster posted. i just posted not the link, because i did not know if outside-sources are allowed here.

the installation manual links to (at that time) a site where there stands “download driver”.
this is logical, i click on it and expect that i with this have all the driver i need, as there is not anywhere anything else is stated.
why should i click on the link to https://github.com/koush/UniversalAdbDriver ?
by this logic i should click download visor too?
i am a regular person, i dont click any links because they are there… (1st rule of internet, dont click links you dont know)

i think the main problem in this case ist, that the manual, or this part in particular, is written from the view of a person who

  • is a knowledgeable programmer
  • uses a existing library of tools and drivers
  • uses linux

no front, but to test if your manual works, dont take a intern, take someone from the street and check if
it works out :slight_smile:

1 Like

You shouldn’t, I just cited the place (linked to on the driver download page) where it says that the UniversalAdbDriver should cover fastboot, too, just to confirm whether it does or does not do the intended job in the scenario at hand.

In the former case the driver would be needed to be more prominently placed in the docs, in the latter case the docs would need to adopt a working solution.

1 Like

“waiting for any device” issue AND SOLUTION

I had an issue while installing /e/ on the FP4 using Windows 10.
The Phone was recognized in adb mode but not in fastboot mode and the following message appared: “waiting for any device”.

Luckily I found a solution which I want to share with you:
This was an USB driver problem, therefore I had to update the driver in Windows 10.

  • I went to the Driver Manager, there the device was shown in “USB-Devices” as “Fairphone” in adb mode. When I switched to the bootloader the device was shown in “Other Devices” as “Android” with a yellow triangle.

  • While the phone is in the bootloader, right click on the device (Android) in the Device Manager.

  • Choose update driver

  • Choose Search automatically for updated driver software → Windows doesn’t find any drivers

  • Choose search for actualized drivers on windows update

  • Choose show optional updates

  • click on driver updates

  • I updated three different drivers (LeMobile Android device and two others)

  • After that my device was shown in the device manager under LeMobile Android Device with the name Android Bootloader Interface and the the device was shown in the PC-console when I typed fastboot devices.

  • Furthermore the installation worked fine in the PC-console that I have started in the Folder with the .img files.

Maybe one could include that issue in the documentation, so people with the same issues wouldn’t spend time on searching for a solution?

Good luck!


I can confirm, that I had definetely installed the recommended adb driver from the installation instruction: https://adb.clockworkmod.com/

With this driver installed I was not able to perform any fastboot command e.g. “fastboot devices”. After the installation of the driver recommended in the instruction at the Beebom Homepage the command “fastboot devices” was able to find my device and I could continue to unlock the bootloader whitout any problem.


Exacxtly! This is what I’ve done according the description at this Beebom Homepage and what have solved the problem on my side as well.

Hello there,

And thanks to all of you that have answered a lot of questions to a lot of person !
I’m here with a new request however :slight_smile:

I’ve bee following to the point the tutorial, wich I find quite clear. I’ve encountered no trouble until the very last step : re-locking my bootloader.
No problem with the fastboot flashing lock_critical but when I finally lock it with the fastboot flashing lock as highly recommended (and I can see why :slight_smile: ) when my device reboot, it finally ends up in

This device is corrupt and will not boot.

Then a bootloader loop appears until I unlock it again, flash it all back in then keep it unlock and boot.

It seems that the flashing lock last bit erase all data in my device and so it does not work properly… any encountering of this problem ?

I’m on FP4, with all the correct tools to flash it as I can boot on eOS and it works just fine. I just have to keet the bootloader unlock and dont feel very safe with that option…

1 Like

Hi @Neruu2 welcome to the /e/ forum, but this thread is for Document Suggestions. Please try a search for your error, like this click on the link:- Search results for 'device is corrupt and will not boot Fairphone 4' - /e/ community.