[SOLVED] Fastboot oem unlock problem, installing /e/ with Linux, Fedora

On my pc screen it shows:
adb devices

daemon not running; starting now at tcp:5037
daemon started successfully
List of devices attached
A209xxxxxxxx device

So I do:
fastboot oem unlock 6bxxxxxx

and I get on the pc screen:
< waiting for any device >

and my phone is showing the following picture!

The solution I got on the forum of Fairphone was:

“Maybe you need to run it as root

And that solved my problem.

Normally one doesn’t work as root on Linux, only as user.

Did you enter the command …
fastboot devices
before you entered
fastboot oem unlock?

No.
I followed the install instructions on
https://doc.e.foundation/devices/FP3/install
I choose Fastboot from the menu the phone was showing.

  • Reboot the device on fastboot mode by running adb reboot bootloader (or press Power + Volume - if your device is off)
  • Once on fastboot mode, unlock the device by running fastboot flashing unlock
    On previous versions of fastboot , the command is fastboot oem unlock

Type Fastboot devices in the command prompt of your host maschine and result should be a serial number, similar to the adb devices command.

If entering this command shows your device name with a serial number, it implies that your phone is good to go for fastboot operations.

However, if the result is empty then you might want to check the fastboot installation, e.g. fastboot version (and drivers).

That’s worth trying next time I need to install. Thanks.
For now I am so glad that after an Open Os on my Fairphone 2 from Fairphone itself, I have again an Open Os on my Fairphone 3.

But that’s the problem described in the other topic: [SOLVED] Fastboot -w installing /e/ with Linux, Fedora on Fairphone 3

This topic as far as I understood is about whether the fastboot/adb commands need root/sudo (or udev rules/correct group memberships; which I think might ask too much of people already struggling with the command line).

You’re right, I mixed the topics up, sorry. Post deleted to avoid confusion.