Fastboot problem - installing /e/OS on Fairphone 3

Hi all!

In trying to escape from Google, I bought a used Fairphone 3 to try to install / e / OS on.

Unfortunately flashing and such adventures are completely new to me and I seem to be having problems, so hoped you might be able to help. I’ve probably missed something very basic!

I started by updating my FP3 to the latest Android 10 build, and then followed the step-by-step instructions at Install /e/ on a Fairphone FP3/3+ - “FP3” . My PC is running Windows 10 (for my sins!), so I followed the directions to download the latest version of the Platform Tools, and the latest Universal ADB drivers.

Then came the first point, fyi, where my experience didn’t fully match the instructions. Following the steps given there under “Adding adb path to the environment variables” did not have the desired result of allowing me to execute adb commands from anywhere on the system. I still have to open the command window inside the platform-tools folder to get a response from adb. But ok, no big problem I thought - just a slight inconvenience.

So I returned to following the main instructions, which successfully took me through enabling USB debugging and allowing the bootloader unlocking. I then ran adb reboot bootloader through the command prompt, and was pleased to see the phone respond by rebooting into fastmode (which I’ve never seen before).

So far, so good. Then I hit the big problem. The next instruction is to run fastboot flashing unlock, but when I do so I receive the message < waiting for any device > and nothing else happens. I tried fastboot oem unlock instead, but with the same result.

I then realised that seemingly no commands beginning with fastboot are working. For example, while adb devices returns the serial number of my Fairphone3, fastboot devices doesn’t do anything at all.

Does anyone have a clue as to what the problem might be?

I did some reading around the forums and tried installing adb and fastboot from here and here, but neither worked. I’ve also noticed that while my Device Manager looks fine most of the time, when the Fairphone3 is in fastmode (and only when it is in fastmode) there is a yellow exclamation mark against the phone in Device Manager.

This makes me wonder whether there might be a driver issue, despite my installing the Universal ADB drivers as instructed. Since it seems that fastboot is not working at all, is there perhaps a separate driver for fastboot that I might be missing??

Thank you for any guidance you can offer as to next steps I can try.

Usually this here should help, just ignore references to the Easy Installer and concentrate on the steps regarding the driver situation …

1 Like

Ah, thank you for the very speedy response. This looks promising. I am downloading the new drivers now and will let you know.

Yes, as you suspected, this has resolved the issue, and I have been able to unlock the bootloader. Thanks so much @AnotherElk!

One further quick question, if I may. The next stage in the instructions simply says

Unzip the archive:

 unzip <zip>

Having tried a few variants on that, I’m unable to find the correct syntax for the unzip command.

On my system, I have currently placed the zip file for the /e/OS build at:

Can you tell me what exactly I should be typing into the command prompt?
Or should I simply use unzipping software to unzip the file in its current location (in the same folder with adb and fastboot) before proceeding with the below?

I’m a little confused that I don’t see anything in the below that specifies the location of the /e/OS build files, and don’t want to make any silly mistakes that brick my phone!

Install /e/ using the following commands (from fastboot mode):

 fastboot -w
 fastboot flash system_a system.img -S 522239K
 fastboot flash boot_a boot.img
 fastboot flash vendor_a vendor.img -S 522239K
 fastboot flash dtbo_a dtbo.img
 fastboot flash vbmeta_a vbmeta.img

 fastboot flash system_b system.img -S 522239K
 fastboot flash boot_b boot.img
 fastboot flash vendor_b vendor.img -S 522239K
 fastboot flash dtbo_b dtbo.img
 fastboot flash vbmeta_b vbmeta.img

 fastboot flashing lock

Ah yes, they were a bit unspecific with that, it seems.
Windows 10 doesn’t have the unzip command by default.

That’s an option. 7-Zip is a good one, if you don’t have one already. The same folder with adb and fastboot is a convenient choice for a target folder.

Alternatively, you could just open the ZIP file with the Explorer, which would show the contents then like they would be in a folder, so you could copy the contents out of the ZIP file this way.

1 Like

Thanks for pointing this gap in the documentation
Will add a reference to unzip in the folder where fastboot is located or else add path to the fastboot location in the console commands.


Thanks @AnotherElk . I’m happy to report that I now have /e/OS successfully up and running on my FP3! Your help deeply valued.

I have a bit of learning to do now as I get used to how it all works, but that’s the fun part, now that the fear of bricking the device has passed :wink:

And @Manoj, perhaps I can usefully offer some input to your reworking of the documentation, as an authentic completely inexperienced newbie! Two things that would have left me very grateful to the documentation author and saved me having to come to the forum for additional help:

  1. On the adb/fastboot installation instructions for Windows users, there is a helpful tip:

Tip: Windows users also will need the proper drivers installed on their computer. You can check the options available here

  1. … I followed this, but it would have been helpful to also note (as @AnotherElk did above, offering a useful link to instructions) that in addition to the driver package offered, searching for optional driver updates under Windows Update may also be necessary.
    However, I suspect that such a search may only produce the requisite drivers if done after installing adb and fastboot? In case that’s right, I’d suggest adding an additional tip about Windows Update at the bottom of the page, after the adb/fastboot installation instructions.

  2. Thanks for the update you’ve already made to the Unzip instructions, which are a great improvement.
    I would actually find them clearer if you also removed the two words immediately under “Unzip the archive” that say “unzip < zip >”. Due to the formatting that gave me the impression that I am supposed to enter “unzip < zip >” into the command prompt (which doesn’t work).
    So I would recommend that you just delete those two words from the instructions since, as a newbie, I find the new instructions that you have added much clearer. If they followed straight on under “Unzip the archive” I would have known exactly what to do before continuing on to the fastboot instructions given underneath.

  3. And one additional thing. “Unzip the archive” could maybe be changed to “Unzip the /e/OS build archive”.
    I worked out that that was what “the archive” must refer to, but it is possible to make it clearer, since the word “archive” had not appeared in the instructions before.

I hope that’s helpful (both to you and to newbies following the same trail in future), and thanks again for all the help in allowing me to explore a Google-free phone life!

Naturally disregard any of my suggestions that you can see are misguided for any reason. In general the documentation was exceptionally clear and helpful, which is what encouraged me to give it a go.

Very best,


From my experience, technically it depends on the phone being connected via USB in the respective mode (i.e. normal OS + UDB debugging or recovery for adb drivers, fastboot mode for fastboot drivers).

Which makes sense, because windows will see there is a so far unsupported device connected. And each device sends some kind of identification information that windows can then use to search for the correct driver.
That often works automatically once the device is connected. Not sure why this doesn’t seem to be the case for the adb/fastboot related drivers.

1 Like

Thanks. Yes, that fits with my experience (as per my original post above) that Device Manager only showed the yellow exclamation mark when the phone was in fastmode.

Hopefully a tip can be crafted for this page that will guide people through getting the drivers they need to make the installation work.