Feedback for v1.7

Anything regarding the “Overlaying app detected” issue on the FP3 with some banking apps?
Should an issue be raised on gitlab directly, or what is the best way to proceed?

1 Like

Today I discovered this “Overlaying app-problem” while operating the German comdirect-APP. Disallowing all overlaying-grants doesn’t help to fix the problem! Help urgently wanted!

EDIT: I opened an issue

  • Vendor Name fairphone
  • Device name Fairphone 4
  • Device CodeName fp4
  • Version of /eos e/os/1.7-s-20230110250403-stable-fp4
  • rooted

Update itself worked flawlessly.
What I encountered was that images taken in HDR mode had a strange color effect (without any filter being set). Deleting camera data reverted this to normal.
What changed is that the lens is now shown as text - much better as there is now less confusion with the button to change front/back camera.

Still in camera app tapping lens will first change to wide lens, then to a 3rd lens (that does not exists, so an error is thrown). This behaviour has not changed.
Also unchanged is the speed of the autofocus: extremely slow. Taking pictures might take seconds (or does not start at all if the object is moving). That is quite annoying.

Overall the update did not change anything notably to the worse and it is a joy to work with /e/os. Also battery life is extremely good (though I have no real life comparison with my fp4).

Best regards

1 Like
  • Vendor Name fairphone
  • Device name Fairphone 4
  • Device CodeName fp4
  • Version of /eos e/os/1.7-s-20230110250403-stable-fp4
  • Not rooted

Everything works well. Did not notice any new bug.
Still not able to rotate and save pictures that are stored on the SD card with the native gallery app, but this is a minor bug as I can do it right with “simple gallery app”.

Thank you to the whole team for their valuable work!

1 Like

Thanks for raising the issue @frank.bxl. Have passed the detail to the development team.

1 Like

FP3+, Andro 11
Noticed no new issue so far.
Persisting issues from 1.6:

  • 20–33% of boots are strangely long (Feedback for v1.6 - #125 by alice_m).
  • When charging while the phone is turned off, the circular charge-level gauge eternally remains at the same level, not reflecting the actual charge level you’ll see when booting up. I hope it’s just a display issue and not something that could set the battery on fire by overcharging it, haha.
Vendor Name: Sony

Device name: Experia XA2 Ultra

Device CodeName: discovery (H3213)

Version of /e/OS or Stock which existed previously:

Is the device Rooted / Not rooted: Rooted
  • Turned my device on today, OTA update notification arrived. Performed update which seemed to go well at first but on reboot I got stuck on the recovery screen (which did show v1.7). Tried setting bootslot to ‘a’ with fastboot (was on ‘b’) and reboot - performed the update again, same result.

  • Did a full install (from Pop OS and following the install guide, which I think is very clear and simple to follow), and succeeded in booting 1.7-s-20230111250406-dev-discovery.

  • Will have to reinstall all apps and test.

My current experience (with 1.6) is: I really like that I can see and block trackers per app (such as my banking app that uses Google Analytics). Privacy mode does seem to slow down browsing, but it seems the battery lasts forever :).

  • microsoft app, kroger grocery app
  • oneplus8
  • instantnoodle
  • previous version worked (assume 1.6?)
  • Rooted, unlocked bootloader

Since 1.7 update my microsoft apps won’t allow me to login. This effects outlook, teams, office 365
Also, kroger grocery apps (frys, qfc, fred meyer)
The beatstars app is also having issues.

Overall if i were to speculate there is an issue with account validation with this update

Try this : go to Advanced PrivacyManage apps’ trackers → then disable ‘Block trackers’ for the apps you have problems with.
Now try to login again…

Hi I realized that after my last update the battery doesn’t resist charged more than 6 hours (after complete charge) and the application doesn’t work anymore.

Vendor Name: Fairphone
Device CodeName: FP3
Version of /e/OS or Stock which existed previously: 1.6
Is the device Rooted / Not rooted: Not Rooted


I had the same issue as you with SNCF.connect app.

Battery usage:
I’ve uploaded the v1.7 on 10 of January. Since this date the charge of my battery decreases quite quickly (about 1 day, even after having selected the option to reduce the battery usage).
I have a Samsung S7 (model SM-G930F).
Is there a way to fix this pb ?

Edit: I think that I discovered the pb. When I reboot the phone, it starts automatically all my apps in background including magic earth which is terrible for the battery. I’ve forced them to stop and the battery consumption seems to be normal.

1 Like
  • Vendor Name: BQ
  • Device name Aquaris: X Pro
  • Device CodeName: bardockpro
  • Version of /e/OS 1.6 previously
  • Not rooted
    Everything works fine, no issues.

Can’t answer as I don’t live in France.

Did you try to clear cache and data, deactivate advanced privacy and try again?

If You did not use Advanced Privacy´s features before the update it´s definitely worth checking current AP´s settings … seems like the update activates AP-functions and /overwrites specific previous AP-settings (I can tell from experience with my S7, same model, whereas I did not observe change in battery behaviour)
Also worth trying: check which apps eat most of the battery (system settings → battery → upper right 3-dot menue) and clear cache of those apps

1 Like

Hello dear community!

I would appreciate your help as I ran into an issue while upgrading my phone to the latest /e/os release last week.

Device model: Samsung SM-G950F

version before upgrade: I didn’t write the version down, however it was the /e/ OS version released in Spring of 2022 (April I think).

version after ugrade: 1.7-20230110250404 (build number e_dreamlte-user 11 RQ3A.211001.001 eng.root.20230110.190553 dev-keys)

Symptom description: The download of the upgrade files went well, but after the reboot the phone got into recovery mode and I had to choose to boot is via the menu. I was able to reboot it and the phone basically works (installed version is shown as 1.7), but the screen constantly shows an Android System notification “Finishing system update…” with the progression bar being either around 15-20% or around 75-80%. This progression bar does not change over time while the system is operating, but might switch randomly between these 2 states after a reboot.

After a couple of hours to a couple of days, the system crashes and restarts into Recovery mode (v.1.7).

From the options there, if I choose “Apply Update”, I can get to the next screen, where:

“Apply Update” cannot be selected

“Apply from ADB” is selectable, but on the next screen “ADB Sideload” goes not lead any further.

On the main screen of the Recovery mode, I get the following message (3 lines):

Now send the package you want to apply to the device with “adb sideload ”

Install completed with status 3.

Installation aborted.

I am still able to access the following options in the “Advanced Options” menu:

Reboot to bootloader

Reboot to recovery

Mount/unmount system

view revovery logs

Enable ADB

Power off

“Reboot to boatloader” works in the sense that the phone then boots correctly, but I still get the “Finishing system upgrade…” notification, and the phone eventualy re-crashes after a few hours/days.

Also, since this incomplete update, I am unable to update any app via the “official” app lounge. When I try, the app gets downloaded correctly until it reached 100% but then never switches to the “installing…” phase (even after hours).

Any help would be greatly appreciated!



Hello @Denis_O That sounds unfortunate. Not really helpful but here is an example of an other user with same device. Maybe read thru his comments…

Thanks for this link, mihi. In my case however it is somewhat different as the system crashes and goes into recovery mode, where it then clearly states “Install completed with status 3. Installation aborted.” (By the way, what does status 3 mean?). The progression bar is only one part of the problem, the system crashes and boot into recovery mode are far more disruptive.


Have you tried to re-install e-1.7-s ?
(you may have to re-download it because “delete update file after install” is the default setting in the system-updater feature).

you mean wiping the device and re-installing it from scratch? That would be my very last option: I’d like to try to somehow recover the system without loosing data, if possible.