FP3 Wifi-Calling no longer working

Since the update from 1.4 to 1.5 (Android 10 to 11) on my FP3 WiFi-Calling no longer works.
On 1.4 WiFi-Calling was working without any problems. So Provider supports Wifi-Calling, Wifi-Calling is activated on the Phone and prefered when dialing

I hoped that 1.6 will fix it but it didn’t. So I rolled back to Fairphone-OS and installed a fresh /e/OS 1.6.
→ WiFi-Calling is still not working.

I tried every Tipp or Workarround an this Forum, but nothing fixed the Problem.

OS Verision now: /e/OS 1.6-20221129238947-stable-FP3

Would be great if someone could help.

Works for me on 1.6-s-20221201239247-dev-FP3 with a Telekom SIM card.

You could ask your mobile network provider whether they can currently see a problem with this on their end.

1 Like

I called my provider (congstar), they checked everything and told me it’s all correct and Wifi-Calling should be working. I also made a Wifi-Call with my SIM in another Phone. It worked.

I think it must be my phone because wifi-Calling stopped working directly after the update from 1.4 to 1.5 (Android 10 to 11).

I fould these two posts from other users:
https://gitlab.e.foundation/e/backlog/-/issues/4850

https://community.e.foundation/t/when-trying-to-use-wifi-calling-while-connected-to-wifi-phone-asks-to-connect-to-a-wireless-network/37772

If there is a bug then I wonder under what circumstances it appears, because I doesn’t seem very spreaded.

Is there a way to compare ALL for Wifi-Call necessary settings of the FP3? … including permissions and the “advanced privacy” settings?

Thanks for your help.

Usually I don’t use Wi-Fi Calling, so I don’t know much about what could go wrong (apart from the whole thing in general for more or less comprehensible reasons).
For testing I …

  • enabled Settings - Network and Internet - SIMs (I only have one) - Wi-Fi Calling
  • in the same place made sure Calling Preference was set to Call over Wi-Fi

In Settings - Advanced Privacy my real IP address is exposed.

Thank you for your answer. I tried everything you said and other things too. I checkt allot of the settings twice, but still no Wifi-Calling.

But today something strange happend: I got a Call with Wifi and Airplanemode on and it said: incomming Wifi-Call !!! So I was surprised by it.
Immediately after the call I tried to make a call over Wifi. But then the old message popped up again:
“Mobile network isn’t available. Connect to a wireless network to make a call.”

What is going on? Seems like there is only a problem with MAKING a call and not getting one!
Its frustrating… :frowning:

do you set any DNS servers yourself, either on-device or custom ones via dhcp? if so, give the ISP supplied a try. But this used to be only an issue with Vodafone that infers eligibility from the used DNS - might be moot with congstar. Incoming working but outgoing? really weird. Do you filter udp port 500 and 4500 ?

Thnaks!

I didn’t change any DNS settings at my Router or FP and think they are all default.

On the FP3 under DNS:
Use network DNS is ON
only if I turn it OFF I can see “Enter DNS IP” it’s set to 9.9.9.9

looking at “adb logcat” while trying to place a wifi call (you can set it to prefered so it will give it a try first) maybe yields a verbose reason for it to fail?

From your description the reason must be on-device. But still would be helpful to tcpdump at the router if any dns querys for 3gppnetwork.org occur and packets to udp 500/4500 leave the device.

here’s a (lengthy) german article on the wifi perspective, but as I said I think issue must be on-device.

I think @Liquid77 that you might continue your research with your carrier on the basis that this might be an APN settings issue.

When I search the internet for “congstar + wifi calling + APN” I got many hits.

Another hint to this idea is that you just Upgraded Q → R; in /e/OS -r- branch, prebuilt/common/etc/apns-conf.xml · v1-r · e / os / android_vendor_lineage · GitLab there is no match for “congstar”, while in the Q branch there are two hits.

<apn carrier="congstar Internet" mcc="262" mnc="01" apn="internet.telekom" type="default,supl" protocol="IPV4V6" roaming_protocol="IP" authtype="1" user="congstar" password="cs" mvno_type="spn" mvno_match_data="congstar" bearer_bitmask="1|2|3|9|10|11|14|15" />

<apn carrier="congstar Internet" mcc="262" mnc="01" apn="internet.telekom" type="default,supl,mms" protocol="IPV4V6" roaming_protocol="IP" authtype="1" user="congstar" password="cs" mvno_type="spn" mvno_match_data="congstar.de" mmsc="http://mms.t-mobile.de/servlets/mms" mmsproxy="109.237.176.193" mmsport="8008" bearer_bitmask="1|2|3|9|10|11|14|15" />


This post does not give conclusive advice, nor does it mention wifi-Calling, but does demonstrate some of the issues found with #apn + #fp3 FP3 roaming/APN not working.

Of course they cannot see the APN settings on your device, and they may think that their settings have been issued to you on the fly. I suggest you call them again and ask to have the full APN settings sent direct to your device.

Less recommended

You can check your settings and try to edit them manually from Congstar’s own published APN settings. In my searches I found unusual variance in recommended settings as in this article (which I do not particularly recommend, but include only because it seems to show up unusual issues with Congstar’s settings).

https://www.internetsettings.org/en/germany/congstar-apn-settings/#apn-settings-for-android

Settings > Network and internet > Mobile network > Advanced > Access point names