Galaxy S9 'starlte' + /e/OS 'Q' dev AOSP Android 10

He who waits with prudence
He will be rewarded in due time
Now the wait is over
Lend your ear to a legend

The long awaited, indeed hotly anticipated /e/ OS ‘Q’ upgrade AOSP Android 10 for the Galaxy S9 'starlte’ (also S9+ ‘star2lte’) has been released as ‘dev’ release e-0.13-q-20210120 and has been downloadable to the general public since 25 January 2021.

I was able to manually install it fresh & clean via TWRP Recovery 3.5.0_9-0 with Samsung Firmware Android 10, build date April 2020.

The fact that the eOS ROM generated on 20.01.2021 is released with ‘Android security patch level 5. Nobember 2020’ at the end of Janauar 2021 and with older microG Services Core speaks volumes - at least for me.

eos13qmicroG vs

Let’s see what surprises are still in store for 2021 …


Hi @SuzieQ,

Might be a beginners question but where did you get the Samsung Firmware android 10 (vendor image I guess)?
I have /e/ android pie loaded.

Thus I always get a error 7 with regards to wrong vendor.

Hence, whatever I am missing here,thanks for some guidance on how you did it.

Best regards,

Hi @marcih83, yes, I think it’s a beginner question :))
But those who don’t know should ask so they can move on.

Samsung stock firmware is available on various channels. Two reputable ones are sammobil and samfrew. Samfrew has the slightly faster free download, but it still takes hours to download the zipped 4.65 GB ROM.

Happy downloading & flashing.

1 Like

Hi @SuzieQ,

As I am a beginner, my question fits the shoe:)

I top it with another startes question for the joy of the community.
So it means I need to dumb the full official Samsung os first over my /e/ os (via Odin I guess) and then flash the new /e/ update?!?

So there is no way to use a file like “” ,that was used to get the pie version running?

If so, that is really some extra extra work .

Thanks and best regards,

@marcih83, we were all beginners once. And I’m still learning every day. And this learning is fun …

Well, it makes sense for me to install a stock Android 10, because it updates not only /Vendor, but also the bootloader and the important /EFS (modem and more).

The software jump from Android 8-Oreo or 9-Pie to 10-Q is a big one. For future-proof S9 / S9+, I think it’s worth the work. Tinkering around does not pay off. The S9 / S9+ is still a valuable phone. It deserves the best conditions to remain operational for a long time.

I’ve installed /e/ OS Q on my S9+ this morning, after the long wait! Most apps are running OK so far. Its been a while since I tried /e/ Oreo on the S9+ so looking forward to giving Q a decent run.
Just a quick question @SuzieQ to your knowledge does this Q version have 2-button navigation? I haven’t been able to find anything myself.

@Sean, a 2-button navigation app is available in /e/OS ‘Q’, but disabled.

In the meantime, the urgency has been recognised:

This is a good start for a successful y/e/ar.

:slight_smile: i am already downloading…sloooooowly…the October Stock Rom from Samsung to do this task.

I will let you know if it did work out in the end.


This is the price for gratis, but clean firmware… :))

Thanks @SuzieQ , this might be dumb question to ask but can it be enabled easily?

Unfortunately no, @Sean. I’ve tried it via adb root. Adb shell reported back: … new state: enabled. But the app is still not active within /e/ OS ‘Q’.

That’s a shame, I find the 2 button set up very useful as I only have one arm

That’s why I donate to /e/ as hopefully all users do one day:)

Well, for LineageOS there is a ‘Magisk’ 2-Button-Navigation app. I use /e/ OS deliberately without root (Magisk). But I will try this app for you. Not today - but in the next few days. Please remind me if I forget about it.

That would be awesome, thanks @SuzieQ, I’ll look into the magisk option as well and let you know how I get on.

Hi @Sean, I was able to install the 2-button navigation app successfully and it is also displayed under ‘Modules’ in the Magisk Manager, but there is no option(s) for it in the > System > Gestures section.


At the moment I can’t tell if I made a mistake or if the app doesn’t work with /e/OS ‘Q’.

Fyi, I tried skipping flashing to stock Android 10, and tried to flash to the new Q first (with TWRP 3.5). Got missing vendor errors, so it seems that you really do need to start with flashing a stock ROM.

I am still trying to find a stock ROM zip file that will work for me (getting corrupt file errors), I’ll make a follow up post if I succeed.

If you’ve successfully upgraded to Q can you decribe what you did, where you got stock Android 10 files, etc?

I have tried sideloading a couple of stock Android 10 ROMs from samfrew and get corrupt zip file errors when trying to sideload with TWRP 3.5. Copying the same ROM into the phone directly and installing from within TWRP does not work either. I am trying to see if files from sammobil cause the same errors, just waiting on downloads.

I’m in the USA, but have no idea which stock Android ROM will work, so I’m just guessing - does this mean that I cannot upgrade to Q?

What is your actual working CSC ?
( it is stored in the location : /EFS /IMEI /mps_code.bat )

also viewable in the stock download mode screen