GPS acquisition


I am now in the position to move to /e/ as a daily driver. Came across an issue this evening which is preventing me from completing the move.

I have tried to see about raising this as an issue in the git lab thing but can’t see how to do that…

Basically GPS doesn’t work. I did a fresh install of the latest /e/ on a OPO 3T. Maps and Waze were unable to get a fix. Waze reporting no GPS Fix possible. I install GPS Status which confirmed that even with being outdoors I was unable to pick up and satellites.

After some quick googling I found that this is a common issue for lineage.

The culprit being a gps.conf file which is not configured and so has no options enabled.

Using ADB I was able to gain access to /system/etc/gps.conf and edit the file. Removing the # from the 3 lines which start with XTRA_SERVER and also changing Version check for XTRA from 0 to 1 has fixed the GPS issues. Device now gets pretty much an instant fix.

How do I go about getting this fixed from source ? as I expect that the changes will get overwritten with each new update of /e/

1 Like

I cannot answer your question on how to fix this from source. I just want to point out that there is an app in F-Droid called FasterGPS. It is an editor for the gps.conf file which makes editing more convenient. Of course it requires root.

I don’t think it is possible to integrate the modification of this file into the global version of /e/ because the XTRA server settings you modify depend on the user’s location. So the gps.conf file must be customized according to the country of each user, which seems difficult to manage for each build of each smartphone model.

However, to prevent your configuration from being reset each time you update, it is essential to change the permissions of the gps.conf file (as shown in the image) before saving it to the smartphone.

1 Like

Thanks I’ll see about finding the correct configuration for my location and changing the permissions as you suggest. Seems to only affect 7.1

1 Like

I also seem to be having problems with GPS. However, I am not so technically savvy as to be able to implement this fix. Help please!

1 Like

I’m using /e/ OS on HTC 10 (the build from 17.01.2019, based on Android 7.1.2), and my GPS is not working either (I used to have LineageOS installed, and it worked fine there).

I tried the FasterGPS app, as well as some gps.conf files for my country (Poland), but nothing seems to fix it.

The GPS test app doesn’t report any satellites in view / use.

I’d be really grateful for any help in solving this issue, as I’d love to keep using this system, but GPS is a very crucial feature.

1 Like

Pl can this be raised as a bug on Gitlab with all details. That will help get a developer to work on this. If an issue has already been raised Pl share the ID so that I can pass it on to the dev team to work on.

1 Like