GS290 easy-install worked well; Bluetooth & WLAN fail under e OS

Hello there,

do you have an idea why bluetooth and WLAN refuses to be activated?

The only system message is: Bluetooth stoped a lot of times



Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello !

May be the same issue as Wifi not working - #3 by austrasier ?

Thank you for your response. The error messages are the same. So i will look for a possibility to install eOS again. I am new in doing this.

Hello @Uccello Did you manage to fix the issue? Did reverting to stock image without updates, and then installing /e/ solved the issue?

Hello Shenol, thank you very much for your question

to be honest: I do not own the stock android image and can not find it. The reset to factory default did not bring any change.


Hello Uccello,

you’ll find the link to the right stock rom here (process to revert a GS290): Reverting to stock ROM on the GS290 for Windows users

I encountered the same issue with Wifi and Bluetooth, and described problem and solution here:

Hope this helps!

Best regards,

1 Like

Hello mc21,

thank you for your advice. On my windows OS the sp flash tool do nothing after i followed the instruction in selecting the MT6763_Android_scatter.txt and clicking download. So i do not know, when to plug in my GS 290. Do i need an authentication file and which? The tool changes display to inactive until i select stop. This without any output.

Do you have an idea, what i could do to reset to stock android.

Best regards


Hello Uccello,
After clicking download, you can insert the phone cable, or if already inserted remove it and insert again. It should start automatically.

I ran into the same issue when flashing a brand new GS290 with /e/OS 0.19. When these “bluetooth keeps stopping” messages appear on screen repeatedly here are the steps (I followed) to get things right:

  • Go to the GS290 revert to stock rom page and follow the instructions there to get Android 10 stock rom installed
  • Start the phone and update several times until May 2021 update is running
  • Do not execute any further updates!
  • Use easy-installer to flash /e/OS. Remember not do any further system updates, even if easy-installer tells you so.
  • Have fun with your new installation and don’t forget to donate if you are able to.

kind regards

1 Like

Hello Christian,
thank you very much for your post. My problem is, the sp flash tool give no reaction like i wrote to mc21 4 days ago. Without an advice in using this tool i am unable to reset my phone. It is a pitty: The great work of the eelo team (great design, responsive and battery consumtion for now is very low) is not usable for me.

Hello Shenol,
thank you very much for your post. In my case it makes no difference if a phone is connected or not. I assume the tool needs an authentication file. But there is no error message asking for that. Without an advice how to use the sp flash tool i am unable to reset my phone.

Hello Uccello,

you could try the following steps to find and fix the issue:

1: is the GS290 correctly configured to receive commands and images via usb?
(Android in developer mode (7x click on build), Android debugging enabled, Default USB configuration: USB file transfer enabled)

2: is the GS290 in fastboot mode?
(phone off, then vol+ plus power to start into a tiny boot-menu on the phone screen, choose fastboot-mode using vol+ and then start it using vol-)

3: check the complete connection between PC and GS290 (hardware- and softwarelevel, incl USB-C-cable) using adb or fastboot command before continuing with SPFlashtool:
e.g. try: C:<complete path to fastboot.exe>\fastboot -v devices -l
or C:<complete path to fastboot.exe>\adb devices -l
(both commands don’t change anything, they just show the connection status: some lines with “GS290” stating that the phone has been recognized)

4: do you have the right adb/fastboot-versions in use? (should be r30-tools, not r31)
check: C:<complete path to adb.exe>\adb help
this should show a long option list beginning with:
Android Debug Bridge version 1.0.41
Version 30.0.5-6877874

check C:<complete path to fastboot.exe>\fastboot --version
→ fastboot version 30.0.5-6877874

5: if SPFlashtool doesn’t work, it might be an installation issue with the driver

(this batch contains an unnecessary Windows-version-check that leads to an installation-error, solution:
insertion of a line:

set osrecognized=1

below the 7 for…do…-lines to make the batch running through even if no Windows-version has been identified)
Now the batch can run to install the driver.

Now try again to use SPFlashtool.

Good luck!

Best regards, mc21

1 Like

Hello Uccello,

to get SP Flah Tool to work, i had to do the following:

Disconnect the phone from PC.
Turn off your phone.
Click Download.
Connect the turned off phone with USB cable to PC.

Then it worked for me.

I had the same two problems as Uccello (no wifi, flashtool didn’t start). I’m running Win10 with latest updates and the GS290 had an update from late 21 (nov or dec I think) when I ran into the problems.

I could solve them with your help, so I wanna thank you and share my solutions in short:

Problem 1: No Wlan, no Bluetooth, Bluetooth error message

  • The instructions of chrisphl worked fine
  • Update until the 2021-05-13 update
  • Rerun easy-installer

I think this should be updated in the installation instructions for the GS290!!! There’s a big red box saying “Caution: Before following these instructions please ensure that the device is on the latest Android Stock firmware…”
I think this sentence will cause some more people ending in this thread :index_pointing_at_the_viewer: :stuck_out_tongue_winking_eye: :raised_back_of_hand:

Problem 2: Could not revert stock rom because SP flashtool refused to start

  • Settings: Android in developer mode (7x click on build), Android debugging enabled, Default USB configuration: USB file transfer enabled
  • Plug out and switch off phone
  • DON’T use the mediatek driver from the link of mc21 and chrisphl but install this one! (it corresponds to this manual on androidgreek)
  • Start flash tool, select scatter.txt file, press download
  • When you connect your turned off GS290 now, the flashing process should start immediately

Maybe the drivers in the “Reverting to stock ROM on the GS290 for Windows users” guide should be updated? I didn’t compare the packages, just tried them out and it worked well with the package from androidgreek.

Thank you for the information. To get the attention of devs to this issue someone has to report an issue.

I suggested this in this post #76 GS290 Documentation Suggestions but the resulting bug report GS290: after installing /e/OS, BT and WiFi do not work by @sugit is filed in a location where not found in this search Gitlab Issues ~GS290

1 Like

I had the same problem with the SP Flash Tool.
I used the mediatek driver from the link of mc21 and chrisphl.
To get the download started after click on download button, I had to press both loudness buttons (+/-) simultaneosly and then plug in the device. The download of the stock rom then started automatically.

1 Like


thanks a lot for your instructions! I’ll be straightforward, I’m really struggling to revert to stock ROM - no experience whatsoever.
So this might be the first of a couple of very basic questions that I will have to ask: how do I find the “driver-installation-batch”, what’s its name? Any help would be much appreciated.

Best regards

A file within the driver archive you downloaded, with .bat or .cmd extension.

1 Like

Hello ns4w,

I’m sorry for the late answer. When you download the driver, you’ll receive a zip-file “Driver_Auto_Installer_”. After unpacking it, you’ll see a directory with the same name, it contains a file “Install.bat”.

Good luck!

Best regards,

1 Like