GS290 Updated to v1.0 Issues

Hello all,
From the last update of my gigaset to v1.0 I noticed a high battery drain, now I’m around 3 days with a full battery and no special tasks done.
From this morning the screen is totally gone, it types what it wants several times with no reason, launches the icon next where I’m typing…switch off alone when using the phone and so on…
So no more possible to use the phone.

Already few reboots done and same issue, and launch of the phone introducing the code is also really difficult (it types several times the keys).

My last action of yesterday has been to switch off the google trackers from Advanced Privacy… (I’m VERY frustrated to see “google” on my phone… But I do not see any link with the screen issues.)

Did someone else noticed some stranges behaviours with the gs290? Or do you know what should I verify to solve the screen problem?
Thank you all!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Ok, after some additionatal tests it seems the issue I have with the screen appears when the phone is charging (Usb cable or with Wireless charging).
Removing the phone from the charging status the screen react normally…

1 Like

Note that there is a bunch of reports regarding perfs and battery here:

I experience battery drain on my GS290.
Privacy on


1 Like

Hi! thanks for it.
Indeed the battery issues are the same of the one spotted in the other post.
I was more worried about the issues with the screen, it seems to be also linked in a way to the the battery drain, at least for the resolution (bliss launcher cache + reboot)
Issues are now partially resolved… but not fully

Hi, Thank you for your additional confirmation.
The tips spotted in the main discussion solved in part the battery drain but appeared back again on my phone…
I see a better usage of the battery with Privacy off, but cannot quantity it for the moment
Fingers crossed :slight_smile:

Hi everyone
My GS290 was working fine for the first few days, but when i tried to install updates the app lounge stopped working. Now the app lounge doesn’t open at all. I rebooted once but that hasn’t made any difference. I haven’t had any other issues though.

Yes, this is another issue on a long list…

App lounge doesn’t launch at all for me too. But it can be launched fine from the guest user (where no /e/ account has been set).

I saw a post somewhere (can’t find the topic anymore :frowning: ) where it was found out that supposedly after upgrading to 1.0 a file would try to run in a continuous loop, and because of that the device would get hot and the battery would drain quickly.

Hi !
Updated from 0.23 to 1 on FP4.
No issue as of yersteday aside from some fiddling when navigating with privacy enabled. (Having privacy settings as an icon in the drop down menu is really great ! But it doesn’t serve to dis/enable it for now.)

But today the App Lounge began to crash as well. No amount of data or cache deletion or reboot made it work. I reckon it’s a network issue, but I’m just here to notify this issue as well anyway.

Good luck debugging all these problems, and thank you. :+1:

Thanks for the info, let’s hope a fix shortly for the battery issue.

On my device, I noticed it was hot only when charging, and normal temperature when not charging.
Also, the Airplane mode (night) seems to drain more battery compared to when in use during the day, because the battery percentage lost is huge.

Just my own idea, but it seems the battery charge is not realistic. Before, the phone was charging on twice the time it needs now, that’s why I think something is wrongly calculated (and drops twice faster, like doing only a half charge).
And to be mentionned, the charging time remaining (appearing on the screen) increase during the charge.
Bad calibration of the battery? That’s why I tried to charge phone switched off, no overheat and a little improvement…

The issue with the touchscreen disappeared but other bugs appeared in the meantime.
Let’s wait for a fix

1 Like

Maybe it’s because your IP address is obfuscated, which can slow down the network connection.

No no, I did try without it of course. The app crashes the same way.

Does App Lounge works fine on your Guest account?

Too bad :frowning: It worked for me after two tries…

Seems like it’s fixed now without any specific input from my part. It kinda conccurs to my belief it’s a network problem the client can’t handle.

Same thing for me, crash of lounge app on GS 290.

An other strange behavior is the localisation of my phone witch is in Indonesia.
This is on two navigation apps.

After reading your message I tried again, and the pop-up error message continued to appear (also after restart).

Then, I was trying to take a printscreen of the error, and really funny… it solved the App Lounge issue!
On some phones you can take a screenshot by swiping the edge of your hand across the screen from one side to the other. But this doesn’t works on the gs290… :wink:

Now I have back the App Lounge working… :grinning:

You can set the location of Advanced Privacy to be the real one instead of a fake one (2nd menu page)