Help Please - galaxy Note 3 hlte

OEM unlock does not appear on my phone. I tried a ‘fix’ I found online which did not help, also a factory reset.
Can anyone advise me if there is a way to restore this option on my phone or is it OK to proceed to try to install /e/ without OEM Unlock?

Thank you.

Hi @dsimpson have you tried updating your phone to the latest stock version as suggested here

Yes, it’s all right. The OEM Unlock is generally available from Android 5.0 and later - but this option is not implemented on every Samsung device: neither is it on the N9005.

Normally, you’ll find this option “OEM Unlock” in the “Developer options” between “Bluetooth HCI Snoop Log” and “Running services” .

Thank you, archje. I will carry on and give it a go.

Yeah, do it. It’s not tricky.

See also → Samsung Galaxy Note 3 LTE SM-N9005 with S-Pen

No luck I’m afraid.
After step 4 in the Pre for Installation instructions, I enter Boot Mode.
When I insert the USB cable to the phone, nothing happens. The computer doesn’t see the phone. I get this on the phone:

Yes, it tells my my system is up to date.

This Samsung’s (Odin) Download-Modus.

At this point I connect the N9005 to my Windows PC & Samsung Odin3 and install the twrp-3.3.1-0-hlte.img.tar

Am I right in assuming that you work with Linux and Heimdall?

I am using Linux and Heimdall. I have tested Heimdall with ‘heimdall version’ and it seems to work.

When I have the phone running as normal, the Linux PC recognises it via my USB cable.

That means the Android Debug Bridge (ADB) on Linux works correctly?

Yes archje. When I run ‘ADB version’ I get a working response.

I appreciate you taking time to help me. This is my first attempt to do this with a phone.

You can do it! Just be patient.

Was your N9005 detected by Heimdall (Heimdall Frontend ~ button “Detect”)?

Did you create the device’s own PIT file und saved it? (Heimdall Frontend ~ button "Save As …)

Heimdall-Frontend (under Utilities tab) just says ‘device-detected’.

I am not sure (don’t understand) about creating pit files. When I run ‘heimdall print-pit’ in the CLI, it shows a USB error.

Sorry @dsimpson, I’m not fit in heimdall on Linux. I just got the error message:

Initialising connection...
Detecting device...
ERROR: Failed to access device. libusb error: -12

I’ve to think. Usually use the uncomplicated Odin3.

See also → Flashing Heimdall Firmware Package with Heimdall Frontend

Which Firmware package am I to Flash at this stage? H-Frontend is set to find .tar.gz files whereas I have downloaded .zip files. I have unzipped the files into folders but Frontend does’nt see them. I will look again to see if there are other Download options. I am using Linux Mint.

Are you sure of your câble ?

Yes Piero. When I connect directly to the Laptop, Linux (Mint) see the phone. Also, when I use the CLI to run ADB ‘devices’ I get a response. Once I put the phone into ‘Download Mode’, it is at that point I cannot get the laptop and phone to connect.

Do you see “Developer options” ?
Is your device have an USB défaut setting like MTP or SHARE ?
I think you know you have to boot into download mode and THEN connect to the PC.
Do you have built your own Heimdall ? And tried with it ? That’s how i had success with my s7edge and s4mini.

This is Android 9 parameters menu :