Help updating to S I'm stuck with Sake ZenFone 8

I bought the cell phone with A12 (a half year ago)
I downgrade to A11 because this was necessary vor installing e

I followed this: Install /e/OS on a ASUS ZenFone 8 - “sake” for installing S and 1.5
but I did something wrong … I went to a12 first
and then followed the instructions, flashing vendor_boot, recovery = OK with recovery , reset and update , adb sideload…all = ok but

Signature verification failed error 21
E:Current SPL: 2022-11-05
Target SPL:22-10-05 this is considered a downgrade
E: denying OTA because it’s SPL downgrade

after reboot ==> bootloader

help please.

and you used ?

to me it seems you have Android “parity” already with stock on A12 and /e/ S (A12), but stockrom is still farther ahead

not sure about the (is it patchlevel date?) of the e-1.6-s spl, but I’d assume it to be farther ahead but can be wrong so you’d need to wait for a newer /e/ build or reset vbmeta… but never faced this so my knowledge is lacking on this

No I didn’t use 1.6
I will try
otherwise switch to Lineagesos ?

Which vendor_boot ?


I guess one that is a few days before the build timestamp on the /e/ zip… so 20221125 ?

did you go through the other thread you commented at and those 2 gitlab issues ( ) on sake?

I’ve got not sake so I can’t help much

I tried used but no succes
same issue

LineageOS is running e won’t

vs ?

yes the latest 20221202 nightly
If I have no solution today or tommorow with e , I will install microg for Lineageos

… but did you also use the

vendor_boot.img from the directory named with the latest date.

yes ofcourse always the latest:

I will try tommorow morning again.
I’m now on A12 and LOS

This is the latest vendor_boot I think:
And I will flash e 1.6 recovery and /e/

You may try to use the oldest vendor_boot.img available, instead of the latest.
Last week I tried with the latest and I had the same error “downgrade, aborting”
But with an older one (2022/11/04 for me I think), I had warnings but I still have the choice to overpass them and start the installation

I tried the last and penultimate vendor_boot without success
I also tried the vendor from half a year ago (with A11) and boom then it does work /e/ 1.6 is running.
Those were fearful hours again
thanks everyone and especially jacquarg with the solution

1 Like

Hey everyone
I’m stuck in the same situation. Latest eOS does not install because it is considered as downgrade. Before trying to install I had upgraded to the latest release of Asus Android 12 Version (WW-31.1010.0411.138).
After several failed attempts to install eOS ( I’ve tried latest release of LineageOS, which worked fine.
Then reinstalled Asus Android 12 (Version WW-31.1010.0410.61) with Android13-Beta-OptOut-Tool from Asus.
Joyfully retried installation of eOS, as I assumed my Android version is now old enough for eOS not to be considered as downgrade. Was a bit bummed out, when getting the same error message.
Unfortunately the oldest vendor_boot.img is not from Nov 19th, which doesn’t solve the issue.
Any hints? Where can I find an older vendor_boot.img? Is there any other solution?
Any support is appreciated!
Many thanks!

I will post my boot.img from a half year ago

try this link

vendor_boot.img from july , its on my server. let me know if you get on my server. (Have a firewall with geolocation…) otherwise I’ll open it up a bit

Many thanks!
Not working yet, connection is timing out.

1 Like

or Dropbox - vendor_boot.img - Simplify your life

Excellent. Thanks so much. Will try later and revert!

That worked nicely. Did you also get the message that signature verification failed?
Thanks again for sharing the vendor_boot!