Hotspot turns itself off

When I turn on my hotspot it always turna itself off after a few seconds.

Any idea what I can do?

I am running 1.0.1 on a FP3+.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


if there are no connected clients the Hotspot disables itself automatically - but more like after minutes. If you can attach adb logcat, there surely will be a message explaining it

there’s a bug ticket for this at Hotspot issue (#5699) · Issues · e / Backlog · GitLab

1 Like

Yes, I’m also facing the same issue on my FP3 (not FP3+) with the latest OS version (1.0-20220622198552).

Since the OS update the hotspot functionality refuses to activate. The button lights up blue for a few seconds when I press it, then goes back to grey. At no point do other devices appear to recognise the activation of a hotspot, even for a second.

This is a huge issue for my lifestyle, so hopefully will be resolved soon. Thanks for linking the bug ticket @tcecyk, which gives hope. If I could I’d add the info there that this also applies to FP3 users (or at least this one!), but I don’t have the requisite access.

1 Like

Also note the below from another thread (thanks for the research @AnotherElk!):

Same issue here with FP3 and latest update.
In case, it works fine if you use the USB connection (might be useful in the mean-time).


Same here, FP3+ and the latest update

1 Like

This sounds like a very helpful workaround, thank you. Can anyone explain how to do it?

Not having used USB tethering before I followed online instructions - I connected the phone/laptop by USB, selected “USB tethering” from the list of “Use USB for…” connection options, and turned on USB tethering in the hotspot options.

That gave a notification on my phone “Tethering or hotspot active. Tap to set up”, but when I tap, the only remaining option there is to turn on the hotspot. And unfortunately it still suffers the same problem that we are discussing in this thread.

Is there something I’m missing? Or something I need to do at the laptop end to connect to the tethering? (perhaps the issue is that my laptop is running Windows, possibly unlike @Wichtc91’s device?)

In my case, i just have to plug my phone to my computer (Windows 10) and then in Parameters go to “Networks and internet” → “Access point and connection sharing” (don’t know the exact name in English since mine is set to French) and finally just turn on “USB tethering”.

Once done, it should simply work you shouldn’t have to define anything else I believe.

1 Like

Thanks for the much-appreciated reply @Wichtc91.

Hm, ok… I’m on Windows 10 too, so suspect I’m missing something very basic here :smile: I’ll keep playing around.

To clarify, are you talking about switching on “USB tethering” on your Fairphone (which I’ve done) or on your laptop (where I haven’t yet found any such option)?

I’ll also try a different USB cable - I’m using one of the Fairphone store’s cables, and they always seem to charge slowly, so maybe that’s the issue.

Mhhh that’s weird, I am using the same USB cable as you do.
Yes I turn on “USB tethering” on my fairphone and then my laptop basically detects it and establish the connection automatically.

Still, I set up my USB connection as “File Transfer”, maybe that’s the difference? (so that I can recognize and access the files in Windows Explorer)

1 Like

It looks as though it’s an issue with my laptop’s USB drivers. In Device Manager I uninstalled the USB Root Hub and restarted the laptop to make it reinstall.

After that when I tried tethering again Windows 10 set up the “Remote NDIS based Internet Sharing Device” for the first time and I was able to tether successfully.

Unfortunately on disconnecting/reconnecting the USB connection it didn’t work the second time! So maybe I’ll have to uninstall/reinstall those drivers every time?? Anyway, I’m very grateful for the pointer towards the workaround, and will proceed to wrestling with my laptop’s drivers until the /e/OS issue is fixed and I can get back to smooth wireless hotspotting :slightly_smiling_face:

Thanks again @Wichtc91!

1 Like

Hey there, never had any config to do on W10, as all you need to do is set up your smartphone with the proper cable. Experience showed me that using a data transfer compatible cable is enough, as your internet traffic will be going through it.
Now, the most important thing is to connect your FP to your computer, then make sure you have access to the wifi hotspot in your shortcuts from status bar, long press it to enter network sharing options, and switch on USB tethering.
Another option is to edit your shortcut list and add the icon for USB tethering.
Hope this was clear and helpfull.

1 Like

Thanks for the advice @cyril.paulin. Yes, after sorting out the drivers on my PC it’s been straightforward.

For anyone else facing similar challenges, the other thing that seemed to help was turning off the “Allow clients to use VPNs” option in my FP3’s Hotspot and Tethering options. Despite the fact that I am in fact using a VPN on my laptop, turning this option off seemed to get things flowing smoothly. Don’t ask me why, but definitely worth a shot if you’re struggling!

I look forward to getting back to wireless hotspotting with the next /e/OS update :crossed_fingers:

Thanks issue here with the last 1.0 update on my FP3.

Working with the USB tethering in the mean time.

I can’t switch back to previous version because there were some others issues : camera fatal failure almost every time I tried to use it, slow interface (very sow to go and come back from idle state).

I can confirm the same on FP3+. Hotspot turns of after a second or two, tethered network works fine.

1 Like

Confirming that /e/OS update 1.1-20220705201319 has fixed the hotspot issue on my FP3.

Thanks to all those who contributed to developing and rolling this out :smiling_face_with_three_hearts:


Can also confirm that v1.1 on my FP3+ fixed the hotspot issue.


Hotspot issue not fixed, still present for me with 1.1-q-20220629200240-dev-FP3 *.
Just as a heads-up for dev channel users. According to the GitLab issue, a 20220507 build would be needed for the fix, dev channel version of it is still pending.

* Settings - About phone - Android version (tap on it) - /e/ OS version (can be long-tapped and copied to clipboard since Android 10)

1 Like

Can also confirm that v1.1 on my FP3 fixed the hotspot issue.

Thanks for the works!