How to format SD card to make it writable

After the recent update, my SD card was corrupted (see SD card no longer working after update to 0.19).

I had to re-format the card, but it seems my choice of formatting it as “portable storage” was wrong, because apps cannot write to it.

How do I re-format it as “internal storage” (if that’s what is necessary to make it writable)? I simply cannot find an option to do so.

Would I be right in thinking there is stuff on your SD card?

The internal storage option was proposed to be dropped as it caused problems for many! I assume you have just suffered the “drop”.

I was able to extract everything off the SD card using an OTG drive.

As I had already suffered card writing issues, I then installed a brand new card as " external storage".

I have the stuff all backed up, so I can start from scratch. But after formatting as “portable storage” and copying all the contents back onto the card, for example OSMand can no longer write to the external storage, which is necessary to update the map data. In fact, it won’t even start because of this.

How can I make the SD card writable again?

So it seems the apps simply lost the right to write to SD card. However they crash before even asking for access.
Where can I configure SD card access for apps?

I think 2 things, it is not clear when you suffered “the drop”.

If portable internal storage is dropped and you try to reinsert a [sorry!, late edit,] "portable internal storage" card I don’t expect it to work! :slight_smile:

If you want to start again, I used a new card. You could attempt to make you corrupted card “Brand new”, (maybe Fat 32 on your PC). Ideally you would then format the card from the device, it should be possible from TWRP; from /e/ itself is available in first start wizard, someone else may be able to tell us if it is available elsewhere. (The only removable storage I ever threw away was once reported corrupted, so I didn’t get involved!)

Ok, quick summary of what happened so far:

  1. Updated to /e/ 0.19
  2. First reboot
  3. SD card reported corrupted. Offered to format as internal storage or portable storage
  4. Tried reboot, same result
  5. Inserted SD card into PC, copied content
  6. Formatted SD card as “portable storage” on the phone
  7. Inserted SD card into PC and uploaded all original data (but didn’t overwrite the few files files already existing on the card)
  8. Inserted card back into phone and tested → OSMand complained it couldn’t write, but didn’t ask for access. Simple file manager asked for write access which it previously had. My conclusion: Apps lost write access

Apps lost write access

Agreed … and the things you tried so far did not work!

I do believe you must start again as I already suggested! :slight_smile:

I think you mentioned all the things that might be complications. Seems they are! :frowning:

For anyone with the same issue: The re-format changed the root folder name of the card. So all paths were invalid.

Unless 0.19 reintroduced the “internal storage” option (and I haven’t found anything hinting that it did), I would assume this is still the status quo (bullet point 4):

I am using latest OS update 1.1-20220627199797. My Samsung 32Gb SD card is not recognised by the phone in any way (I can’t actually remember if it was in previous versions). I have no response from it when insert into laptop via an SD adapter (I know the adapter does work as I have used it with another mini SD card). Does this mean the card is corrupted or not useable in some way? Is there a way of getting the phone to detect that a card is present? Can I format it on the phone?