[HOWTO] Backup and Restore Data on Android Devices

@petefoth started an enlightening conversation coverig this very topic, for which i have gone back to heart-thank all participants
Thank you!

I don’t understand, why SeedVault is not in /e/, because it is in Lineage already included. And as far as I know, this is the base for /e/

That doesn’t make 100% of LineageOS a part of /e/OS. You can take something as a base and change it so that things being in the base aren’t there anymore or things working for the base don’t work anymore.
/e/OS is based on LineageOS, but it isn’t simply LineageOS + some goodies … https://doc.e.foundation/what-s-e, https://e.foundation/wp-content/uploads/2020/09/e-state-of-degooglisation.pdf.

1 Like

Actually it is in /e/, but it’s not yet visible in the phone UI. This thread describes how you can use it via `adb’ on a connected computer

Also, if you have access to a linux computer, then this post suggests a possible alternative backup solution


In /e/OS v1.0 R (on Teracube) I see Seedvault is present. Is it functional in this case?

Haven’t tried it yet. Tried to use it once or twice on another phone and ROM. Didn’t care for its limitations regarding restoration but maybe I’ll take another look.

EDIT: I tried to crop this pic but the Gallery app essentially gets stuck processing. That’s not cool.

I am in the process of moving my devices away from /e/OS to LineageOS for microG. As part of this process I did quite a lot of work backing up my user-installed apps and my setting, then restoring / migrating them to new ROMs and to different devices. In fact, I didn’t need the backups: once I had the new ROMs built correctly, I was able to successfully ‘dirty flash’ them over my existing custom /e/OS builds. But I tried anyway, to get some up-to-date experience of which solutions work best.


  1. TWRP backup of data partition
    • All user installed apps, with all their data. Ignores the ‘Backup not allowed’ flag
    • ‘All or nothing’ not possible to restore individual apps
    • Successfully restored / migrated: to a new ROM on same device, to different devices (by copying the backup from one device to another)
  2. Android Backup and Restore Tools (ABRT)
    • Most apps and most of their data backed up. Ignores the ‘Backup not allowed’ flag
    • Some apps lose their data, particularly those that store acount data in Account Manager. For these apps, you will need to re-enter account details in the app, or create new accounts in Account Manager
    • Some apps keep stopping after restore / migrate. Can be fixed by clearing storage. Affected apps for me are: OS Maps, Element
    • Can restore specific apps, without affecting other apps
  3. SeedVault
    • Respects the ‘Backup not allowed’ flag, so some apps will not be backed up at all, or will be backed up but with no data. You will need to install them, and set them up from scratch. These include BBC Sounds, News, Sport & Weather, Ebay, Element, WhatsApp, Garmin Connect, Twidere, Messenger, Magic Earth, OpenKeychain, Telegram FOSS
    • Does not backup settings for some apps (e.g. Lawnchair)
    • Some apps which claim to have been restored, don’t actually start (BRS Golf, XDA Forums)


  • If it works for your use case, then TWRP backup / restore of data partition is the most effective at duplicating your current setup on your new ROM or your new device. (In this case, there’s a good chance that ‘dirty flashing’ will also work, and the backup won’t be needed. Worth doing though, just in case :slight_smile:)
  • If you have a computer (or a VM) running Linux, and your device / ROM supports rooted debugging (i.e. it’s not a stable /e/OS build), then ABRT is nearly as good. It has the advantage of working with individual apps rather than with the entire data partition
  • SeedVault is really limited, and only fit for use if no other alternative exists for your ROM / device. After restoring / migrating, you will need to test the apps that claim to have been backed up, an reinstall any that don’t actually work

Thanks for this complete review ! :slight_smile:

AFAIK installing TWRP on the phone does wipe all data.
How did you solve that?

It hasn’t been pointed out clearly enough, but it turns out that you can boot TWRP with fastboot, but you shouldn’t install it on devices like FP3.

Installing TWRP doesn’t wipe user data.
Unlocking the bootloader does, if you need to unlock it to install TWRP, which isn’t necessarily the case (if the bootloader already is left unlocked or can’t be locked).

In general, just refer and stick to the documentation at twrp.me for a specific device to know the TWRP proceedings on this device.

1 Like

So, just booting TWRP into fastboot mode on my FP3 gives the opportunity to backup without installing, if I understand the advice here.
Is that correct?

See the reply from @AnotherElk

All of my phones have TWRP installed on the recovery partition. More recent phones apparently d things differently, but I know very little about that :slight_smile:

Yes. But …

hooray. Just wiped my phone, trying to flash twrp. I knew I should save my pictures first, but I thought I will backup my pictures afterwards, bc I’m just trying to install the Backupstuff. Very pissed right now.

Why does this Tutorial not start with, “you’ll wipe your data if you try to flash TWRP?

I guess because

  • this isn’t true on every device.
  • on devices where true would need active running of wipe command by user or user consent to wipe, as far as I understand. (Or does locking/unlocking the bootloader not ask for consent for the included factory reset? I don’t remember, unfortunately.)
  • because until now apparently nobody added something like this to the tutorial. It’s a Wiki post, feel free to, “Edit” button at the bottom right of the tutorial post.

Because I have never known installing TWRP to cause loss of data. Unlocking bootloader will cause loss of data, but that is not covered by this tutorial.

What steps did you follow to flash TWRP. What device are you using?

Files I copied from TWRP MTP mode all got the same timestamp something in 1970 - unusable for backup of only changed files - like I do with FreeFileSync with device connected via USB
I got twrp-installer-3.5.2_9-0-FP3 installed

actually the only reliable tool I’ve got is Titanium - up till now only Signal didn’t work after recovering

Interesting. I can confirm that the current TWRP 3.6.2_9-0-FP3 using MTP offers no change timestamps. I’m using Windows 11 Pro on the computer side.

And apparently this isn’t entirely new, although seemingly dependent on the device or on the computer OS … MTP not prividing change timestamps · Issue #1065 · TeamWin/Team-Win-Recovery-Project · GitHub

I just asked the TWRP maintainer for Fairphone 3/3+ … let’s see.

FreeFileSync got that working reliably? There were a bunch of MTP problems reported in the past.
Anyway, doing this sync with /e/OS booted is not an option (since you mentioned Titanium)? The timestamps are there when /e/OS does MTP.

1 Like

I must admit, I’m not shure if it worked with my /e/-installation.
It works with my Lineage-install. I’m using it regularly to synchronize files between my FP3 and Win10(pro)-Computer. Should work for /e/ just the same - a lineage-fork - isn’t it :wink:
actual IMG-e-1.2-r-20220727206630-dev-FP3 I tested bases on lineage 18.1
I actually use latest 18.1-package

Thanks for your answer. Stepped away from the forum for some days :slight_smile: Aehm. I do not know exactly anymore which steps I followed, but mostly internal documentation about TWRP and unlocking the bootloader. Maybe XDA too. Should have read this first “✏ FP3: unlock the bootloader - Guides - Fairphone Community Forum

I’m using the Fairphone 3.

So, used the wipe to flash Android 11. But now my build-number seems suspect to me: “eng.root (…) dev-keys” is not what I wanted. Bootloader is locked, but SafetyNet is not working anymore, CTS profile does not match.