[HOWTO] build eOS in old fashioned way with breakfast -- now with interactive script

they are 4 and when I execute your command they are all regularly downloaded

https://gitlab.e.foundation/e/os/android.git” is in your 161.sh I downloaded. Should I have perhaps replaced this quoted above with that you sent to me in a second moment? If so, I’m very sorry but don’t forget that I’m a newbie and that I’m learning step by step, mistake after mistake, and what is obvious for you, it is not for me :sweat_smile:
I really appreciate your help …

That are the main sources. If you want go step by step, use the howto (first post) after all about the scripts. There is a step by step tutorial, which you can go via terminal.

Already done without success. I’m sorry for the time you lost for me, harvey186, but I have to give up! unfortunately I haven’t catch the different phases of the build process so I can’t understand and tie the different parts of the code: without fully understand the process, I can’t correct my actions. I did several attempts, trying manually and/or using the 161.sh file, and I’m tired now. I don’t exclude a future new attempt but for now I leave…
Thank you so much anyway!

Have you seen this [UNOFFICIAL BUILD] Unofficial Pi/e/ Community Build for Samsung Galaxy S5 mini - kminilte (G800F/G800M/G800Y)

1 Like

Hi, I’m trying to build with this method now on Debian LXQt, minimal installation.

The fisrt try has failed just after the repo has been synced because of a missing package. I will edit this post if there are more dependancies.

New dependancies to add in the run_once.sh script :

In the 161.sh script, “kein repo sync” should be “no repo sync”.

Ok, if all running on your debian I will add all

1 Like

For the first two errors I was able to understand and fix the issue but for the third try I need help please.

I found this, looks like there is a solution but I don’t understand it.

By the way, why there isn’t openjdk-11-jdk in your run_once.sh script since it’s necessary to build Pie (according to the link to the LineageOS wiki you gave me in my topic) ? I installed it.

Edit : could it be related to the fact I changed the Region from France to United Kingdom just before building ? (In order to provide you logs in english)

You may be facing a LOCALE configuration problem.
See line #2857, and https://www.cyberciti.biz/faq/perl-warning-setting-locale-failed-in-debian-ubuntu/
Don’t know if it’s the root cause, but cannot hurt :wink:

Ok thank you, that’s it then :slight_smile:

If it can help, In my building VM I have “en_US.UTF-8 UTF-8” activated in /etc/locale.gen
And here is the output of locale command :


Thanks. I just started again a few minutes ago with “fr_FR.UTF-8 UTF-8”, it should be all right.

I think I have to add, that the run_once.sh is for ubuntu based systems.
All your missing things are debian related.

Yes you were on Mint, but anyway I think it can be added because it will be useful for those on Debian and it won’t do anything for those on Ubuntu.

I’m at 8666/9004, will tell you soon if another dependencie exists :slight_smile:

1 Like

It failed near the end, for the same reasons that my last two tries with docker :

Exception in thread "main" java.lang.OutOfMemoryError: Java heap space LineageOS

I think I found good topics here and here about this issue and I will be able to solve it. That’s at this moment I’m really glad the build will resume where it failed :slight_smile:

Will retry as soon as the shared computer is available.

I don’t know if it’s because I’m idiot or extrimely tired but I didn’t succeed to solve this issue.

So I can’t finish the few steps remaining, I’m sure this issue is the last one to solve in order to finish the build.

I tried to add “JACK_SERVER_VM_ARGUMENTS=”-Dfile.encoding=UTF-8 -XX:+TieredCompilation -Xmx1024m" in /home/anonyme/.jack-settings
I tried to add “export JACK_SERVER_VM_ARGUMENTS=”-Dfile.encoding=UTF-8 -XX:+TieredCompilation -Xmx1024m" in the 161.sh file after the “export CCACHE_SIZE=50G”,
and I tried to just write “export JACK_SERVER_VM_ARGUMENTS=”-Dfile.encoding=UTF-8 -XX:+TieredCompilation -Xmx1024m" in the terminal.

I also tried with “-Xmx512m”, but it doesn’t work.

In the topics I mentionned above, they also talk about the number of jack process running at the same time, and that I needed to decrease the number of jack server/process, but I don’t find where to do so.

No, No, first time building is a pain. So never give up :wink:

in some build scripts we will find this

# Provide a default JACK configuration in order to avoid out-of-memory issues
export ANDROID_JACK_VM_ARGS="-Dfile.encoding=UTF-8 -XX:+TieredCompilation -Xmx4G"

I can add it to my script if it will help building a low memory machines

by the way, after failing you can use
the export command direct in terminal and you can start new build with
‘brunch DeviceName’

no need for calling the 161.sh again

If you have closed the terminal, you can start with ‘source build/envsetup.sh’ in you root build directory
‘brunch DeviceName’

1 Like

I tried to run it in the terminal and after 161.sh, and I tried to directly put the line in 161.sh but same resultats… (For now I will call 161.sh each time, I don’t want to deal with multiple issues :yum:)

That’s it ! I found what’s working !

First, in the terminal I entered :
java -XshowSettings 2>&1 | grep Heap

This told me the recommended heap size, and it was “1.03G”.

Then in the 161.sh file, I added
export JAVA_TOOL_OPTIONS="-Xmx1g"
(and not “Xmx1.03g” because it doesn’t work)

under the line :
export CCACHE_SIZE=100G
(that I changed to 50G by the way)

I saved the modifications, and I ran the 161.sh scrip and no OutOfMemoryError anymore !

I will now test the build I made.

This script is just better than the docker method for everything, I don’t see one positive point for docker. Thank you a lot !

1 Like

Nice to here. I think theses changes are special for your low memory system. If I would change the script to this values I would slow down the build on other machines.

1 Like