[UNOFFICIAL BUILD] Unofficial Pi/e/ Community Build for Samsung Galaxy S5 mini - kminilte (G800F/G800M/G800Y)

I have build a Pi/e/ ROM for the Samsung Galaxy S5 mini - (G800F/G800M/G800Y) “Kminilte” , not for the G800H .
Before you proceed with the flashing and testing please read the warning given below very carefully

  • Please note this is a test build.
  • Please take a backup of your data before your proceed.
  • Coming from previous Android Versions i suggest you do a clean flash ( wipe system, data and cache)
  • Please report if you encounter bugs.

If you are Ok with these warnings then you can download the Pi/e/ image for the Samsung Galaxy S5 mini - (G800F/G800M/G800Y) “Kminilte” is available for download here
Feedback and comments are welcome.
This build was made with the sources of https://github.com/spookcity, thanks for these.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

2 Likes

@Chimpthepimp, thanks for investing your time. You’re really amazing(!)

If you don’t know what you could do in your spare time, build two new /e/ builds e-0.8-p-2020 for Samsung Galaxy Tab 2 7.0 … ;-\

is it espressowifi and espresso3g?

Our /e/ friends pjmbraet and piero use “espressowifi”, I still use the oldi but goodie “espresso3g” with LOS 14.1 …

1 Like

Hi Chimpthepimp,
thank you for the file you built; I have tried to install it by means of twrp but failed! The zip file seems corrupted TIMG_20200419_100500|375x500
Maybe I made some mistake…
Thank you

i couldn t try the build for myself yet, but sometimes these zip errors come from download errors, could you try to download it again?

the new downloaded file is named “kminilte.zip” while the first downloaded was generic “download.zip” so maybe was corrupted au you supposed.
The installation by means of twrp is successful but the screen is frozen at the initial image showing “Samsung Galaxy S5mini”. I tried wiping system, data, cache, and Dalvik before the installation and wiping Dalvik/Cache after, but no success: the screen remains frozen as said above :frowning:

1 Like

I have a S5 mini and would like to test the build. Is there any chance to go on? There are no files at the linked location.

Thank you very much.

I deleted the build from my server andam just about to do look for the error as I got my hands on an s5mini myself i will put it back up and ping you here once i get it working, should be just a matter of apllying the right patches :slight_smile:

OK, understood. If I can do anything supporting you (e.g. testing) just let me know.
Thanks a lot!

1 Like

a working build should be up at the same location as before in max 10 minutes :slight_smile: also @cellulosam

2 Likes

Hi Chimpthepimp, I’ve just installed your build and it works!!! :rofl:
Thank you so much!
I’ll try it with a sim card; for the moment, I note that SELinux is not working.

1 Like

I will test it when I am back from work. Is there any manual I can use? I only installed e on two S7…

if I can recommend a simple method, that I followed, is this (assuming that you already have TWRP installed and a SD card):

  • copy on the sd card the three files extracted from the zip file you downloaded from Chimpthepimp
  • from TWRP install the zip file (I had to format and wipe the precedent installation of a Lineage rom)

Yes depending on the file you download that is correct, if you downloaded just the rom zip without md5chesksum stuff no need to extract, only copy to sdcard, wipe everything (data, caches, system) except internal storage and sdcard, and then continue with flashing :slight_smile:
@cellulosam regarding the selinux, as i took spookcities lineage-16.0 sources and in these it is not working it won’t work in this build, fixing it would exceed my knowledge and capabilities by far :smiley:

WORKS. So far I see no problems: Camera ok, OpenLauncher ok, some apps installed and ok.
The device is for my son (e.g. to be able to video-call family members) - he is sooo happy!
THANK YOU SO MUCH!!!

1 Like

BTW: I followed this guide: https://doc.e.foundation/devices/klte/install

1 Like

Congratulations !.!
as I know it was not LineageOS supported…

1 Like

There’s something wrong with the audio, but I do not know if it is related to the build:

  • if I use the audio-recorder and hold the device like 0.5 m away from me the recorded track is loud and clear
  • If I use a headset and use messaging apps like jitsee.meet or wire same result
  • If I use the internal mic with the messaging apps WITHOUT hands-free everything is fine, too
  • BUT If I use handsfree the partners can’t hear me - incredibly low audio…

I had the idea that maybe the echo cancelling might cut my mic audio?

1 Like

i can t really replicate your failing scenario, as i don t use the s5 mini with a sim card so no possibility to make calls, but it seems my handsfree devices are all working with it… maybe you can test your hands-free device on another device, so that we kn ow that it works correctly…