[HOWTO] Import Gmail contacts into eCloud

Recently we had a user ask this question on the forum - How do I import my google contact into the eDrive. So thought it might be helpful to add a simple post on the importing process.

Step 1:
Log in to google contacts with your Gmail credentials. When Google contacts opens up on the Left side of the screen you would see a menu like this . Click the ‘More’ and you will see the ‘Export’ option

Step 2:
Select the vCard( for iOS contacts) option. eDrive works with this option. Export to a file on your desktop /laptop. The extension would be .vcf
Screenshot%20from%202019-03-18%2015-12-36

Step 3:
Login to eDrive as per the url given in the screen shot. Enter you username@e.email and password.
Note: Enter complete useriD@e.email
Screenshot%20from%202019-03-18%2015-13-39

Step 4:
On the top of the screen on eDrive you will see a menu bar like this. Choose the icon for ‘Contacts’
Screenshot%20from%202019-03-18%2015-14-14

Step 5:
On the lower part of the screen to the left you will see the Settings icon. Click on it and the text ‘Import into Contacts’ link appears
Screenshot%20from%202019-03-18%2015-28-57

Step 6:
Clicking on the ‘Import into Contacts’ link will open a window where you can browse and choose where you saved the .vcf file. Import it into the eDrive. You should see a small popup where it will show you the contacts being imported into the eDrive contact list.
You should be able to see the contacts in the eDrive list now.
Step 7:
If as a part of your /e/ ROM setup you have added this same /e/ account then the contacts you have added should show up in your phone after a couple of minutes. Remember this sync will take some time. So wait for it to happen.
You can add and remove contacts from the contacts app on your Phone or from eDrive and they should sync in both places after a short time.

I was able to import some of my contacts but others for some reason failed. I tried a second time and ended up with a duplicates. I cannot see how to delete an address book and start over again.

When I add the folder link that shows in the Contacts settings in ecloud.global to my NextCloud app on the desktop, it sees the folder as empty even though the web interface on ecloud.global shows a bunch of contacts.

Any suggestions welcome.

Thanks,

David

Okay. Belay that request. I fooled around with adding new address books and renaming the default address book and somehow a delete option appeared in the “…” menu and I was able to delete. Might be that you can’t delete your one and only address book.

Thanks for listening!

One more addendum, in case anyone else is working on this issue. The web interface available via https://e.email also offers a Contacts tab. It offers the possibility of importing a .vcf file (exported from Gmail) similar to the method available for the Contacts tab at https://eclould.global.

Also available in the https://e.email interface via the Settings :gear: button is an option to pull your email contacts from the https://ecloud.global instance with Remote Synchronization (CardDAV). Paste the link from http://ecloud.global - Contacts/Settings/{AddressBookName}…/CopyLink into the Remote Synchronization (CardDAV) dialogue and your contacts will be synchronized for both applications.

I’m not sure if this is the simplest solution but it seems to work.