[HOWTO] Installing Banking Apps

Hi,

in my case it is not working. Using samsung galaxy s4 mini. I could do every step from the instruction above until the check if Trust Root Access is Disabled. I cannot see the same menu as it is in the screenshot above.
I used the Magisk Beta Version 19.3. so the questions are:

  1. SaftyNetStatus of Magisk is failing (is this necessary ?)

  2. Where do I find “Trust” to ensure that root access is disabled ?

  3. When I try to open the DKB Tan2go app, it closes instant after the proceeding

Maybe you could support me with some help to fix these problems.

Thanks in advance

Hi, at first, I have tried DKB Tan2Go on 2 Xiaomi phones with e-pie. And … it works out of the box, no hacks needed.
Have you tried it complete without magisK installed ? Of not, remove magisK https://magiskroot.net/uninstall-magisk-module-twrp/

Now to your questions:

  1. SaftyNet will ALWAYS fail
  2. Trust you will find under ‘Security@location’
  3. It’s closing and starting web browser, or ? That’s because it has found magisK

And when you are using the DKB app I think you are a German guy, so we could also talk in German :wink:

I have tried DKB Tan2Go on 2 Xiaomi phones with e-pie

Hej, what’s e-pie?

Do I guess right ~ android 9 - Pie as a /e/ OS version?

My Samsung Galaxy S4 - “jfltexx” works “only” with e-0.7-n-

Can I also meet you in the german /e/ forum?

I want to try Tan2Go and Consorsbank SecurePlus in the next few days.

Servus

Servus, you can contact me in german forum or telegram group.

Regarding the app, try it on your noughat e version without root installed.

I have now the samsung s7 device in front on me as there is no google play where do I get the banking apps . The homepage of the bank shows only the google play link.


=> https://play.google.com/store/apps/details?id=at.oberbank.mbanking

The same for the other banks

any hint how to get these apps on /e/ phone?

You can install an additional App Store that loads apps from Google Play anonymously.
One option is Aurora and another is Yalp.
You find these in the /e/ Apps store.

I am not an expert, but it seems that these app stores coexist nicely with each other.

2 Likes

use aurora store for any g-play app

1 Like

cool. thanks to all for the tip with aurora store.

Yalp is out of service. No further development :woozy_face:

For the archive:

I’m now quite happy with aurora. I was able to install all banking apps I needed from aurora and they runs for now on /e/.

2 Likes

Tgx, good to know.but pls ket us all know which banking apps are working

Yalp store (fork) was updated in July and is available in Apps.

I’m using yalp as ‘backup’ ud Aurora isn’t working :wink:

But I want know the banking apps, not the store :wink:

Hi,

I’ve been using /e/ for some time now and tried to use it for my banking as well. Here come the “bad” news:

  • CIC app is working for account “check” : you can see your balance and “everything”. I did not try the transfer yet. BUT you cannot register the phone for “Mobile Confirmation” (“cannot connect to the server”): meaning you cannot buy anything on internet since the app doesn’t detect the transaction.
  • “Secure Sign” Crédit Suisse is working (double authentication in order to access the account on your computer) but when trying to connect to the account using the “Banking” app, a message “a technical error has occurred” appears

If anyone has a solution for CIC, I would be more than happy to hear it (I had to take one of my -very- old phone and install the app on it, not exactly ideal…). Maybe create a “virtual machine” inside my phone, which really reproduces a “non rooted” environment?

NB: CIC app doesn’t show any warning concerning Rooted phone (before and after MagisK), Crédit Suisse does (both before and after the MagisK installation)

PS: All application were installed using Aurora (and are up to date)

I didn’t use your apps, but the problems with the banks’ new TAN procedures (Payment Service Directive / PSD2) are similar.

I also tried @harvey186 hint …

Both apps are working properly so far.

It worked for a Citibank app

1 Like

Hi Harvey,
I have tried unsuccessfully the N26 bank software downloaded from Aurora.
Control on Magisk … SafetyNet successfull; ctsProfile:false, basicIntegrity:false.
Rootcheck: Root access properly installed
Busybox 1.30.1 installed on /sbin
I closed my N26 account after opening one month earlier.
What do you think? Have you others returns of experience?
I am interested to know your opinion. Thanks in advance.
Michel

Have you tried N26 app without root ? I have heard that it will work out of the box without any ‘hacks’

1 Like

Just succeeded to install and activate and use the banking app “com.bpb.mobilebanking.smartphone.prd”.
I could install it before but never got it in use really. This is how it worked: on a rooted phone have Aurora from F-Droid installed, go to “settings > Apps & notifications > All apps > microG Servics Core > disable and force stop MicroG”, go to the Aurora store to download the app as apk, go to “Files > Aurora” and install the apk. After that go into “settings > developer options” and disable root. Then activate and use the app.
Don’t forget never to use the banking app on the phone while it is rooted.

1 Like

Hi,

I use the CIC app, didn’t notice any problem with mobile phone registration.
I get notified on my phone when needed by CIC, and confirmation is working fine.

Did you try both mobile data network and WiFi ?

My phone is Xiaomi MiMix2 (chiron) running Oreo (official), registration at CIC was done last summer with latest build available at this time, and I re-checked notification today with latest build.

FYI : notification seems to use kind of “push” mechanism, maybe you can investigate this way ?