[HOWTO] Sync your contacts, calendar events, email, notes and tasks to /e/

Hi! To remove your Google account from your device, perform the following steps:

Oreo: Go to System Settings > Users & accounts > [your Google account] > Remove account.

Nougat: Go to System Settings > Accounts > Google > [your Google account] > 3 dot menu > Remove account.

okay thanks for the further details. I would prefer doing this manually, so that I can use app-specific passwords and not have a third-party app with access to my account (think for instance in the context of using /e/ devices in a work environment).

the “manual” way of setting up the syncing seems to be:

thanks for the guidance!

FYI when I tried setting up the syncing with Account Manager, the notification I received said:

Your Google Account was just signed in to from a new Huawei HUAWEI P smart device.

I am signing into Account Manager from a Nexus 5X. so some bug there re: how /e/ devices identify.

1 Like

This is an issue with MicroG which identifies the device as something else. I think there may also be a bug about this already.

Excuse the really late reply but I don’t think it’s a microG bug. Remember we’re using a webview based on Bromite webview IIRC. As part of its privacy features the device and chromium webview version are masked, if you will. Supposed to make it harder to fingerprint (though some argue that reporting Chromium version as v71 would make it somewhat easier given that v74/v75 is current and widely used).
Even my standard Google-based ROMs using Bromite webview has Google thinking my LG phone is Samsung or my Motorola is a FIG-LX3, whatever that is. As long as a setup wizard or account manager uses webview to get device information, via the useragent, then that behavior is normal. Not a bug.

1 Like

Some questions:

  • When I do this, can I be sure that Google does not get a link to my new /e/-phone? I don’t want that!
  • Does this also sync the Tasks?
  • And what happens with Reminders ?
  • After this sync, how do I get rid of all my contacts and calendars and tasks at Google ?
  • And what if I want to get rid of my G-account altogether?


Hi @sugit for queries regarding the syncing part, just follow the steps as suggested by @nihar1024 in this thread.

Remember we have all been using Google for a long time. To remove it completely from your system it will take time as you may have shared that ID for a number of services - banks, government offices etc.Do not immediately delete the Google account unless you are sure you have deactivated all these services and links. If you have shared your new email ID with these services, wait for them to be operational before deleting your google ID.


Thanks for all the comments.
I see now that I put my question wrong. The question is:
How do I MOVE all my Google contacts, calendars/events and tasks to /e/ ?
(So that then I am free to remove them from Google.)


First, access your Google account and select Contacts then export all of them (CSV Google format - the file will be contacts.csv) and save it to your computer; next do the same to Calendar (the file will be like youraccount@gmail.com.ical.zip).

Access your /e/ account and import the files accordingly.

Once it’s done, it is safe to remove all itens from Calendar and Contacts from your Google account since you have a backup file that you can restore in case you change your mind.

1 Like

In case it’s useful to someone, you need to select the second “Google” after you press “Add account”. See screenshot:

The first “Google” will not work to sync contacts/calendar/etc.

1 Like

I added my google account, it is listed under accounts, but sync is off and i can not turn it on … on the first google Account option. Thanks @xavives

On the second “Google” option, it added my account, but no other model was added to my google device list on the dashboard. There was a hint, that it should added as another device?
But I saw on the activities tab:

  • New Login Unspecified Device - this must be the browser login
  • Account Manager access - for the device account manager

Sync seem to work now over some davdroid version. It looked very exactly like Davx integrated in the account process?

Thanks for the explanations! Sync works will with my OnePlus 3T phone! But … each time a ‘501’ https error; about https not used / permitted. I do work with DavDroid / SabreDav…

Account name: Recentelijk gecontacteerd (gaytan@e.email Ew)
Authority: com.android.contacts

Request{method=GET, url=https://ecloud.global/remote.php/dav/addressbooks/users/gaytan@e.email/z-app-generated–contactsinteraction–recent/6048, tags={}}

Response{protocol=http/1.1, code=501, message=Not Implemented, url=https://ecloud.global/remote.php/dav/addressbooks/users/gaytan@e.email/z-app-generated–contactsinteraction–recent/6048}

<?xml version="1.0" encoding="utf-8"?>

<d:error xmlns:d=“DAV:” xmlns:s=“sabre/dav”>


at.bitfire.dav4android.exception.HttpException: HTTP 501 Not Implemented
at at.bitfire.dav4android.DavResource.checkStatus(DavResource.kt:362)
at at.bitfire.dav4android.DavResource.checkStatus(DavResource.kt:338)
at at.bitfire.dav4android.DavResource.get(DavResource.kt:210)
at at.bitfire.davdroid.syncadapter.ContactsSyncManager$downloadRemote$1.invoke(ContactsSyncManager.kt:305)
at at.bitfire.davdroid.syncadapter.ContactsSyncManager$downloadRemote$1.invoke(ContactsSyncManager.kt:77)
at at.bitfire.davdroid.syncadapter.SyncManager.useRemote(SyncManager.kt:774)
at at.bitfire.davdroid.syncadapter.ContactsSyncManager.downloadRemote(ContactsSyncManager.kt:304)
at at.bitfire.davdroid.syncadapter.SyncManager$syncRemote$1$1.run(SyncManager.kt:438)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:462)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
at java.lang.Thread.run(Thread.java:923)

Package: com.thehelm.sync
Version: 2.0.6-ose (251) from 7 dec. 2018
Installed from: cm.aptoide.pt
JB Workaround installed: no

CONNECTIVITY (at the moment)
Active connection: WiFi, CONNECTED

Power saving disabled: yes
android.permission.READ_CONTACTS permission: granted
android.permission.WRITE_CONTACTS permission: granted
android.permission.READ_CALENDAR permission: granted
android.permission.WRITE_CALENDAR permission: granted
org.dmfs.permission.READ_TASKS permission: granted
org.dmfs.permission.WRITE_TASKS permission: granted
System-wide synchronization: automatically
Account: gaytan@e.email
Address book sync. interval: 240 min
Calendar sync. interval: 240 min
OpenTasks sync. interval: 240 min
WiFi only: false
[CardDAV] Contact group method: GROUP_VCARDS
[CalDAV] Time range (past days): 90
Manage calendar colors: true
Address book account: Contactpersonen (gaytan@e.email Sg)
Main account: Account {name=gaytan@e.email, type=thehelm.com.sync}
URL: https://ecloud.global/remote.php/dav/addressbooks/users/gaytan@e.email/contacts/
Sync automatically: true
Address book account: Recentelijk gecontacteerd (gaytan@e.email Ew)
Main account: Account {name=gaytan@e.email, type=thehelm.com.sync}
URL: https://ecloud.global/remote.php/dav/addressbooks/users/gaytan@e.email/z-app-generated--contactsinteraction--recent/
Sync automatically: true

| locale |
| nl_NL |

| _id | accountName | service | principal |
| 1 | gaytan@e.email | carddav | https://ecloud.global/remote.php/dav/principals/users/gaytan@e.email/ |
| 2 | gaytan@e.email | caldav | https://ecloud.global/remote.php/dav/principals/users/gaytan@e.email/ |

| name | seq |
| services | 2 |
| homesets | 2 |
| collections | 5 |

| _id | serviceID | url |
| 1 | 2 | https://ecloud.global/remote.php/dav/calendars/gaytan@e.email/ |
| 2 | 1 | https://ecloud.global/remote.php/dav/addressbooks/users/gaytan@e.email/ |

| _id | serviceID | type | url | privWriteContent | privUnbind | forceReadOnly | displayName | description | color | timezone | supportsVEVENT | supportsVTODO | source | sync |
| 1 | 2 | CALENDAR | https://ecloud.global/remote.php/dav/calendars/gaytan@e.email/contact_birthdays/ | 0 | 0 | 0 | Verjaardagen | | -1451943 | | 1 | 0 | | 1 |
| 2 | 2 | CALENDAR | https://ecloud.global/remote.php/dav/calendars/gaytan@e.email/huishoudelijke-mededelingen/ | 1 | 1 | 0 | Huishoudelijke mededelingen | | -926896 | | 0 | 1 | | 1 |
| 3 | 2 | CALENDAR | https://ecloud.global/remote.php/dav/calendars/gaytan@e.email/personal/ | 1 | 1 | 0 | eCloud Calendar | | -14910990 | | 1 | 1 | | 1 |
| 4 | 1 | ADDRESS_BOOK | https://ecloud.global/remote.php/dav/addressbooks/users/gaytan@e.email/contacts/ | 1 | 1 | 0 | Contactpersonen | | | | 0 | 0 | | 1 |
| 5 | 1 | ADDRESS_BOOK | https://ecloud.global/remote.php/dav/addressbooks/users/gaytan@e.email/z-app-generated--contactsinteraction--recent/ | 0 | 0 | 0 | Recentelijk gecontacteerd | | | | 0 | 0 | | 1 |

Android version: 11 (lineage_oneplus3-userdebug 11 RQ3A.211001.001 10037567)
Device: OnePlus ONEPLUS A3003 (OnePlus3T)


I get the same 501 error constantly

I wrote the app editor; this is hiw answer:

please use the original DAVx⁵, if you can. You’re using a pretty old
version of our software and one that has been adapted by “Helm” as it
seems. If you can’t change the app please contact the developer that has
taken the DAVx⁵ source code and adapted it to their needs.

Best regards,
Bernhard Stockmann

Depends on which DavX toel you use… I used the DavX5 but it bugged me it required my (exact) location each time; then I installed DavDroid, with ‘above 501’ error each time for ‘recently contacted email addresses’. The calendar and contacts sync ok…

Tried to de-activate the ‘recently contacted’ but it keeps on bugging me with 501 error as well…

if you create a separate and new thread I’ll follow up with debugging there

Tx for contacting me: my thread:


Tell me if you found it ok… or if you need more info.

Thanks and Happy New Year!

that’s not a new thread, but nevermind.

I guess the problem is your app fork and version is doing a HTTP GET to a webdav endpoint that will only accept PROPFIND or OPTIONS. Maybe nextcloud did accept the verb on the endpoint some versions ago. I think you have a client to server version mismatch, the client doing something that is now unexpected by the server

  1. could you switch to /e/s integrated davx fork (“accountmanager”) back from helms davx fork? it is more current (2019 vs 2021)
  2. recently-contacted is a serverside supplied address book that can only be deactivated by the operator. But you should be able to de-select it in the davx(fork) settings, see Synchronisation error for contactsinteraction--recent
1 Like

I setup 2FA after the fact and now I’m getting an authentication error. How do I get my phone to prompt for credentials?

I want to start using the calendar app from /e/ and it seems I need some help please. I entered a test entry in my calendar in my Murena cloud with the browser on my laptop but i doesnt show up on my smartphone.
I enabled synching the calendar in the Murena account there already.

I also added the account via DAVx5 on my Lineage OS tablet, there the calendar entry showed up immediately.

Any ideas what to check further?

Next questions will be around setting the calendar up for everyone in the family, but first I have to get my own going :slight_smile:

Edit: It shouldnt be necessary to add DAVx5 or Etar Calendar App on the /e/ device, right?

Next confusion: I tried connected the calendar via WebDAV and the calendar entries showed up, but doubled! After disabling syncronisation with the WebDAV account the entries where gone completely again…

After installing the DAVx5 App the entries show up like they should.
Quite confusing! Thought DAXx5 is already integrated (without understanding how all this works, I am just a simple user…)