I don't see the back-up utility, The Help says: -System > Backup- but the option isn't there

I want to make a back-up and read about seedvault beïng available on e/OS.
But when I look under System i Don’t see a backup option.

It’s there for me on a Fairphone 3 running /e/OS S (Android 12) and on a Fairphone 2 running /e/OS R (Android 11).
Are you on an older Android version perhaps, where Seedvault wasn’t visible yet? … [HOWTO] Give complete /e/OS version info easily for support, answers, comparison etc

Else … if you’re looking for the term “backup” specifically, the term gets translated into the system language, so perhaps it’s not “backup” (in German for example it’s “Sicherung”).

1 Like

Thanks for your reaction

I’m running Android 12 (e/os 1.11-s- 20230510288098-stable) also on FP3.
I’m not seeing (even in Dutch) something like Back-up. (

See screenshot)

Interesting. It’s there for me after Date and time, I have no immediate clue. The forum search says to me Seedvault isn’t restricted to the dev release channel.


You can look in the system apps for seedvault: Settings-Apps-all apps-three dot menu for show system-search for seedvault.

Or you could try manually enabling with adb. See this post:

I found Seedvault as a systemapp but don’t know how to start it.
Hope you don’t mind me asking :innocent:

Of course I don’t mind but I don’t know the answer, I’m sorry. Maybe this is a bug in s-1.11 stable that you have found. Maybe search through eOS issues backlog or report the bug.

Activating via adb looks like an option but I’ve not done that before so I don’t know how the gui will present itself; or even if it presents itself.

I might try the procedure tomorrow if I have time.

I don’t have /e/ on a device at the moment so I tried running the commands on iodéOS but failed at the step:

adb shell am start-activity com.stevesoltys.seedvault/.settings.SettingsActivity

and couldn’t get any further. The output was:

Exception occurred while executing 'start-activity':
java.lang.SecurityException: Permission Denial: starting Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10000000 cmp=com.stevesoltys.seedvault/.settings.SettingsActivity } from null (pid=5767, uid=2000) requires com.stevesoltys.seedvault.OPEN_SETTINGS
	at com.android.server.wm.ActivityTaskSupervisor.checkStartAnyActivityPermission(ActivityTaskSupervisor.java:1059)
	at com.android.server.wm.ActivityStarter.executeRequest(ActivityStarter.java:983)
	at com.android.server.wm.ActivityStarter.execute(ActivityStarter.java:672)
	at com.android.server.wm.ActivityTaskManagerService.startActivityAsUser(ActivityTaskManagerService.java:1252)
	at com.android.server.wm.ActivityTaskManagerService.startActivityAsUser(ActivityTaskManagerService.java:1224)
	at com.android.server.am.ActivityManagerService.startActivityAsUserWithFeature(ActivityManagerService.java:2953)
	at com.android.server.am.ActivityManagerShellCommand.runStartActivity(ActivityManagerShellCommand.java:572)
	at com.android.server.am.ActivityManagerShellCommand.onCommand(ActivityManagerShellCommand.java:201)
	at com.android.modules.utils.BasicShellCommandHandler.exec(BasicShellCommandHandler.java:97)
	at android.os.ShellCommand.exec(ShellCommand.java:38)
	at com.android.server.am.ActivityManagerService.onShellCommand(ActivityManagerService.java:8667)
	at android.os.Binder.shellCommand(Binder.java:950)
	at android.os.Binder.onTransact(Binder.java:834)
	at android.app.IActivityManager$Stub.onTransact(IActivityManager.java:5183)
	at com.android.server.am.ActivityManagerService.onTransact(ActivityManagerService.java:2520)
	at android.os.Binder.execTransactInternal(Binder.java:1184)
	at android.os.Binder.execTransact(Binder.java:1143)

calling the intent as normal user this way is no longer possible in non-debug builds of Seedvault, you’ll need to elevate the shell to root.

The issue of hiding Seedvault is 2 years old, sad.

1 Like

This may help…

How to Do a Backup using Seedvault

How to Do a Restore from Seedvault Backup

This means I have to be root? My FP is not rooted yet.

Thanks for the YouTube links. I have seen them before, but because I can’t run Seedvault I am stuck there.

@aburg Have you tried installing seedvault from the applounge?

Have you tried Neo Backup?


You can find it in the App Lounge.

I don’t recall Seedvault ever being an installable user app.
Did you mean something else?

Sorry, I missed typed. I mean that you can always download Seedvault from APKmirror.


1 Like

I had the exact same poblem here on us Fairphones. On one phone i have done an complet reset. After that i found (sichrung) under System again. But this is not really an soltion to reset all phones here.

The installation is on actual e/OS (Android12) not possible, not without reset.

This topic was automatically closed after 180 days. New replies are no longer allowed.