Install /e/ on Gigaset GS290, Windows, using Easy Installer success second pass

This is an abbreviated transcript of a thread from Telegram 10 March 2021.

Caller: Hi, my GS290 stops at the “fastboot mode”, screen is black, on screen is only “fastboot mode”. The installer stops right there and does not continue.

Support: I was able to continue, by running windows update, which downloaded phone driver for windows, after that Easy installer was able to continue

Caller: After I downloaded and run the easy installer, I tried to restart Windows and had a “blue screen”. I had to reset the system.
Now, after all updates that I could find, it worked!
So the problem was with Windows!
So thankful to have finally /e/ on my phone! :see_no_evil:

Does anyone else has the problem to log in into the account from the phone?

Here is my build number.

As I said, after the Update of Windows 10, the Installation went well!

The only thing that I experienced yesterday that I was not able to log in into the /e/ account. But this might be a different issue.

I guess the account problem was linked with yesterday’s fire at a datacenter, see Outage : /e/ website and eShop

1 Like

Reviewing the OP. Linked to Documentation Suggestions.

If Easy Installer seems to fail in Fastboot mode and you get a small orange warning triangle in Windows device manager the advice would be to be sure to fix the Windows warning.

  • You can try with Windows update, sometimes Windows may need additional driver. If you run windows update when in fastboot mode, it should detect the device and download necessary driver. Credit @shenol.

  • Failing that, carefully close the connection to your device. Restart Windows. Perform necessary steps to update. It is significant that “device” is your device in Fastboot mode. Does the warning still persist when you connect the device in Fastboot mode? Once the warning has gone try Easy Installer again.

Testing, do those two steps fix the problem?

If the warning has not gone, there could be satisfactory ways to introduce the GS290 drivers to Windows. (Please post below if you follow this path!).

Credit image: a Fairphone HowTo

I didn’t need a Windows update, nor did I need to download additional drivers, nor did I need to restart Windows.


It was enough to activate other driver software in ‘Device Manager’ of my Windows host machine, for example: ADB Testing Interface.

1 Like

Thanks @SuzieQ for this image. I have no Windows so I cannot see. Edit x 2: in the event that Easy Installer has introduced such “:warning: problematic driver” does Windows Device Manager helpfully pop up for you?

Or do you have to open it yourself? Thanks.

1 Like

Yeah @aibd, since I’ve very different Android devices in the test, from Galaxy to Gigaset GS290 to Google Pixel and OnePlus as well as Xiaomi, and my Windows host machine constantly complains about missing drivers depending on the ADB/fastboot status, I always have my Windows Device Manager open and in view in order to quickly select the appropriate driver for the situation. They are all already available in Windows and therefore only need to be changed with a few clicks.

1 Like

I used the /e/asy-installer for a short time only for testing purposes. Now it is being shelved again. I prefer to flash manually in the old fashioned way.

When the /e/OS ‘Q’ upgrade for the GS290 was released, the /e/asy-installer was a bad recommendation, because it installed /e/ OS 'O’reo-8.0.0 instead of ‘Q’ 10.0, leaving the GS290 unusable. Now, weeks later, the bug is fixed, after tens of us/e/rs have fallen into the installation trap, and the installation with the Windows version of easy-installerv0.12.1_beta runs as it should, apart from the Windows driver stumble discussed.

I had a good experience until the end, except that in the end the phone is broken and there is no black screen.
I feel like I’m alone, no one to help me.
New phone

I am sorry to hear you had this experience, I hope we can help :slight_smile: .

Please can you read this and then provide us a log from Windows.

Please describe “broken” more fully. If you are stuck with the phone on, please send a photo of the screen.

Thank you very much for sharing.
I am having exactly the same problem that I am stuck in “Rebooting in bootloader mode”
Windows is fully up to date.
I even tried to follow the steps here according to the guide suggested by SuzieQ: GS290 No recognition on PC
But, the problem is that when I connect the phone in recovery mode, it is not recognized by windows neither.
In the device manager the GS290 is listed under USB devices.
When I right click on it for updates, it says Windows determined that the best drivers are already installed.
I even installed Android Studio hoping that that might change something, but, still the same, always stuck in “Rebooting in bootloader mode”
I am running windows 10 on a Thinkpad t440
The easyinstaller is version 0.12.1.
Thank you all.

Is there an option like “Let me determine if the best drivers are installed”?

It is significant that “device” is your device in Fastboot mode.

And, of course the log might say something useful. :slight_smile:

Thanks for replying so quickly, and sry in advance if I cannot follow all your advice, I am completely new to this.
So, the GS290 is currently listed under Portable Devices, the driver it uses is called “MTP USB Device” - There is the option to install a driver manually, so, I guess that would work, but, which one would that be?
And, what do you mean when you say that “device” is your device in Fastboot mode? And what is the log you are referring to?

To do a job like this I find that I have to read the instructions three times before I start! :smiley:

The source of the log is mentioned by me in the post immediately above your first.

From what you say, as you have Windows 10, “choose your own driver” won’t happen, please disregard that line!

Your phone can boot as a phone. It has two other bootable modes. Recovery and Fastboot. I guess you need to do some more reading if this is all gibberish!

Edit: :warning: Our documentation refers to “Bootloader Mode”, but is it clear that within Bootloader Mode exists Recovery Mode and Fastboot Mode :warning::interrobang:

Keep at it! :smiley:

Thank you so much
Ok, I put the phone in Fastboot mode now, connect it again, and play around a bit, see what happens, if there are other update options etc, and meanwhile do some more reading.

1 Like

… and now please “playfully” follow this installation instructions ‘Install /e/ on a Gigaset GS290

  fastboot flash --disable-verity --disable-verification boot boot.img
  fastboot flash recovery recovery.img
  fastboot flash system system.img
  fastboot -w
  fastboot reboot

and you will have a sense of achievemen …


Indeed! It is done! /e/ is running on the gigaset gs290. Thx community!


Our GS290 install page tells us to reboot in bootloader with

adb reboot bootloader

“Fastboot mode” is not mentioned (my apologies @Hermann!)

However there is a request by @freechelmi for the Key combinations for Recovery and Fastboot

I have no GS290, please could either of you @SuzieQ or @Hermann confirm if this is right?

Recovery Mode from Phone off

  • Hold the Power button and the Volume Up key for a while.
  • Wait for the Boot Mode to appear.
  • There, Volume Up key to navigate
  • Volume Down button to select, open the Recovery Mode option.
  • Use the Volume keys to navigate inside the Recovery Mode and select by pressing the Power button.

Fastboot Mode from powered off

  • Hold the Power button and the Volume Up key for a while.
  • Wait for Boot Mode to appear.
  • Press the Volume Up key find Fastboot Mode
  • Select it with the Volume Down key.

Or is is helpful? / accurate? to say

Bootloader Mode from phone powered off

  • Hold the Power button and the Volume Up key for a while.
  • When Bootloader Mode appears you can follow on screen instructions to navigate to Recovey Mode or Fastboot Mode.

Does this persist after /e/ is installed?

Just so readers can become more familiar with the GS290, please could I ask for a screenshot of the “Boot Mode” screen? Thank you so much in advance. :smiley:

Hello aibd!
The instructions you give are all correct; I entered the bootloader mode via the mentioned command line and the key combinations on the phone, and the fastboot mode with the key combinations on the phone. in the picture, pls see the menu you enter after pressing the powerbutton and volume up button at the same time - here yoyou select between Recovery, Fastboot, and Normal.1615987151631|375x500

1 Like