Install TWRP on Samsung Galaxy Tab S5e

Hello all,

In preparation for the migration to e/OS

i would like to install TWRP.

adb cli is working. USB debug and allow to override boodloader is enabled. But if i reboot the device with
adb reboot bootloader
the device reboot into the bootloader and is waiting for download the image. But if i enter the command:
fastboot flash recovery twrp-3.5.2_9-0-gts4lvwifi.img
nothing is happen.
And if i scan with adb for devices, no devices were found. So what i’am doing wrong?

Best Regards :slight_smile:

1 Like

Ok, found that i must using heimdall to flash samsungphones. So have done the same again, but get an error on handshake:
heimdall print-pit

Heimdall v1.4.2

Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:

Initialising connection...
Detecting device...
Claiming interface...
Setting up interface...

Initialising protocol...
ERROR: Failed to send handshake!ERROR: Protocol initialisation failed!

Releasing device interface...


Have you flashed the proposed vbmeta before or when flashing TWRP ?
According from twrp

If you wish to install TWRP without rooting, there are numerous pitfalls to consider. For example, a stock device is protected by Android Verified Boot. This is implemented as a vbmeta partition that contains cryptographic digests for verifying the integrity of boot.img, recovery.img and other partitions/images. Flashing TWRP without first flashing a vbmeta image with verity disabled will render your device unable to boot.

it is an additional step for recent Samsung

If you have access to a Windows PC, you can follow
Install LineageOS on gts4lvwifi | LineageOS Wiki

If not, try to extract the .TAR file to a .IMG, and flash it with Heimdall (to the appropriate /partition),

sudo apt-get update
sudo apt-get install heimdall-flash android-tools-fastboot android-tools-adb libusb-0.1-4 libusb-1.0-0 libusb-1.0-0-dev
sudo heimdall flash --RECOVERY /path/to/recovery.img --VBMETA /path/to/vbmeta.img

( Replace "/path/to/your/downloaded/files/” )

Very thanks for the howto. But i get the same error message. Ok, i boot now into windows and test this with these tools.

Ok, now i have done the same in Windows. I have checked it 2 times. The OEM lock is off, but on the tablet i get the error message:

Custom Binary (recovery) Blocked by OEM Lock.

This is, if i would like to intall twrp 3.5.2 on the tablet. This little vbmeta.img has worked, but i have no idea what this minifile is doing. What also has worked i can boot into android owns recovery image.

With Linux Heimdall Gui (tested too) i can’t even download the PIT file. There is still something wrong.

So Bootloader is still locked

According to LOS :

  1. Connect the device to a Wi-Fi network.
  2. Enable Developer Options by pressing the “Build Number” option in the “Settings” app within the “About” menu
  • From within the Developer options menu, enable OEM unlock.
  1. Download this VBMeta image .tar file.
  2. Power off the device, and boot it into download mode:
  • With the device powered off, plug in the device while holding Volume up + Volume Down + Power.
  • Now, click the button that the onscren instructions coorelate to “Continue” and/or “Unlock Bootloader”, and insert the USB cable into the device.
  • Device will restart, repeat steps 1 and 2.
  • Verify that “OEM Unlock” is still enabled and continue to step 5
  1. Download and install the necessary drivers.
  • Download the newest Samsung drivers from here. You will need to create a Samsung account and login to download them.
  • Install SAMSUNG_USB_Driver_for_Mobile_Phones.exe.
  1. Download this version of Odin.
  2. Extract “”.
  3. Run Odin3 v3.13.1 found in the newly extracted “Odin_3.13.1” folder.
  4. Check the box labeled next to the button labeled “AP”, and then click the “AP” button.
  • In the menu that pops up, select the newly downloaded custom VBMeta .tar file.


11.TIP:* The filename may very depending on your device, and version of TWRP.

  1. Check in the top left of thne Odin window that you see a valid device, it will show up as something like COM0.


14.TIP:* The COM port, or the number succeeding COM, may be any valid number.

  1. A blue transfer bar will appear on the device showing the recovery image being flashed.
  2. Your device will reboot, you may now unplug the USB cable from your device.
  3. The device will demand you format userdata, please follow the onscreen instructions to do so.
  4. Run through Android Setup skipping everything you can, then connect the device to a Wi-Fi network.
  5. Re-enable Development settings by clicking the “Build Number” option 10 times, in the “Settings” app within the “About” menu, and verify that “OEM Unlock” is still enabled in the “Developer options” menu

According to xda :

[ROM][OFFICIAL][gts4lvwifi][11] LineageOS 18.1 | XDA Forums

– bit more friendly stock → lineage instructions –

  1. Unlock the bootloader
  • Connect to WiFi network
  • Enable OEM Unlock in developer options
  • Turn off the tablet
  • Boot to download mode manually by plugging in USB and holding all the buttons for few seconds
  • Follow instructions on the screen
  1. Connect to WiFi network and make sure OEM Unlock in developer options is still checked
  2. Flash custom VBMeta image ( Download vbmeta.tar ) in Odin ( use AP slot )
  3. After flashing VBMeta, boot to stock. It’ll likely ask you to wipe data, if so do that
  4. Connect to WiFi network and make sure OEM Unlock in developer options is still checked
  5. Now you can flash TWRP ( Download TWRP for gts4lvwifi ) in Odin ( use AP slot once again ), for convenience you can hold volume up while flashing it so that you boot to recovery right after it’s flashed
  6. Install Lineage × whatever else you need ( gapps, addon-su, … )
  7. Format data
  8. Reboot ( make sure to not install TWRP app when TWRP asks you to )

Is the same
adb reboot download
I hope so because the reboot with holding the keys did not work. Tested it many times.

And I don’t have that here either.

Yes adb reboot donwload is the same, coming from system mode or recovery mode,
but outing from download mode and going to recovery mode (to validate the TWRP install),
you will need to use the buttons combination and the good timing

Supported models

  • SM-T720
  • SM-T720N

About the Galaxy s10e :

I am finally one step further. The bootloader is unlocked. The key combination was quite different: “Volume UP/Down” and while pressing these buttons plugin the USB cable.

I have an S5e, so normaly TWRP it should work. But if you see my screenshot, it would not. So i loaded with odin only the VBMETA.

Maybe the problem is “secure download enable”. I did not find any option for this on the tablet.

2 questions:
Is anything else missing?
Or may I put e/OS without TRWP, probably a bad idea because if something goes wrong I can throw away the tablet?

I found also this information:

Is this worth a try?

When faced multiple problems,
Flash back to stock firmware and starting from scratch is always a good idea…

In your Download mode screen I see
KG status Prenormal.

I think we really need to account for the reason for seeing that.

This can happen when the phone is being used now in a country different from the one it was intended to be used in when Samsung sent it out. Put another way it has been imported in a slightly irregular way.

Could that be the case here? Do you have all the original labels and packaging? Edit, or alternatiely that it has not been used with a local SIM card in the local country for a specified time to “lift” the restriction.

I just looked at the original packaging. Apparently, the device was originally intended for France. I am in Austria. The device does not have a SIM card slot. Only MicroSD

This also explains why after I unlocked the bootloader, the language was set to French. But what does the country have to do with the fact that it can’t be flashed? What if I were in France right now? It’s the same planet… :slight_smile:

Sure that was just a first guess. Here is a Knox Guard page for the UK.

Sounds quite benign, really. But Knox is a security suite to do all sorts, including what I guessed a Regional lock. (It might well be a different lock!)

Some form of trade restriction? but within EU seems strange.

Step one would be to find what magic would release the Regional lock, edit, unknown.

Did you use it for a while “normally” after you first got it? Any labels to tell you what is required?

Not really nice.

And again, I get to learn something.

Yes I used it normally for 2 days, played with it a little. The first time I turned it on it came with the wizard and suggested German language, then I connected it to my wifi here.
Other than that I haven’t noticed anything unusual or important unfortunately.

If it was new from a Samsung dealer, this would be for their support staff.

“Prenormal” seems to be used to tell the device that it is not yet open for “normal” business until some event has happened to release it. We have seen a label saying that you must make 5 minutes of calls on phones in EU.

We must be open to it being not a Regional lock.

Ok, i created an test google and test samsung account, connect with my WLAN with Country US / Language US because it is easier with tutorials and findout menu positions. So i let the tablet only with GPS and do all nice Updates, after that i will reboot into downloadmode again. Maybe the status will be changed.

USA is where this problem really hits! Will UK setting work for you in case geo-location is very important to the release! A Samsung account might be a very good idea,

Is this link relevant ?

Hi @piero my feeling is that that method stopped working with Android 10. When you read the recent contributions, it has still worked for some, but we do not always see the cause of the “lock” and the Android version.

It is definitely worth reading (and opening and inspecting the patch) to help understand how these locks are triggered and potentially released.

After all, it has worked now with the file vbmeta.tar.

Now i see on the screen “Android Recovery”
Can’t load android system your data may be corrupt. If you contiue you get this message, you may need to perform a factory data reset and erase all user data stored on this device.

So, now i should go to
Install /e/ on a Samsung Galaxy Tab S5e (Wi-Fi) - “gts4lvwifi”
and install the custom recovery twrp-x.x.x-x-gts4lvwifi.tar after Factory reset or go directly into downloadmode?

1 Like