Installing eOS on Fairphone 3

Hello everyone!

Wanting to degoogle my mobile life and having read about the e-foundation I bought a used Fairphone 3 (Android 10 installed) last week. I am now trying to install eOS on it. However, I am completely new to the field, this is probably the reason why I got some problems so far…

In a first step I tried to follow the instructions on Install /e/ on a Fairphone FP3/3+ - “FP3”. In order to do so, I downloaded the necessary files and installed “Minimal ADB and Fastboot” on my PC (Windows 10). However, I got stuck with the command: “fastboot flash recovery twrp-3.4.0-0-FP3.img”. I got: “FAILED (remote: partition table doesn’t exist)”. I don’t know what caused the problem, maybe it depends on my choice of “Minimal ADB and Fastboot”?

I then started reading across different forums. I came across the recommendation not to install TWRP as this would make OTA updates impossible in the future. The issue is not clear to me, as I imagine the e-foundation would not recommend installing TWRP if this caused problems for the future.

After some further research I realized that since November 2020 the easy-installer is also supporting the FP3. I am therefore asking myself whether it would not be the best option to use the easy-installer in order to get eOS installed. However, I also found a couple of threads mentioning that using the installer resulted in differnet problems.

Could anyone give me e hint what would be the best hting to do?

Thanks a lot in advance!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

This might work, but the install guide recommends to use the current Android SDK Platform Tools.

I don’t know why that’s in the install guide for the Fairphone 3/3+, this is an error, it doesn’t work that way on A/B devices like the Fairphone 3/3+.
Just ignore the “Installing a custom recovery” section, the guide doesn’t use TWRP at all after this.

Seems like a rather old error, too …

That’s true for Fairphone OS, not for /e/.
On A/B devices there is no recovery partition to flash a recovery image to. Instead installing a custom recovery like TWRP is done by altering the boot partition. The Fairphone OS updater doesn’t OTA update in case it detects altered partitions, /e/ will just restore its own boot partition including its own recovery when doing an OTA update (so an installed TWRP would be gone).

1 Like

I had replied to your same question in another thread. I’m moving it here to avoid duplicates. :wink:

That’s an error to be corrected in the docs, see TWRP in install instructions for the FP3?

Just skip the entire “Installing a custom recovery” section of
I personally would go with the official instructions. The other topic (how to install on Debian based linux) might help a bit, because it contains a couple of screenshots. But essentially, the actual things to be done are the same. If there are differences, I’d go for the official docs, as other tutorials might not always adapt the latest changes.

1 Like

Thank you a lot for your fast reply, @Ingo_FP_Angel! And sorry for double posting…

I will just skip the mentioned TWRP-passage!

However, I have another small question: As mentioned, I had the “Minimal ADB and Fastboot” installed. Follwing AnotherElk’s reply, I should rather stick to the recommendedI current Android SDK Platform Tools. I am not sure about the installation process. If I am not mistaken, it is not suffcient to just copy the files into the folder from which I operate?!

Would it be recommandable to install Android Studio or is this exaggerated? (I first tried to follow this instruction for the installation of the SDK tools only, however, it didn’t work.) Or ist there another easy way for using the Android SDK Platform Tools?

Thanks again!

Android Studio is way too much if you ask me. It takes a couple of GB diskspace which are just not needed to flash a phone.

To install the official platform tools you can follow the 5 steps listed at

1 Like

Thank you a lot! Everything worked fine!