Is it possible to make Q builds using Docker?

It might be interesting for unofficial builders to start trying to make Q builds for devices with working Lineage 17.1 builds - official or unofficial?

If it isn’t possible yet, is there a timeline for making it possible?

1 Like

Has anyone tried with v1-q option ? Let me know if it worked …will check and get back if this is not working and if there is a timeline

I will happily try in the next day or two. Please can you suggest a device to build for, for which the /e/ team have successfully made a Q build. If Docker works for that, then there is hope for ‘unsupported’ devices.

I will update you by tomorrow once I check with the team.

1 Like

A french user has tried but it isn’t working in moment. As far as I know he was in contact whith Romain.

Any news on this one please?

The official Q alpha build works on the Mi Mix2 chiron. Have tested the build myself on the device.

Great - thank you. I’ll see if I can build that on Docker

Was it build with docker ?? If yes, could you post the docker command for the right docker container, so the docker builder could use it ?

The /e/ official or test builds are only built with Docker. If @petefoth can run the same build commands calling v1-q branch and devices as chiron it should build. If there are error messages it would be helpful to get the same to check.

1 Like

Getting an error

>> [Wed Sep 30 11:45:04 UTC 2020] Branch:  v1-q
>> [Wed Sep 30 11:45:04 UTC 2020] Devices: chiron,
>> [Wed Sep 30 11:45:04 UTC 2020] (Re)initializing branch repository
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 32517  100 32517    0     0   172k      0 --:--:-- --:--:-- --:--:--  173k
>> [Wed Sep 30 11:45:05 UTC 2020] Copying '/srv/local_manifests/*.xml' to '.repo/local_manifests/'
Traceback (most recent call last):
  File "/root/", line 61, in <module>
TypeError: write() argument must be str, not bytes
>> [Wed Sep 30 11:45:05 UTC 2020] Syncing branch repository
>> [Wed Sep 30 11:45:06 UTC 2020] Missing "vendor/lineage", aborting

Build command was

sudo docker run \
-v "/srv/e/src:/srv/src" \
-v "/srv/e/zips:/srv/zips" \
-v "/srv/e/logs:/srv/logs" \
-v "/srv/e/manifests:/srv/local_manifests" \
-v "/srv/e/userscripts:/srv/userscripts" \
-v "/srv/e/ccache:/srv/ccache" \
-e "CCACHE_SIZE=200G" \
-e "BRANCH_NAME=v1-q" \
-e "DEVICE_LIST=chiron" \
-e "REPO=" \

Also tried with -e "BRANCH_NAME=v0.12-q" \ Same error

Building a nougat branch worked OK e.g.

-e "BRANCH_NAME=v0.11-nougat" \
-e "DEVICE_LIST=suzuran" \

Thanks will ask @rhunault to have a look at this error.

1 Like

Note: remote compute instance was using ubuntu 18.04 with all updates applied.

I tried again using 20.04 - same error :frowning:

Searching online for this error indicates it maybe a problem with python versions: python 3 seems to be more picky about type safety than python 2. Sadly, I have no idea how to fix it in the Docker build image

Thanks for pointing this out…will pass it on . Was not able to get an update, yesterday will check today.

you have to build with python2, otherwise you will get alot of errors.
remove python3 from your system and install python2.

If the problem is with the python version, I think the problem lies in the Docker image, rather than the system it is running in. Also the problem is only with Q builds. Nougat builds work with no problems.

I’ll wait to hear back from @Manoj and the Dev team.


Any more news on this?

Unfortunately I did not get an update on this . Will check on Monday once the team is in office and get back to you.

Thanks very much @Manoj