Is it possible to rollback to a previous release from the latest?

Hi there, thanks in advance for any help.

I’ve updated to the latest version (version 1.5.1-s-20221102231514-stable-FP4) and unfortunately internet doesn’t work over WiFi properly.

I found one recent post with someone having the same issue with this update, and their solution of switching off private DNS let me get from no internet to being able to get it to work for anywhere from 5 to 20 minutes after resetting WiFi, mobile and bluetooth, but then it’s gone again and all i can do is reset again.

I’ve spent the last 6 hours searching for solutions and trying things but I haven’t found a solution so I’m kind of happy to just give up now as I need my phone. I updated to 28 Oct version beforehand, and that worked fine for me. Unfortunately when i search for earlier builds, all I can find is the latest stable, i.e. the one that won’t work on my phone.

Does anyone know a link to earlier builds? Would I be able to download it and install like an upgrade, i.e. without resetting my phone and all its data?

Many thanks!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Well, not sure you can downgrade to a lower version, even if you’ve got the right build.

I heard that FP4 is equipped with anti-rollback feature.

Maybe the best way is to reflash stock ROM (that will format and wipe all partitions) and maybe try to come back again. See link here:

However, it’s weird because I’ve got also FP4 on 1.5.1-s (as well as my wife) and we both don’t face any issue at all.

I had some rare troubles since 1.5.1-s with mobile data, but this was due to my very old sim card. My carrier sent me a new one and now everything is perfect.

So no idea why you get into trouble with your WiFi connection. But I hope you will somehow fix this.

Thank you for the information!

That’s a bit of a shame, it would take me a lot of time to rollback to stock, reinstall /e/ and then set it up as i have it now. I’ve got my old phone as a backup for now, so I’ll wait and see if anyone else has the issues as well, before doing anything drastic.

Strangely I’ve just woken up to my phone still being connected to the internet, so it has been online all night, and I didn’t do anything after my last reset - this makes me think that problem is likely something in my individual set up, perhaps to do with running shelter and two separate VPNs simultaneously. I reset the wifi settings at least 5-10 times yesterday after losing internet, so it’s hard to believe it has just became stable on its own over night. But I will just wait and see - and not panic :slight_smile:

Thanks again for your time.

Is the e-1.5.0-s-202210xx-stable-FP4 exist ?

Is a previous one (an “r” one) can be flashed and works ?

I have tried searching but can’t find a list of releases for confirmation.

I did two updates yesterday, because 1.5.1-s-221102xx was not in the available update list when i did the first update, but I am fairly sure that the latest version I saw was 1.5.

Do you have a backup of previous state to restore ?

Stupidly I do not, but I have learnt my lesson! I will do some research on creating a full image of my phone; I regularly do it for my computer so it’s my own fault that i did not for my phone.

How does one make such a backup Piero? I want to rollback my e/OS update after Aurora store stopped working.

About Backup and restore :


About AuroraStore not working, you can update it (2023.05.02) via F -droid,
or you can uninstall and reinstall the app.
(You will have to redefine the blacklist)


About downgrading to previous /e/OS version (same Android version based), simply dirty-flash the .ZIP from recovery mode

Thank you very much Piero very helpful!
Ha ha dirty flash is probably a pro term have to look that one up being a newbie :wink:
I am going for the simplest solution reinstalling through F droid.
Can I also update app with app lounge which have been installed wit aurora before?


deleted Aurora. Did a new install through F Droid.
I am getting the same error message.

dirty-flash is flashing witout wiping or formating anything

Thank you Piero,
Do you perhaps have any other suggestion? I am not sure if downgrading will solve the problem. That is why I wanna use it as a last resort.
Would it be possible to using app Lounge for updates from app which have been downloaded by aurora?

Last night Aurora suddenly started working again for no reason.