Issues with Spotify on 1.15 stable & 1.16 dev

Hi everyone,

Since update 1.15 stable or Dev on 2 drastically different phones, we do not have access to Spotify’s quick access control from the locked screen. Triple checked, but did not find any change in the settings.

Has anyone encoutered the same kind of issues? If yes what is the fix?

Thank you all in advance for your consideration and help. This OS and it’s community rules!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online services phone


I just wanted to open a similar thread, maybe we have the same problems only(?) with spotify.
Quick control froze on my FP4 a couple of days ago and now shows the specific song at the specific timestamp from the moment it froze. I also couldnt use the control buttons anymore on the quick access (“swipe down”) menu.
Furthermore, spotify randomly just stops playing as if someone pressed “play/stop” every ~10-20min. Everything works in the app itself. Reinstalling brought me back controling the quick access buttons, but the other two bugs remain.
I have no further solution or idea what caused this.


I can confirm the frozen Spotify lockscreen widget.
Also sometimes random stop playing, although much less frequent.
Using a Motorola edge 30 on 1.16 T dev.


Hi y’all!
I seem to have been able to narrow it down to when the display gets on auto-lock.
Seem to work fine after phone reboot and screen locked manually.
Also, force stop followed by restart of the app somewhat allow control over bluetooth, still no locked screen visual nor control though.

Indeed, we do have the same problem.
Feels better not to feel alone…


I have the same problems. Swipe down/lock screen controls stuck displaying one song (although pause/skip controls work). I also have the random pausing every ~15min. I updated my FP3+ to 1.16 stable a few days ago, the problem persisted.

1 Like

I´m having the same issues; I’m also having trouble with video podcasts not working well on the 1.16 FP4. :frowning: It seems that Spotify made some changes in + that are not working well with eos.

Same here on FP3+, since 1.15 and still happening on 1.16.
Notification locked. But reboot does not fix it, force stopping app neither. Spotify update this morning fixed it temporarily, same after 1.16 update.
Music pauses randomly on bluetooth headset only.
Manual screen lock or auto lock does not change a thing for me.
Noticed that Bluetooth headset controls for play/pause/next/previous are also gone (with Spotify, haven’t tested something else). Don’t know if that could be linked.

Exact same issues for me. Mine is pausing usually 10 or so seconds after a new song begins, but not with every song.

So whats the process now? Is the team aware of this? @Manoj ? Should somebody open an issue on git?

1 Like

Can confirm having the Spotify pausing playback issue under miatol since 1.16

A user on the telegram channel reported that updating spotify to the latest version resolved the issue. Are you on the latest spotify build.

Hi Manoj,
Someone on this thread already said the update worked for them.
Unfortunately did not work for me on any OS version all running the latest update.
Have not had time to study 1.15 changelog to look for any background app rules management change.
Could there be some sort of regression?

Yes I am, also did a reinstall of the app.

I also reinstalled the app and am on the newest version.

Getting two different versions here. One where users with the latest version of Spotify are not facing the issue, another where despite the upgrade, the issue persists.
This will require an issue to be raised on gitlab. Pl also add logs to the issue - generated after you face the issue. Pl always check the logs before you post them and ensure that they do not contain any personal data.


Hi everyone. I’m on the same boat here. Running /e/OS 1.16 on Xiaomi Redmi Note 9 pro. Spotify controls are not showing on start screen and starting or stopping the music over my BT headphones is not working. I have Spotify version which is the last version afaik. I hope a solution comes soon.

1 Like

Hi everyone, I am also impacted by such issue. It is related to the last spotify update. The workaround is to reinstall an oldest sotify version like the 8.8.78. I reported the issue there Now we have to know if the issue come from spotify or if it is about missing feature from /e/OS.

Also it mayb be good to report such issue in spotify community too

1 Like

Theres an update to the spotify app which solved the issues for me at the first glance. I justed wanted to let you guys now, although i’m only using it for 20min so far.

edit: same issues after 1h.