Langis : no more updates

I have the repo “patched-apps” instelled in F-Droid, but it seems that I have no more updates for Langis.
The Langis version proposed the 6.34.4 since the Signal version is 6.38.2
Langis was generally close to the Signal version but it’s been a while since the langis version has evolved.

Could this be due to an e/OS/ update or rather to the Langis repos not being updated ?

I’d say it’s rather Langis-repository ( → patched apps) not being updated… (last update: sept 27)

btw: Signal-FOSS (TwinHelix-repository) is up to date.

Yes, I also noticed this. That’s bad, especially because the last Langis version asks again and again for the PIN. And it’s also bad that the Langis guys had never any other communication chanel than Matrix.

I use Molly for a couple of weeks now. Works good and reliable, but notifies over Google servers like the original Signal.

@obacht I can’t activate the TwinHelix repo, it says always “network error, couldn’t sync” :frowning:

There’s hickups every once in a while but in general sync works for me with:

Yes, thanks, I also configured this address, but I never had a single successful connection in the last six months or so …

That’s odd. I normally use droid-ify but can confirm sync of repo also with fdroid just now.

With regards to notifications what about Molly-FOSS or Molly (UnifiedPush) versions.
Never used any, just curious.

I downloaded the FOSS version of Molly right now to check how good it works.

I tried the Signal-FOSS version some days until I missed the notifications. I did receive any message but just didn’t notify at all. That was not good.

good to know thanks,
did not try it myself yet (I am just curiously observing these projects)

Molly-Foss does notify very well. Good so. Think, this will be my next daily Signal app. Not sure how to keep this up to date, I installed it using the APK from the home page.

Then maybe check out this one. Sounds interesting on paper. Looking at the issue tracker it seems it has a ways to go before being fully usable.

1 Like

I installed Molly-FOSS (test purpose) not with an APK but with f-droid, adding this repo url :
Last version proposed for Molly-FOSS is v6.35.3-1-FOSS
Signal is in v6.38.2
Signal-FOSS is in v6.38.2
Langis is in v6.34.4

1 Like

Molly and Signal-FOSS have both caught up and are at v6.39.1.
Langis still trailing.

Seems that Langis is a dead horse :frowning:

maybe it´s just a momentary lapse of reason and the makers are occupied elsewhere (?) … the available download here (“show more” → “download latest artifact available”) contains version 6.37.2

Something else makes me wonder:
I use “normal” signal and I get it from aurora store.
Now depending on which repos I have active in FDroid (“Signal FOSS/twinhelix” or “Langis/patched apps” or “Molly”) FDroid recognizes my “orignal signal” installation as either being “Signal FOSS/twinhelix” or “Langis/patched apps” but never as “Molly”…

I’ll check this.

This is a known problem with Langis for a while: it’s sometimes not clearly distinguishable from Signal. In my F-Droid-client Signal updates got into the list of Langis updates. The top-most entry in the Langis updates was not Langis, it was Signal itself. When I tried to install this very new version it said the version is incompatible, I should uninstall the old version. When I did this and installed the new one I got indeed Signal, not Langis. Also on other places where the app name is visible an installed Langis is seen as Signal.

1 Like

…strange enough as “normal Signal” is not available in FDroid afaik.

But I expected Langis not being discernable from Signal (or I should say, it´s explained by Langis) as they say on their webpage:

“The APKs provided here are signed to allow you to upgrade your Signal App without needing to uninstall previous version.”

Which I understand as Langis cannot be discerned from Signal with regards to signature which makes FDroid think it´s the same.

For me Molly appeared as an outlier as Signal FOSS behaves like Langis in that regard…

Deoending on the order of your repos Langis and Signal-FOSS will display differently as far as title goes. At one point I had the Firefox repo which also houses/housed Signal. Three providers under one heading.
Mostly use F-Droid Classic where I can see what’s where at a glance.

In general though the client never offers updates to an app unless it is from the repo originally installed from.
For instance I originally installed Joplin from IzzyOnDroid repo. Versions fall behind F-Droid repo where newer versions are available. They are shown in the client but not available as updates.
I removed and re-added the F-Droid repo so it was the last one. Now Joplin shows up as an update (after I had manually updated a newer build).

1 Like

6.41.2 in the zip file. But the patched-apps repo (which seems to be reachable again) shows still 6.34.4 as latest version.

1 Like

6.42.0 now.

The repo shows still 6.34. Has anyone a Matrix client installed to ask them about their dysfunctional repo? Regular automated updates are the key for any use of this app.