[LIST] Banking Apps on /e/OS

I use N26 (German), ING (Dutch, to be discontinued soon), PayPal, Openbank (Dutch), S-ID-Check (German) and Consorsbank (German). ON e/OS 1.6 running R, rooted with Magisk having Shamiko and Denylist running. They all work fine. Furthermore I have blocked as many steps as possible using XPrivacyLua and use TrackerControl next to AdvancedPrivacy.

But what I miss in ANY conversation here, and what worries me most… Many banks are already “measuring” all your expenses to CO2 footprint. This is of NO concern to them and the biggest privacy theft you can imagine. Exact reason why I am canceling my Dutch ING account.

3 letters: WEF. Prepare yourself.

@Infinity and everybody

For my part, I am currently testing bitcoins. I have installed relai.app from App Lounge to easily buy bitcoin.
To spend bitcoin I installed bitrefill, again from App Lounge. Bitrefill allows you to buy “gift vouchers” (even for Amazon) and thus allows you to spend your bitcoins. Unfortunately, each transaction is subject to additional fees. But in this way it may be possible to bypass bank surveillance.
Beware, relai.app and bitrefill contain trackers. To try to limit the damage, I use shelter to run them in a sandbox.
If anyone knows of similar applications but open source and without trackers, they are welcome :wink:

Working also: Cajamar, Spanish bank, download through App Lounge: 100% working with MicroG.

Hi there, Austria - “Bank Austria” (Member of Unicredit) App works for my needs as far as I can tell - I did not test every function / feature of this app. Basically I use the app to receive TANs for money transfers since this banking institute does not provide TANs via SMS anymore.

The only function / feature that I found out not to work is “Mobile Geldbörse” (“mobile wallet”). Even when I`m not logged in and try to access this feature the app instantly crashes…

Tested on a OP 8 Pro /e/ v1.6

Tested app from Banco Sabadell-Spain. Working fine

1 Like

Are you still able to use the LCL App?
I personally can’t pass the step where I have to register my device.
I can login, then I’m receiving the confirmation text from which I have to open a link with the app, but when I do so, I am sent back to the login screen, and it’s a cycle from there.
Thanks for any info you can provide.


Could you try to disable advanced privacy to do your test?

Then if it is working fine you can enable advanced privacy again and exclude LCL app from the config.


Ing direct italy works fine
Bancoposta italy works fine
Posteid italy works fine

I already tried that but forgot to mention it. I retried it, just in case, but it did not work.
I just found a workaround, if it can help someone :

  • I put my SIM card in my “old” phone (the one I am switching from, that already has the LCL app installed)
  • I started the registering procedure again, but this time I chose that I received the confirmation text on another device
  • On my old phone, I clicked the link and it displayed a QR code in the LCL app (you don’t need to be connected on the app)
  • On the e/OS device, the app asked me to scan this code and it worked fine!

Advanced Privacy was not on at this moment as I just forgot to turn it on so I don’t know if it works with it on. But after that step, the app seems to work fine with it.
Thanks for the help!

…just to remember that there is an editable table in the first post.

The facial recognition functionality from Nubank app (Brazil) didn’t work for me. That is needed to validated your account ans unlock full capabilities of the app. I’m using a Xiaomi POCO F3. The function uses the frontal camera to take a picture of your face, but every time I tried the image was out of focus and the app didn’t accept it. Need to ask Nubank to to change the method of validation for me. After that, the app is working fine.

I have experienced the same with N26. I could not find a solution so far. Please let me know if you find a solution.

1 Like

Hi there! I sent a message to Nubank through the help desk, reporting this problem. After some attempts, they changed the method of ID validation, allowing me to send a selfie-picture with a document. Now the app is working normally. Hope you can solve your problem to.

1 Like

Some time ago I tried the RBC Canada (Royal Bank of Canada) app and it did not work. I had downloaded it from their website. I have since downloaded it from the app store. It is working now. However I will probably never use it, privacy ratting is 0/10 and I generally won’t use any banking app on a cell phone.

Spain / Caixa d’enginyers/caja de ingenieros / Caixa d’Enginyers Banca MÒBIL is working fine directly from App Lounge, in the main features used at everyday using. Didn’t check fingerprint.

Testing romanian banking apps:

  1. Revolut - Works great.
  2. ING Home’Bank RO - Works great.
  3. BCR George - eToken doesn’t work: ‘Out of security reasons, eToken is not working on phones that had their administrator protection removed or that are running modified operating systems. 112.1491.0.9007’

Hello from Spain.
The Triodos Bank app works perfectly on my Samsung Galaxy S4 with Lineage OS 18.1. The operation of the fingerprint could not be verified because the device does not have it.
Best regards.

I can confirm few UK and Polish ones.
In Poland I use:

  • mBank, (also eMakler app)
  • Alior Bank

In the UK I use:

  • Nationwide (already on the list)
  • Revolut
  • Starling Bank

Also Cushon pension/investment app works very well.

(al of them worked well a long time ago already, since version 1.0 or so, I am using FP3)

Has anyone noticed issues with Nationwide not loading with the latest update ?

App version : 28.1.1

/e/ OS version : 1.8.1-s

It was working previously to this on Fairphone 4 with locked bootloader.

1 Like

SG (former Société Générale) works fine App version : 4.20.4
Paylib for SG (Paiement sans contact) App version : 2.0.19
with shelter, magisk, and (!) ADB (USB debugging) disabled.
On FP3.