Mi4C TWRP boot loop

Hi !
I’ve used /e/ for a day (I had to use twrp-3.1.1-0-libra) to properly boot on TWRP. I’ve flashed the e-0.7-n-2019101126749-dev-libra released with ADB Sideload and everything worked perfectly.

I got the notification for the recent update, downloaded it and tapped “install”, it seems to install something, then rebooted on TWRP repeateadly.
I’ve tried to install an older version with ADB or by coping the .zip at the root of the phone and install it from TWRP install menu with no result.
I tried to use an older version of TWRP, with no effect at all.

While transfering files by ADB, the installation process seems to be 2x faster than what is shown on the windows cmd screen, but I have no error message.

If I try to manually reboot the system in TWRP, I got a “are you sure ? There is no system installed on your phone”.

Can somebody help me ?
Thanks !

Things are getting worse : I tried to install a regular Mi4C rom but in the end the phone keeps rebooting and I can’t boot on recovery mod. " adb reboot recovery"commande sends a “can’t find device (null)”, and every solution on the internet is related to a driver problem, but as I could have used this command by the past I doubt it cames from my PC android drivers…

Have you already tried to re-flash TWRP from fastboot? You might want to try a newer version from HERE.

Can you boot into Fastboot ?

  • If no, you’ve bricked your phone, I got the same thing on my cactus, Redmi 6A, it was covered by the warranty.

  • If yes, flash MIUI with MiFlashingTool, do not try to flash manually or things will get worse.

Where do you downloaded /e/ image ? /e/ version 1 is out, the image you’ve flashed is 0.7 if your phone isn’t bricked, try to directly install the latest version.

PS: When you have a bootloop on a Xiaomi device and wiping data or flashing another zip do nothing, you have to reflash MIUI…

Thanks both of you for answering !
The TWRP 3.3 could be flashed to my device so I have now access to recovery mode :slightly_smiling_face:

I couldn’t find a file to flash with MiFlash, it asked me a “flash all.bat” file that I din’t have. So I flashed a xiaomi.eu_multi_MI4c_6.9.29_v8-5.1 rom with TWRP (I know it wasn’t a good idea). The system keeps rebooting but with progess bars so I still have hope.

Do you have a link to a simple file to flash with MiFlash ? Or a tutorial ? I was only able to get tutorials explaining how to use MiFlash for flashing Fastboot (but it’s the only thing working on my phone so I won’t).

However I wasn’t able to locate the /e/ v1. The official tutorial keeps pointing to old versions of TWRP ans to 0.7 versions of /e/ (https://doc.e.foundation/devices/libra/install)

Thanks !

Ok,here some updates.
The first flashing (manual with TWRP) didn’t work, as you predicted. The system kept rebooting.

I then flashed the system with Fastboot mode but it also kept rebooting. I used TWRP to wipe everything and reflashed the system with Fastboot. It works fine now with MIUI 10 installed. So happy !

I’m about to flash /e/ again but would like to have the 1.0 rom if someone has a link…

The tutorials are here :

https://c.mi.com/bd/miuidownload/detail?guide=2
This ROM din’t work for me (there is only a Mi3/4 rom and no Mi4C, maybe it’s the reason why it failed to flash with fastboot (got a 0xffffff error)).

This worked perfectly to flash with flasboot :

Nice to see you succeeded! I also suggest you take a look at another topic about our model: Installing latest 0.7 build on Mi4c (libra)

For MiFlash you have to download MIUI from official website (http://c.mi.com/miuidownload/index) then unzip the downloaded file in a folder on your computer then select the folder in MiFlash.
(it will reflash ALL the system, including recovery and boot partition and Fastboot in the latest version)

EDIT: Seems the latest version for libra is 0.7 and nougat, can you try to build a new version or maybe ask @Unknown to build ? Fastest and easiest guide for building unofficial /e/ rom

EDIT2: Lineage stopped supporting libra, idk if script provided by Unknown will work.

Found why is there a bootloop on TWRP :
The system is waiting for you to install the update manually on TWRP : [HOWTO] Update /e/ (section 2 part B)
Problem is solved :grin:

Thanks everyone :slight_smile:

I’ve reflashed TWRP 3.3 after the MIUI reinstall, then used the classic tutorial with the latest 0.7 rom and everything went well !

Too bad I discover the update tuto too late, I’d just had to go into the right folder in TWRP and taped “install” and I’d have no issue ^^’

Going to “HOWTO” then “Update” was not my first idea when having trouble…

Anyway I’ll try /e/ in the end so thanks again everyone :slight_smile:

1 Like