Missing apps in /e/ app store

Newer Versions of /e/ include this feature. I have installed /e/ on an FP2 and found the “App-Suggestion”-Feature.

How can I request a new app in the /e/ app store? I did not find this feature.

In the settings of Apps you’ll find an option to request missing apps.

Thank you! I’ll try it!

In 2019 when I started using /e/, I requested some apps that were missing in the /e/ app store.

After a while some of them became available for installation, but 2 years later I remark that some others are not yet. If I launch a new request, I get the answer that the app is already available or already requested.

Is there a way to check why these apps are still missing despite the request? Or to open a ticket for that?



I am also wondering about the progress of an app request. I am not even sure that the request was entered correctly, since I never saw a confirmation. I posted a separate topic before I noticed this one (Checking progress from Google store to /e/ Apps).

If someone knowledgeable (which is not me) can write a comprehensive discussion of installing Apps under /e/ OS, that will be very helpful.

The remainder of this post is just general muddled musing on the organization of Apps, which might help a knowledgeable person understand the low level of understanding of potential readers.

I have the /e/ Apps store, and something called F-Droid. I just read about the Aurora store and found a [HOWTO] for using it ([HOWTO] Download every app in the Google Play Store thanks to Aurora Store). But I am reluctant to have 3 different routes for loading Apps, and I don’t understand the long term implications. E.g., if I pull an App through Aurora, and it appears later on the /e/ store, I probably want to switch over. Would I have to check regularly for such things? That’s just an example of a bit of confusion that perhaps could be fixed by a good document. I appreciate that it is not easy to organize these [HOWTO]s, so this is just a soft suggestion, not a complaint.

1 Like

As I read more about installing Apps with Aurora, as well as with the /e/ store, I find that I don’t understand the difference. Do /e/ programmers clean up the apps, perhaps purging some Google dependencies? Do they vet them for some good qualities? Is the main point to anonymize the use of the App? One person mentioned that Aurora violates the Google terms of service in its anonymous access. Does /e/ satisfy Google while providing anonymity? Is it possible to install Apps directly from Google Play? If so, what exactly am I exposed to? If it were merely letting Google know that I have the App, not so bad. If it allows Google surveillance to run within the App, much worse.

Any sort of general explanation of the App world would help. My new Teracube with /e/ OS is the first “smart” phone that I have ever used, so I cannot update a previous understanding of Apps by just considering the changes made by /e/.

No. /e/OS developer do not alter the apps that come through the App Store. You can check this using a PGP signature check, or a checksum.
We also do not share any inputs with google regarding this. The point to be noted is if a user is installing an app like WhatsApp or Facebook on top of /e/OS then their information is for sure going to pass on to Google through these particular apps. Also not all apps that can be installed on /e/OS will work as some have a clear dependency on Google code. You can find a list here.

1 Like

Thanks. That helps a lot.

I am still not totally sure of the point of the /e/ App Store. I am guessing that anonymizing the download of the App is a key advantage (but, as you point out, there may be further surveillance through the App), and that you include only Apps that will probably work with microG. Also, some of the basic /e/OS Apps are probably not in the Google Play Store at all.

This post by Gael on a connected topic seems to imply that the main point of the /e/ App Store is to download anonymously.

Going on to the Aurora confusion, it seems that there is no disadvantage to an App downloaded through Aurora vs. the /e/ App Store, but the use of Aurora itself requires some work to avoid conflict with the /e/ App Store on items that are in both.

The app store is required as we cannot use the other existing repositories as is. We will be making some changes in the app store as part of the next release. You can read the details here
You as the user can decide which store you want to use regularly.

1 Like

These two consecutive FAQ entries give the best information that I can find regarding requests for apps: FAQ entries

I am missing the “requst an app” feature in the new App Lounge, is it a bug should it be like this?

It shouldn’t be needed because - from what developers have said - App Lounge gets it apps

  • direct from Google’s Play Store, for non-FOSS apps. Some apps in the Play store are geo-restricted which may mean they don’t appear for you. This is the case in Aurora Store, and there is a known solution for that. I don’t know whether the same problem (or solution) is present in App Lounge.
  • from F-Droid via cleanapk.org for FOSS apps. cleanapk claim to get their apps direct from F-Droid so, as far as I know, if an app is available in F-Droid it should be available in App Lounge

Which app are you missing? Is it available from F-Droid and / or Google’s Play Store?

That makes a lot of sense, and I should have come up with this answer myself if had thought it through thoroughly, sorry!
It just shifts my problem know:
There seem to be compatibility problems with the “Lego Boost App”, I need it for my kids… :slight_smile:
Thanks for taking care anyway!

On 2022 March 24 I requested com.tyloheloinc.saunalogic in the /e/ App
app. A week or so later it appeared in a search on the /e/ application search Web page (Searching for “sauna”). But I cannot find it in the App app on the phone. I now get the error message: “Something went wrong! Please try again later.” A few weeks ago, I got a different error message but neglected to write it down.

I also tried to request a Garmin Connect app, and got a message that it was either already in the App store, or already requested. Several Garmin items show up on the Web page (searching for “garmin”), but not that one. A search in the App store on the phone gives the same “Something went wrong!” error message as the sauna search.

Search on the phone finds other apps, or gives the more normal message that the app is not found.

So, I suspect some general problem with recent additions to the App store repository, rather than just with my particular App. Before making it a special support ticket, I thought I should explore possibilities. E.g., perhaps there is a glitch in the transition to App Lounge. If the Lounge is coming soon, and will fix the problem, I should just wait for that.

In case it’s relevant, I have a Teracube with preinstalled /e/ delivered on 2022 Feb 26. I updated to system version 0.23 in the middle of the issues described above, and did not notice any change. I can’t remember whether the phone came with 0.22, or whether I had already upgraded once before.

It will fix it. Just wait…

1 Like

Thanks for the info MRTN. Is this authoritative word from /e/? In any case, is there any estimate how long to wait? Even a fuzzy estimate will help.

It will fix it. Just wait…

Is there a way to add Fdroid repos to App lounge, for example izzyondroid? Or do you have to have fdroid as well, with app lounge to get repos working?

App Lounge is already available on the DEV channel, and would later become available on the STABLE channel as well. I haven’t read anywhere what date, but I expect it to be with the v1.0 release on 24 May.