Mobile data issue on S7 after upgrade to v1.0

I uptdated my Galaxy S7 (SM-G930F) via OTA (it’s an /e/-shop -device on stable)
from 0.19-20211023142428
directly to 1.0-20220526188859.

The main issue now is a very inconsistent “availablity” of mobile data.
A number of apps do not get access to the internet via mobile data at all. Others do.

Yes, mobile data is activated
Yes, I doublechecked and granted permissions for apps in system network settings.
And I checked every setting I could find or think of (system- and app-settings).

I do not see the systematics in this behaviour, no clue what specific app- or website-property is responsible.

  • signal cannot use mobile data at all (but states an "active background connection), no messages are sent or received
  • browser: (the oddest part of it) some sites are loaded (not from cache!), some do not: “no internet” (for instance all the browser internal search engines do not get internet access. but when I type the google adress in the adress bar - it works…
  • app lounge crashes completely when no wifi but only mobile data is available
  • nextcloud: no sync possible via mobile data

I do not know what more information is valuable or helpful for root cause analysis…
I´d be happy to try to provide more information to anyone who knows what to ask for specifically.

Apps that DO work with mobile data: wikipedia, FairEmail, DAVx5

I did not experience any problems with any app or service with Wifi. Under Wifi everything is OK.

(few other hickups described from here: Samsung s7 updates - #16 by obacht)

edit: clarifications

Hi @obacht pl can you raise an issue on Gitlab if not already done. In case you have raised it pl share the issue ID and can have developers look into it.

To raise an issue on gitlab check this guide.

I also had some trouble with the update of a samsung S7
first i had to reinstall signal , seems to be normal with the update of the system
after i found that my adressbook was empty . so i send all adress with ecloud
now i have two accounts for my adressbook: one local (empty) and one @e.email
signal doesn’t see the the account @.email what can i do?
there was some adresses ( about 10) missing one my ecloud account so i put them directly on the phone
a few hours after finishing my local account had only one person with ten phone numbers
the sms and the messages on signal were from the same person
i have deleted everything in my local account and reinstall signal
what to do next?

i use contacts 1.7.31

Hi @Manoj I just created the issue on gitlab: #5668

Hi, I have the same problem. Everything works via wifi, but via mobile Data I cannot send or receive E-Mails (I use K-9 and Nine) oder messages (Signal and Telegram).

looks like there´s light at the end of the tunnel… :slightly_smiling_face:

I got inspired by @RD138 No mobile data connection on S7 edge - #5 by RD138

Other than in his solution/description there was no proxy defined in my APN-settings that I could delete… but I doublechecked the recommended APN-settings for S7 at my providers support-page (congstar). There is only recommendations for Android 6+7 available but in terms of APN-settings they are the same.
So I tried and changed APN from “internet.telekom” to “internet.v6.telekom” as specified by congstar and left all other settings untouched.

et voilá: mobile data available again for e.g. signal-app…

The other apps and websites seem to have access to internet via mobile data as well!
As of now I can say that only app-lounge still crashes often (but after a few restarts at least has internet access via mobile data). There must be some other issue with that app that has little or nothing to do with mobile data…

I recommend to doublecheck APN-settings if mobile data access on V1.0 is an issue. It´s worth the try as it seems :smiley:

edits: clarifications

Hello obacht, I’ve done the change from “internet.telekom” to “internet.v6.telekom”. After that, access via browser (Firefox Focus) was possible, but I still cannot send messages via Signal oder E-Mails via my clients (Nine und K-9). There seems to be another issue/problem…

@Lorenzobianco thanks for testing!
too bad it´s not the overal solution :slight_smile:
I´ll add this data-point to the gitlab issue…

I can confirm that checking and adjusting the APN settings got the browser back online on mobile data. Though I also had to switch vom “internet.telekom” to “internet.v6.telekom”. Although this is not clear to me, since “internet.telekom” works on other phones.

Doublechecking and adjusting APN settings according to network-provider specs seems to be a promising approach.
It solved the issue for me and a number of other cases - but still not for all cases.

Strange thing is: APN settings used to work flawlessly before the upgrade (from what I know = least in my and some other cases that were reported).
Seems like something happens to APN in the background during update.
That something with APN may be just a symptom of some other issue - yet still it obviously results in either a total failure of mobile network availability (= for all apps and websites) or it may affect just a few apps and websites whereas others still get access.
And it may least partly be healed by different APN.-settings.
I do not see or understand the systematics (or the real issue -if there is one)… but collected what I could find and updated the gitlab-issue (that I linked above already)

Well in the case of an upgrade data is wiped. But it might still be more than this! My money (speculation) is on carriers routinely using Google servers to check in some way that APN are up to date on the device.

APN settings seem to keep changing around the world as technology and international standards change.

I have my carrier on speed dial. I pay for the service, if it is faulty I phone them. Others report that they refrain from this due to the calls being chargeable. This would be unsatisfactory to me. :frowning_face:

I can read the published APN settings, but they have become too detailed for me and it seems 2 times in 12 months my carrier changed APN.

However when I call the carrier, new APN settings are sent within a few hours and are applied automatically. Last time I called I was briefly quizzed about my device as if the operator was surprised the change was not applied automatically.

good point, makes sense.
Now that you say it I can make the connection :roll_eyes:…I experience that every once in a while with the data-modem of my bee-scale that can only be configured manually - it´s a constant struggle …
I´ll doublecheck with customer support of my provider

edit: … but… where did the settings come from in the first place after upgrade when they were wiped during upgrade… where else than from the provider? maybe some generic set instead of device specific?