Motorola - Moto G5 - cedric - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

I’ve just successfully installed e/os v1.4 on my moto g5 xt1676 and I have a suggestion about the installation guide. For me a vital step was missing.

My G5 had firmware older than android 8.1 and I couldn’t flash it with any of the e/os versions available under the link in the guide (ranging from v1.0 to v1.4). The first signal that something was wrong was a “mismatched partition size” message when installing recovery. Despite the message it launched but when at the 47% of the sidelining process it aborted with this message: “‘This package requires firmware from an Android 8.1 based stock ROM build.”.

This issue was already raised in the community here: Cannot install /e/ 1.2 update on Moto G5

What I had to do is to update the firmware to stock android 8.1 and only then I was able to flash it with e/os. I then had no issues with recovery and sidelining. (BTW, this guide to update firmware worked fine for me:

Thus I would suggest adding this step (in case of older firmware) to the guide as many of the moto g5 could still be running older stock firmware. I think this may help some less informed wannabe e/os users.

Hello and thank you for sharing your experience !

I’m the fresh new owner of a pair of Moto G5 - Cedric devices, thank to the fact it’s a cheap one on second hand market (I’ve just buy one for eight €, yes, you read this right).

I have issue with the flashing process, because the OEM unlock just let you flash thing, but the recovery isn’t persistent.
The device I run test on might be of an older firmware version like in your case (I got the same This package requires firmware from an Android 8.1 based stock ROM build.), so your feedback is valuable to me.

However, the guide you point look buggy to me :
in the command to flash the firmware, there is

fastboot flash vendor vendor.img_sparsechunk.0
fastboot flash vendor vendor.img_sparsechunk.1
fastboot erase carrier
fastboot erase userdata
fastboot erase DDR

but the zip doesn’t contain any vendor.img

Further more, I’m no sure fastboot erase carrier is a command I want to run …

So I looked further through the internets and found out that the list of fastboot commands are specified in the flashfile.xml within the firmware zip (source : XDA).

Now i know what to do.
I hope this could be useful to others.

EDIT : it was for me, I now have a Motorola Moto G5 running /e/1.17 !

1 Like

You’re right about the commands. Thanks.

BTW I’ve just installed the latest /e/os on another Moto G5, so now also my brother has one with /e/os, my mum… and counting, because probably my daughter will soon get one as her first phone.

1 Like