Multiroom audio

app-suggestions
microg
issues-for-gitlab
support
user-experience

#1

Has anyone already controlled a speaker with /e/ ? With what app or what multiroom standard?
There is Spotify Connect that works for Spotify. What else?


My experience on Sony Xperia XA2
#3

Has anyone tried an open source Linux media server for Raspberry Pi to control a speaker with /e/ ? (runeaudio moodeaudio osmc volumio Pimusicbox)@vincen?


#4

Should chromecast work by default on /e/? I don’t know how to enable chromecast in antennapod (I installed it just to try that) and my chromecast doesn’t show up in Spotify.


#5

I heard the same from someone on this forum and wonder if, since we can’t use Chromecast, a Linux media server installed on a mini computer like the Raspberry Pi would work ?


#6

Just installed Youtube as apk. Chromecast button is there and works.


#7

Chromecast works on /e/. As mentioned above download as an apk and connect the app to your device normally.


#8

Chromecast state for me is:

Working:

  • Youtube (installed as apk)

Not working:

  • Spotify (installed via Spotify installer from f-droid)
  • Netflix (apk)
  • Google Home (apk)
  • Any other app from f-droid that might have CC support (Antennapod, SkyTube, …)

Google Home doesn’t find the Chromecasts and all other apps just don’t show the cast icon.

At the same time my Chromecasts (one Video, one Audio) work just fine from my wifes iPhone (CS Video with Netflix, CS Audio with Spotify) and Chrome Browser (CS Video with Netflix) on MacOS. Before installing /e/ I ran Lineage and Spotify worked well with my CS Audio.

I’m running /e/ 7.1.2 nightly 0.1-201812152239.


#9

But download what ? as Plex app on my phone doesn’t see anymore any of my Chromecast devices since I switched to /e/ !


#10

@vincen I was trying to check this. I downloaded Youtube apk and it connected to Chromecast and it worked.


#11

This is literally the only one that worked for me, everything else doesn’t. Could you check something else, please, for example Netflix or Google Home.


#12

That’s not what I name a real test !! Youtube is a google app so you can expect it to handle all Google things !! It has to be done with third-party app as I guess most of them don’t include Cast library but use the one of the host system (which is a problem here as /e/ has none or nearly of these libs and micro-G has probably no implementation too for it yet :confused:


#13

That is right. Some of the core google apps do not work with Microg for e.g. Googlepay ,google home does not find the chromecast at all.
The point I was trying to check was if a user has chromecast device and /e/ how could he get it to work. So directly installing the youtube apk gets chromecast to work.


#14

I’m pretty sure it’s not a side app that will get the feature back in other apps !! It’s really libs in micro-G missing for these features :frowning:
For youtube how did you do the test ? I installed Youtube app on mine but I don’t have any button to do Cast to my Cast devices ! or it works only with video Chromecast ? I have only audio ones here !
I tried also Google Music but same as Youtube, no cast button anywhere in interface !


#15

On the Youtube video I see the icon on top right to cast to device


#16

no cast icon on mine (OnePlus 3 with /e/ 201812152239 ROM) :frowning: Do you have video or only audio cast devices ?


#17

It is a first-generation video-capable Chromecast device. Like this

220px-Chromecast_dongle


#18

@vincen: Sorry to say that but your tone seems quite aggressive here. I can - literally - feel your pain, but @Manoj is just trying to help here.

@Manoj: Installing the Youtube apk gets Cromecast to work with Youtube. But the whole point of Chromecasts is to work with many sources. I would like to use it with Netflix, Chromium, the included Music app, Spotify, …

Yes, indeed. I have both, Video and Audio and Youtube only works with Chromecast Video. The only app I’m using on a regular basis which works with both - Audio and Video Chromecasts - is Spotify. And on /e/ neither works.

So the bottomline here seems to be: Chromecast is not working on /e/, except for Youtube from apk. I don’t know what’s the reason but @vincen’s explanation of Android usually including a library for Chromecast that isn’t present on /e/ and Youtube having said library included would explain the symptoms.

@Manoj: where exactly should I file this as a bug?

Niko.


#19

You can file the bug here https://gitlab.e.foundation/groups/e/-/issues


#20

I did: https://gitlab.e.foundation/e/management/issues/197

@Manoj: is the description etc ok?

@vincen: if you think the issue describes your problem you could give it a thumbs up. If not: Please make a comment or open a new issue.


#21

Sorry was not the goal at all, just chatting with niko to find out if there is a solution or if we are stuck with that problem for a while :wink: Sorry if I gave a different impression (I’m not english native too…)

Yep, thanks for having posted the issue on the bugtracker, I added my thumbs up and comment :wink: