Murena One : v.1.21.2 release : with fix for wifi and bluetooth functionality

Attn: Murena One users

As you may be aware post the v1.21 release users experienced a lost of wifi and bluetooth functionality on their devices.
We have rectified the issue. v1.21.2 build specific for the Murena One device is being released.

Since you do not have wifi access you can use the following method to download and update the build:

Please note the download will be 1 Gb in size

For consistency in the installation method for the v1.21.2 build, we have added the instruction on gitlab

We regret the inconvenience caused.

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone



firstly thanks for taking the issue that serious and supplying the patch that quickly! Highly appreciated!

I followed the instructions you shared and choose the adb sideload approach and came across the following issues:

  1. Signature verification fails but can be skipped. So I did continue anyway.

  2. adb wait-for-sideload sideload command fails with error message Failed to find update binary META-INF/com/google/android/update-binary

Anyone having the same trouble or advice how to successfully apply the build?

Remark: I did NOT do any data or factory reset before.


I downloaded and verified the sha256. When I try to sideload it I get a message on the phone. “Signature verification failed”. At the bottom it presents the following:

Now send the package you want to apply
to the device with ' adb sideload <filename>"...
Supported API: 3
Finding update package...
Verifying update package...
E:footer is wrong
Update package verification took 0.1 s (result 1).
E:Signature verification failed
E:error: 21

I cancelled the process, and am waiting for further information.

Edit: An issue with the wrong install file referenced in the install instructions was addressed in the meantime.


The linked guide says “Have the OTA zip linked downloaded”, but …

… the files there are not OTA ZIP files and can not be ADB sideloaded (they are for installing with fastboot according to their content as well as the Murena One command line install guide).

For Murena One users on stable (how to check), the OTA ZIP file is available here … (note the missing “IMG-” in the filenames).


Maybe @c.jordan and @Unsorted7674 … you should wait for an edit of the OP … but we have a convention … that …

  • “fastboot /e/OS ROMs” have a leading IMG in the filename

… but a sideload ROM would be expected to have a name

  • in a format similar to

as alluded to by @AnotherElk.


Download and extract both (mentioned above) install candidates to :


~/test/murena-one$ ls

1) Leading “IMG”

~/test/murena-one/IMG-e-1.21.2-s-20240403391680-stable-one$ ls
bin-linux-x86         gz.img                                  spmfw.img
bin-msys              lk.img                                  sspm.img
boot.img              logo.bin                                super.img
cache.img             md1img.img                              tee.img
cam_vpu1.img          MT6771_Android_scatter.txt              teksunhw.bin
cam_vpu2.img          preloader_g1970upt_v2_gk_p60c_oj_r.bin  userdata.img
cam_vpu3.img          preloader_ufs.img                       vbmeta.img
dtbo.img              recovery.img                            vbmeta_system.img  scp.img                                 vbmeta_vendor.img

Loosely speaking this is a “fastboot ROM”

2) sideload type download

~/test/murena-one/e-1.21.2-s-20240403391680-stable-one$ ls
boot.img                    META-INF               system.transfer.list
cam_vpu1.img                preloader_ufs.img      tee.img
cam_vpu2.img           teksunhw.bin
cam_vpu3.img                product.patch.dat      vbmeta.img
dtbo.img                    product.transfer.list  vbmeta_system.img
dynamic_partitions_op_list  recovery.img           vbmeta_vendor.img
gz.img                      scp.img      
install                     spmfw.img              vendor.patch.dat
lk.img                      sspm.img               vendor.transfer.list
md1img.img                  system.patch.dat

Loosely speaking this is a “sideload ROM” complete with META-INF

1 Like

Hey @AnotherElk and @aibd,

many thanks for your help.
I can confirm that I successfully patched that build.

As I would love to give back something to the community, I would voluteer to to write a documentation / HOWTO collecting all the different aspects into one article.

Please let me know what you think of the idea.



… nice idea … …

Thanks for the clarification, that was very helpful. And thank you /e/ support for the quick turnaround. I’m back in business.

Thanks for pointing that out. I have passed on the feedback to the developer to check.
Apologies for the confusion. In the hurry to get out a solution, we did not share clear instructions. Will have the steps checked by the developers during EU working hours.

Update: For consistency in the installation method for the v1.21.2 build, we have added the instruction on gitlab

Is it possible to provide the community with an explanation of how this issue was caused and whether it can be avoided in the future?

1 Like

This issue was specific to the Murena One. It was an error in development while trying to fix support for Bouygues SMS (French carrier). v1.21.2 reverts the changes. The fix would now be available in v2.0 . An outcome of this issue is enhanced testing routines in the future.



thanks for fixing wifi. But bluetooth is still not being activated. Just like @1.21.1, more details later.

  • /e/ version: 1.21.2-s-20240403391680-stable-one
  • Device model(s): Murena One
  • Developer mode enabled: yes
  • Device rooted: no
  • Trackers blocker enabled: unknown

OTA-update fixed Wifi and Bluetooth problem on my Murena One, another big thanks to the team for your great work!

Update performed and WiFi and Bluetooth functionality is working again. Thank you for a fast response in solving such an important issue.

Link to the installation of the needed “adb-tool”

Direct Link to the working

  1. Boot the phone to recovery mode

  2. Choose “apply update” then “apply from adb”

on the computer,

  1. open a “terminal” or a “command prompt” in the folder where the file is, and type
    adb sideload

how did you install it? sideload or update over mobildata?

Bluetooth after restarts and toogling nfc still not working for me…

(The first post was also edited accordingly.)

Hi @Manoj, @piero, @AnotherElk, @linket, @jmzama and @aibd,

as promised I wrote a HOWTO summing up all the distributed information.
I hope, it can be uselful for someone. Feedback highly appreaciated.

You can find it here.


1 Like

OTA update over mobil data

After thinking about what may the difference… I found it “Bluetooth-Gabeldorsche” was actived.

1 Like