My phone does not recognize usb stick

Same for me : I could connect and use without any flaw at least 2 USB keys through an OTG adapter with my S9+ (not tested with current e-OS 1.11, but a few version before it was OK).

S3 is quite old, it may not support OTG?

@jpmeuret @aibd Hello . Thank you very much for your answers. I would like to add a little information so that it is clear that I understand what I am asking a question about))
So my flash drive is formatted in FAT, I have an original cable that connects to another phone and everything works fine, I also have an OTG adapter that also works well when I connect it to another phone and the phone immediately reports that a USB drive is connected. I tried different settings now i use no data transfer option connect with pc without problems. i have one suspicion but i would like to know your opinion. i installed the firmware everything works the phone is ringing but when i checked the bootloader i saw that it doesn’t match what is indicated here Could this be the cause of my problems?

In what way does it not match ?

My first guess is to check

Models Supported
Other models are not supported

@aibd Hello . Thanks for the answer . My phone model is Samsung S3 GT-i9300i Models Supported

My bootloader - i9300ixwsbqb1
Special requirements Your device must be on bootloader version: I9300IDDUBQE2

I installed the ROM, everything works except USB, so I wanted to clarify if some changes were made, for example, it is forbidden to use USB by default, you need to enable this function in the settings, etc.

1 Like

Your device must be on bootloader version: I9300IDDUBQE2

You will find I9300IDDUBQE2 there : (choose your country/CSC)
or there :Ⅲ__Neo__/58z2/INS/I9300IDDUBQE2/I9300IODDBPF1/ (choose your country/CSC)


OTG/USB only works on my Galaxy s4 and s4active but not on my s4mini.
Charging during OTG don’t works
MHL/hdmi or MHL/vga don’t works
For my devices
scrcpy works
USB files tranfert works
USB internet sharing works

1 Like

@piero Hello. Thank you very much for the detailed answer. Clarification on your answer.
Do I understand correctly that I have to reinstall the bootloader using windows (ODIN 3)? Or can I do it using linux ?

I would not like to use Windows))

After I reinstall the bootloader, I need to reinstall the ROM, right? There is a chance that USB can work …

installation of the Stock Samsung Firmware

@piero Hello . Thanks for your answer and information.

I wanted to ask you and clarify some questions, I see you are well versed in this issue.

  1. Why is it written in the documentation that this instruction will only work with bootloader I9300IDDUBQE2 > but in reality I installed it and everything works with another bootloader. Maybe need to change this recommendation? Now USB does not work, but it is not known for what reason …

Caution: Your device must be on bootloader version: I9300IDDUBQE2 otherwise the instructions found in this page will not work. The current bootloader version can be checked by running the command getprop ro.bootloader in a terminal app or an adb shell from a command prompt (on Windows) or terminal (on Linux or macOS) window.

  1. Concerning setting (installation)
    Correct me if I’m wrong. I download a general archive which usually contains 4 files (firmware, modem, bootloader and language settings if I’m not mistaken)

I also download ADB, Odin 3 and Samsung drivers, then I translate “Download Mode” I connect, I see that the phone is connected (Odin will inform me about this -ID: COM will be blue) then I select AP >> tar.md5 file and click start and wait for the firmware to be installed.

After that I check and I should have I9300IDDUBQE2

Bootloader is not in AP but BL
It is not include in boot.img but in aboot.mbn

About restoring Samsung Stock Firmware :

Using Odin, you must install the four .TAR.MD5 files in one shot.
Using Heimdall, you must have a look to the .PIT file,
and flash all the files exacted from the .TAR.MD5 files (.IMG .BIN .MBN …) to all their related targeted /PARTITIONS

1 Like

That is certainly herited from lineageOS wiki,
Should we understand it as “latest android 4.4.4 kitkat based samsung firmware” ?

@piero Thanks for your replies.

I installed the firmware, doing everything that we are discussing here, but on another GT-i9301i phone model (screenshot below), it does not make a difference, since the documentation has the same recommendation for bootloader, but it did not work, I think this is a bug. I have two more phones, one has Guava installed, I took the same adapter cable and a USB flash drive and everything worked right away.

I can connect to PC without problems.

I may have made a mistake, so here are my steps:

  1. I downloaded this firmware same as here

  1. I unzip the downloaded file, I get a file with an MD5 index

  2. Installed Odin 3, ADB, Samsung drivers.

  3. Put the phone into Downloads Mode

  4. Opened Odin, connected the phone via USB cable, everything went well, I see a blue backlight in COM

  5. I press AP and insert the MD5 file (I wait for everything to go right)

  6. I press start

  7. Everything went well.

  8. Download and install recovery from /e/ foudation

  9. Factory reset etc

  10. Download and install ROM from /e/foundation

Everything went well.

Where did I go wrong or what did I do wrong?

@Manoj Hello. Can you please tell me if this is a bug or did I do something wrong? I have this problem on two phones. Everything works except USB, which is not very convenient for transferring information. I did everything as in the documentation but it doesn’t work. At the same time, I connect to the PC via cable without any problems.

I am affraid OTG is lineageOS dependent.
file transfert via USB to PC works
file transfert via SDcard works
file transfert via Bluetooth works

1 Like

Had problems with USB-stick connectivity on my Sony Xperia as well, got a tip here in the forum to restart it with the stick connected and it worked! Easy to try also:)

1 Like

@MaxO Hello . Thank you very much for your answer and recommendation. I tried it did not work, I think it’s a system error, need to optimize the ROM. The flashlight doesn’t work either.

I tried to insert a flash drive (SD card) , it is formatted in vfat, everything works fine.

This is 100 bug!

@piero Hello . yes, you are most likely right. I need to sell the phone and buy another one, since it’s not very convenient to work without USB.

Please tell me which phone is more optimized, for example Samsung s5 NEO? Which models won’t have this problem?

And / or is it a way of pointing us to the latest, or final software revision ?

Having found that you had a different bootloader, perhaps that could be taken as a clue that you had not reached final ?

If you were to search again for the latest ROM, in light of what you now know, perhaps you would find a software revision ahead of what you have running now, and includes the correct bootloader ?

Searching online it does seem folks were saying OTG was still flaky leading up to Kitkat, 4.4.4.

With /e/ running it might be interesting go to

Settings > About phone > Android version … and note the date quoted for Vendor security patch level. In searching for a different Samsung ROM, might you see if you find any software revision date in advance of that ?

@aibd @piero @Manoj Hi all . So that there is no doubt that I did something wrong, I am attaching a screenshot and video. It seems to me that ROM does not work correctly on this phone model!