New update/setting app keeps stopping

I just installed the new update for my Samsung S9+ and now the setting app keeps stopping.
Any ideas?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

a logcat would be invaluable. You can add on-device logcat apps, but its such an amount to scroll through. Can you debug with adb as in Create a log @/e/ ?

Hello Tcecyk,
I tried adb on my old Mac but that wasn’t a succes.I already tried different launchers and test "netwerk and internet"but that keeps chrashing.All my other "settings"work as normal.
In the past the old e/OS/ stayd on device,so you could install an old version,but now the updates dissepere.
I had no problems with the e/OS/20 dev.
Its’s very important that I can set private dns and so.
Greetings Johan

There is a setting in Updater app which controls this

  • Settings | System updates
  • Open the ‘three dots’ menu in the top right of the window
  • Select ‘Peferences’
  • unset the ‘Delete updates when installed’ button

Hello Petefoth,

Thanks for the tip but
i looked in these settings and remove is already unchecked.
It’sall strange,first time i have a problem with dev.update.

Greetings Johan

this install looks sensible:

I don’t know how often you work in a terminal. The folder navigation you quickly understand I think. When you finally run adb logcat and reproduce the settings crash, you can either copy the last ~100 lines in the file into a pastebin or reproduce it while you pipe the adb logcat > logcat.log output into a file.

For valuable crash stacktraces, look for “Exception”, followed by lots of " at … " lines and a “Caused by:”


I’m really sorry but I know anything about computers and so.That’s wby I bought a phone with e/os/installed.
Is it possible that I send my phone to you or someone who know about phones?It wouldn’be a hurry job because I have spare phone.I don’t k ow anybody who can work on phone.Ofcourse I would pay for the work.

Greetings Johan Verstraete

You say the Settings App is crashing when opening “Network and Internet”?

Then you could try to reset “Reset Wi-Fi, mobile & Bluetooth” in the System → Reset Options as shown in Reset your /e/phone to Factory Settings (do not reset to factory settings, only the first option)

If this does not help:

make the settings app crash a few times (to make it more obvious later in the logs) and create a bugreport, one of us filters out the relevant log lines for you and creates an issue with it.

Here is a help text on how to create the necessary bugreport zip file after your crash occured and options to share it. I updated it with current screenshots: [HOWTO] Create a log (a bug report) easily without computer - #10 by tcecyk and you can also follow the original descriptions.

Share by mail (my username at or move the zip file into a synced Folder and share a link to it from the web interface.

1 Like

Hello,would be sending the v20 update for my Samsung S9+ android 10,to me an option.Its strange the v20
Update vanished because i only manually wipe an update after long time.

Thanks and greetings Johan Vetstraete

(sorry I edited my answer, you can’t see this via mail) - can you give the network settings Reset a try as described or is “Settings” crashing at the earliest when starting it?

If you bought the phone from /e/ and feel overwhelmed I think you can mail support.

I wonder if you’re affected by the S9/S9+ stable ota upgrade process hiccuping on your settings.

Can you share your /e/ version (full length - like /e/OS-0.21-2022011415… + Android 9 or 10) ? it would be included in the bugreport file if you want to create one

1 Like

The /e/ version is: 0.21-q-20220124158536-dev-star2lte and on android 10.
I’m really sorry but tha debug is asked to much for me.I don’t even remember how I maked that what I send.
The guys that work with code all the time must be able to shift whats inportant for the problem and what not,its there job.Sorry that its to long but can someone help me out?I pay for it,with pleasure.
Greetings Johan

ok I understand, no bugreport file. But can you give the Network (!) settings Reset a try? if the navigation path to go there does not crash it is worth trying:

Settings → System → (dropdown) → Reset Options → Reset Wi-Fi, mobile & Bluetooth

As last resort - and only if you have all your files backed up and are desperate, you can try the application preferences reset and finally a factory-reset. This will erase all your data though.

For local support you can post to Find Local Support - /e/ community or really any local phone repair shop has people capable to use adb. Just show them this thread.


First thank you for your effort to help me.
I did reset of wifi and bluetooth,and now i don’t have wifi anymore.
If I do factory reset,will I still have /e/OS?

greetings Johan


I tried to reset wifi and bluetooth but without result.
I appreciate the effort to help me out,thanks.
Wrote an email to Oneclickroot and hope they can help me out.
Greetings Johan

Ps: now I have no wifi

If I do factory reset,will I still have /e/OS?

yes, all your user-data and apps will be erased though. If you have your contacts synced and photos saved online or downloaded you could do it, then reinstall all your apps and setup accounts afterwards.

If this does not bother you it’s a way to go forward without outside help.