No WhatsApp update in Apps

since today i can’t use WhatsApp anymore because of a missing update! I installed it through Apps but Apps isn’t showing any update and shows an old version.
My device is a Fairphone 3+, Android version 10, e/OS version 0.16-q-20210422111920-stable-FP3
i had the same problem with Signal and I had to install it through the Signal website. I’m not doing that with WhatsApp
Please help me!

1 Like

I think the community need a little more info before they can help you…

Thank you for your answer, I’m sorry for that
My device is a Fairphone 3+, Android version 10, e/OS version 0.16-q-20210422111920-stable-FP3

You have to update/upgrade your /e/OS, the current version is 1.5 and since 1.0 the app store is redeveloped and is now called ‘App Launge’. This will fix your problem.

I also have a Fairphone 3, running pre-installed e/OS/ 0.23-20220406176461. But the System Updater says ‘No new updates found’. I’m not confident enough to do a full re-install of the latest, greatest version of e/OS/. Will a new automatic update be available soon? I can’t find App Lounge in Apps, and Aurora Store won’t load, just tells me to try again later.

I just tried Aurora Store again, and it said ‘SSL handshake aborted:’ :frowning:

I have the exact same issue as @drbobw (FP3, /e/ OS version) with android 9 and I’m no longer getting any updates, see Outdated apps in store

Can anyone explain exactly what needs updating, and why it’s not available through the normal route?


I had more than 10 OS updates (there was never a message from an os update, I just didn’t know about them) I tried to download the oldest one and it failed, so I downloaded the last one and tried to install it. After 5 reboots I get the message again and again : “can’t load android system. Your data may be corrupt.If you continue to get this message, you may need to perform a factory reset and erase all user data stored on this device” :(((((((((((((((((((((((

I also never received a notification about system updates, I only found out when maps stopped working and did some digging. After that I received the notifications correctly…

Oh no :frowning: I hope you are able to sort it and not lose anything, that’s such a pain :’(

From a bit more looking it looks like my issue is that I’m still on android 9 and the v1.x updates aren’t available for that, so I need to do some more digging about what that means…

If you have a FP3(+) and you 're still on Android 9 (pie), the only way to upgrade /e/OS is with the Easy Installer. OTA upgrade was not possible because of an ‘encryption issue’. Check this topic :

1 Like

@MRTN thanks yes I came to that conclusion and spent an evening doing the upgrade/reinstall, which thankfully went smoothly.

Can confirm that it’s working now.

Shame there weren’t any notifications in the phone to give a heads up that the system was outdated - didn’t realise I was running an unsupported version since June or something! :scream: