Notes have been deleted / Notizen wurden gelöscht

I guess it could be account misattribution, but without reproduction I can’t tell. For users who can do adb root and know how to use sqlite3 it is easy to recover, but that is not for everyone. On my device both tables are populated with the same notes.

adb root
adb shell 'echo "select content from NOTES union select content from Note;" | sqlite3 -csv /data/data/foundation.e.notes/databases/OWNCLOUD_NOTES' > notes.csv


I’m one of the users who’s notes did not sync and all my notes were stored locally on my device.

I have a SM-G965F ( Samsung Galaxy S9+) to version 1.9-q-20230310268292-stable-star2lite, Kernel Version 4.9.218.

I have months of notes that I’m desperately trying to figure out how to retrieve. Any help would be greatly appreciated!


Please can you tell us @omoney23 if you are able to make any headway with the two line method given by @tcecyk in the post immediately above yours.

1 Like

My situation on install of e-1.9-q was that very soon after restart Notes threw up some sort of notification saying I had zero Notes. Shortly after, a “timer” icon appeared informing me that 254 notes were being “copied”. I lost no notes.

I was very keen to follow up the suggestions of @tcecyk if only to learn how to backup notes from the device.

Firstly I was able to find the databases with TWRP > File manager at the location /data/data/foundation.e.notes/databases/OWNCLOUD_NOTES

I was able to copy OWNCLOUD_NOTES to the external SD card, and then copy that to a Linux PC.

I installed sqlite3

$ sudo apt install sqlite3

and experimented … hmmm.

However I am able to confirm that @tcecyk’s “Two line method”

adb root
adb shell 'echo "select content from NOTES union select content from Note;" | sqlite3 -csv /data/data/foundation.e.notes/databases/OWNCLOUD_NOTES' > notes.csv

worked for me and notes.csv found in my working directory is fully readable. Many thanks – I hope the method will also work for those where sync has failed.


Hi @aibd,

Thank you for the response. Unfortunately I am not technically inclined enough to know where to start trying that method to find out.

On another reply from another person they stated they could not find the/data/data/foundation.e.notes/databases/OWNCLOUD_NOTES folder. When I do a basic file search on my phone I see other files with /,calender,drive etc. but no “notes”.

I see also some are trying to boot in recovery to get to this location, maybe it just hidden from normal file search on the phone. I have never booted in recovery, but could try in attempt to recover my notes.


Indeed, these folders are seen by a file manager in internal storage/Android/data/

The location /data/data/foundation.e.notes/databases/OWNCLOUD_NOTES is not found by most file managers.

That is why in my case looking for the databases with TWRP seemed the easiest thing (for me).

In this post Notes on phone that wouldn’t sync lost after OS update. Any hope of recovery? - #11 by aibd I confidently said that I thought a Samsung (like yours) would have TWRP installed – however I overlooked that many devices now overwrite TWRP with /e/Recovery. (/e/Recovery does not include a file manager, so is not useful for this task.)

You might use that guidance to see if you do have TWRP recovery.

In yet another thread Notes doesn't work after yesterday update - #3 by namib it has been revealed that notes appear to continue to exist on Murena cloud. It is worth checking this in your case, as this might offer much easier recovery of the Notes.


Was there any other alternative in retrieving the old notes?

I checked the online Murena cloud and my notes were not in there. You were right with the TWRP recovery with my phone, which was not present when I tried to to boot my phone in recovery mode.

Was anyone able retrieve their notes at all using any type of method?


See above.

Usually the user has no access to this folder if the phone isn’t rooted, so simply looking for it with the file manager wouldn’t show it.
You can use TWRP to see it as @aibd suggested.
You can use the adb root command to make it accessible via ADB, which the two command lines from @tcecyk make use of to get the notes.

To use ADB:

  • If not done already, make the Developer options visible by tapping on the Build number in Settings - About phone a few times until you are being declared a developer.

  • If not done already, enable Settings - System - Advanced - Developer options - Android debugging

  • Connect your phone to a computer via USB.

  • If not done already, download the current Android SDK platform tools to the computer and unzip the ZIP file to a folder you can navigate to easily.

  • Open a command line/ terminal and navigate to the folder to which you unzipped the tools. If you are unfamiliar with the command line/ terminal, here’s a really good and short 1 page introduction to everything you need for now …

  • Enter the adb devices command to display an ID of the phone to make sure that ADB works with the connected phone (upon first usage the phone should ask you to confirm this access from the computer, there you should also be able to select that the phone remembers that decision, if you want).

To use adb root you first need to enable Settings - System - Advanced - Developer options - Rooted Debugging … if your /e/OS build has this (prior to Android 12 = /e/OS S not every /e/OS build has this).


It will be worth watching the Gitlab issue #6790 linked above. A fix is being worked upon.

For those not familiar with issues, this image from #6790 indicates progress by the dev team


If you contribute to the issue you will be kept updated.

1 Like

Basically affected users have a http instead of https endpoint configured still, and the schema redirect (from plain to transport encrypted) wasn’t handled. As this is a subset of users it didn’t trip for people testing the v1.9 release.

@omoney23 with the next update, the import activity will be able to avoid the failure mode (not handling the redirect), but if the Notes remote folder is already empty, I don’t think (and did some testing) it can recover in the current app logic, despite having them in its local db. It will prioritize the state of the remote Notes Folder.

If you had critical notes synced to prior and the method I outlined is too foreign - it’s straightforward to contact the email support and ask for a restore of the Folder.

(@aibd one can just subscribe to Gitlab issues with an account or vote on it, no comment/contribution necessary)

1 Like

Of course we hope devs can offer a fix, but …

I think you are indicating that a future OTA to e-1.10 might still not recover a user’s notes.

Do you think that downgrading one’s device to e-1.8.1 (at the same Android version) is likely to recover one’s notes?

1.8.1 is on an earlier security patch level, which should trigger Android rollback protection, which should force a factory reset, which should delete the notes.

Theoretically reverting back should work for instance from 1.8.1 to 1.8 (same security patch level), although on devices with a locked bootloader I wouldn’t know whether this is allowed without unlocking the bootloader first, forcing a factory reset, etc.

notes App downgrade? haven’t tested. After “new Notes” migrations ran (before the 301 bailout?) then you’ll possibly end up with incompatible db schema for old App. Still, could work, but seems out of proportion, a vote for the availability of signed+versioned apks of /e/ Apps though. OS downgrade would be a bit heavyhanded.

I think remote backup if you had it enabled is best. If all the notes were local…

There’s also a non-root adb method to fetch the sqlite db, but as it involves doing aes decrypt on a tar file created by “adb backup” - not particularly simpler.

1 Like

Would still be an option for /e/OS builds without Rooted debugging.

download abe.jar from release page, sqlite3 is most likely present. “adb backup” prompts on the handheld screen to set a password

adb backup foundation.e.notes
java -jar abe.jar unpack backup.ab decrypt.tar <password>
tar vxf decrypt.tar apps/foundation.e.notes/db/OWNCLOUD_NOTES --to-stdout > notes.db
echo "select content from NOTES union select content from Note;" | sqlite3 -csv notes.db > notes.csv
went with python first, then later saw there's the simpler java package.. script is interesting though
apt install python3-pycryptodome
git clone && cd ab_decrypt
sed -i 's|^from Crypto\.|from Cryptodome\.|g'
python3 --backup backup.ab --pw <password> -o decrypt.tar
1 Like

Hey, I’m still having problems with restoring my notes and am desperately looking for help. Can anyone share ideas with me what to do?

I lost my notes that were only in the internal storage of my phone and not synched to the cloud, as there wasn’t enough storage in the cloud and I didn’t actually intend to use the cloud. Inside the cache it displayed there were still 10MB, so I hoped that they were actually inside the storage of the phone, but couldn’t access them.

I just decided to try doing the update, unfortunatelly when I open the notes app it only says “welcome to notes” and a button “select account”.
Is there anything I can still do to get the notes back?

Still says there’s 10MB inside the storage of the notes app, so I hope my notes are still there? :disappointed_relieved:

I am also able to use adb commands with instructions. Unfortunatelly my phone isn’t rooted, doesn’t simply have the options to do that in the developer settings, and also doesn’t have TWRP installed.

Any ideas what to do? Would still be very very grateful :sweat_smile:

I understand this is the case with a stable build – are you using a stable build ?

1 Like

Hi, thanks for your answer!

Version is 1.13-q-20230724313392-stable-star2lte

Prior to Android 12 based /e/OS this was connected to passing SafetyNet or not, so stable builds had SafetyNet passing while dev builds had the Rooted Debugging setting … SafetyNet on /e/OS Community "dev" devices - let it in or not?

Q (Android 10) is prior to Android 12, so the stable build doesn’t have the Rooted Debugging setting.