OnePlus 7 Pro issues

In my search for One Plus 7 Pro Oxygen Firmware version 9-pie (lower android 10) I always end up on XDA.However, I cannot judge whether these versions are country-specific, i.e. suitable for your place of residence.

Since StockROM v 9-pie works, I would try another custom ROM, e.g. LineageOS 16.0. Also try with microG. If it doesn’t work like under StockROM, the error is probably due to LOS 16.0, less to microG. It’s worth a try, right?

I installed the same 18th Dec image as you. However I was on v10 stock firmware already. 10.3 I think. Points 1 and 2 worked for me. Cannot comment on point 3. I did however return to stock due to poor camera experience. I wait to see how the /e/ project develops.

1 Like

That’s what I mean on post #2. Point 1 and 2 are firmware issues.

Do you have tried with enabled camera2 Api 2

1 Like

You know this app for getting the firmware ? https://f-droid.org/app/fr.witchdoctors.c4ffein.oosfirmwareextractor

Yep, it’s OK. But not quite there

An update on the situation.

I tried flashing a number of the availabe OOS 9 stock images above and with practically all of them the pattern was this:
After flashing, WiFi (all bands) and modem work, however sensors (proximity, gyroscope, compass) do not work (i.e. no screen rotation, no compass, etc.).
After applying the official OTA update to OOS 10, all sensors work properly.
After clean installing eOS or LineageOS, whether after updating to OOS 10 or directly after flashing OOS 9, sensors again do NOT work.

I managed to use the MSM tool (https://forum.xda-developers.com/oneplus-7-pro/how-to/msm-tool-guac-t3934691) to return the phone to stock condition and then the sensors were working correctly (under Oxygen OS 9.5.3.GM21AA). However, again, after clean installing anything LineageOS 16-based, sensors do not work.

1 Like

Could you extract the firmware with the app I have posted a link ?
I was hoping, that you can extract the firmware, flash eOS and than reflash the firmware. So your drivers will be up to date.

I had similar experience from OOS 10.3 to eOS 16base. Sensors did not work for me. Screen rotate was an issue so went back to stock for the time being as phone is my daily driver.

1 Like

Looks like a firmware update issue as @harvey186 mentions above. The /e/ or LOS ROM’s may not be updating the firmware.

Could you extract the firmware with the app I have posted a link ?
I was hoping, that you can extract the firmware, flash eOS and than reflash the firmware. So your drivers will be up to date.

Seems the application extracts firmware from an image file.

I’m not sure which one to use. When flashing any of the FASTBOOT stock images available, sensors are not working initially. The only way to get them to work is either applying OTA update from stock, or resetting the phone with the MSM tool.

I never have used that app because I don’t have an OP device. But I think, you must have an Android 9 stock firmware installed for extracting.

It requires a ROM file to extract from. Problem is, I don’t have access to a ROM image that gives me functional sensors after installing (without further OTA update).

Here is directory of OP 7 Pro roms

https://sourceforge.net/projects/fastbootroms/files/OnePlus%207%20Pro/

Looks like this has been raised as in issue with LOS. I’ve also seen others report similar issues on XDA

https://gitlab.com/LineageOS/issues/android/issues/1522

2 Likes

Someone here using the 7 Pro with /e/ as every-day device? If so, what are the annoyances (doesn’t work) in addtion to the ambient light and rotation sensor (https://gitlab.e.foundation/groups/e/-/boards/12?scope=all&utf8=✓&state=opened&label_name[]=guacamole) ?

E.g. real-world experience with the camera since I read nobody managed to install the OnePlus camera app so far, but one has to use OpenCam.

I am close to buying it as my new main device but since the price tag is not the cheapest, I’d like to hear some experience from someone actually using the 7 Pro with /e/.

I just got my OP7Pro (GM1913) setup with e-0.7-p-2020033047438-dev-guacamole.

So far I am happy with basic everyday usage, almost everything works:

  • 4G/LTE, data, calls.
  • 5G untested

Not working is:

  • Adaptive Brightness
  • Auto-Rotation

Regarding Auto-Rotation, manually setting the screen orientation via Mudar Noufal’s app “Rotation Quick Setting” works fine for me.
http://rotationqs.mudar.ca/

Thanks to the links here and resources on XDA and elsewhere the sensors are now working on my Op7Pro using latest /e/.

Device:

  • Op7Pro, GM1913
  • Software Base: Initially on Stock 10.0.? ROM, having installed /e/ e-0.7-p-2020033047438-dev-guacamole on top, everything fine with the exception that sensors are broken

Idea:

  1. Try to revert to stock pie rom, get sensors working
  2. Reinstall /e/ from there

What did not work:

What worked:

  • Steps exactly as described here: https://gitlab.com/LineageOS/issues/android/issues/1522#note_274265612
  • This gives the desired stock pie 9.5.11 rom with sensors working.
  • Install e-0.7-p-2020033047438-dev-guacamole, which gives /e/ with working sensors.
  • Then use temporary TWRP "fastboot boot " only, do not try to persist TWRP with "fastboot flash boot " & install twrp zip
    • fastboot flash boot & install twrp zip: Always resulted in ROM bootup becoming corrupted upon "install ", leaving OS bootable, but fingerprint sensor and WLAN broken.
    • Tried standard trwp twrp-installer-3.3.1-4-guacamole.zip and Mauronofrio twrp-3.3.1-79-guacamole-unified-installer-mauronofrio.zip
  • TWRP Install of current Magisk installer zip works fine

Adaptive Brightness and Auto-Rotation are now working. Sensors are coming up fine.

Hello
I had the sensor problem too, because when I downgraded on oos pie, I had chosen the wrong version, I had installed the gm21aa 9.5.11 all while my device is a gm1913, the right version which restored the sensor is gm21ba 9.5.11. Now everything works as it should. But there is something that I can not understand, I wanted to install Magisk (I know it breaks security) for different reasons but I face a problem that I have never seen before, Magisk installs properly, applications have root access BUT the sensor stops working, no screen rotation, no gestures, no double tap to wake … Anyone have any idea what’s going on ??