OnePlus 7 pro problems with latest OS

Upgraded to the latest e/os on my OnePlus 7 pro on 5/15/2024 and it is stuck in fastboot and will not boot up. It will let me go to recovery mode but doesn’t do anything. Is there a way to revert back to the older OS?

Same on a OnePlus 7T. After several attempts it finally has booted into the older version and offered the upgrade again - any solutions for this issue? Is it possible to make a new install by the easyinstaller without wiping my data?

I had the same problem with my OP7T. I tried to install 2.0 5 times, but decided to leave it at 1.21. Actually after the 3rd time, I returned to the update in settings and checked for updates. It deleted the 2.0. I tried again later, and the 2.0 reappeared. Since there are 3 of us with this problem, I would suspect the 2.0 is not compatible for some reason. I will not reattempt to install the 2.0 until the problem is diagnosed and fixed. Restore will return the OS to 1.21. No data was lost.

Another OP7 Pro here, just did an upgrade. Now I am also stuck in fastboot with the only working option to go into recovery. Is there any way to recover without loosing data?

Same thing for me and my OnePlus 7T, unsuccessful update via the device, fasboot on reboot. 2 unsuccessful attempts, then reboot to V1.21 (recovery). I’m not trying again, not even via the easy installer. A little patience before switching to V2 and 1.21 works like a charm.

Can you explain how you rebooted back into 1.21 via recovery? I would greatly appreciate your help, as I couldn’t find any option to do so myself in the /e/ recovery.

When you’re in fastboot mode, you can normally navigate the menu using the volume buttons (+ and -), then choose recovery and select with the on button. That’s what I have done, but no idea how exactly the device restart the OS in fresh V1.21. Not very hepfull, sorry…

When I go to recovery mode and choose recovery it just takes me back to fastboot. It’s like it just takes me round in circles.

Do you have the option to restore? Reboot will do only what you describe.

Yes I have gone to restore and hit enter (power button) and it just takes me full circle back to the fastboot. I also tried the restore feature in the advance option and still got the same results. I am now wondering if the ADB side load option would even work in getting it restored but I am not that familiar with it.

Thanks for your reply. This did (for whatever reason) not work on my device.

After searching the web for a bit, I found a solution that worked for my device:

The background
I learned that there are two “slots” (similar to partitions) on your device (“a” and “b”), there is always one slot active and used to boot the device, while the other is in standby. When you update your device, the update will be installed in the standby slot. After installing the update, the standby slot will be made active and vise versa. For example, when installing an update while slot a is active, it will be installed in slot b and the next time you boot, the device will boot from slot b, when you install an update while in slot b, it will override slot a and so on.

In theory, this means that you can easily switch back to your old working slot if the update is botched. For whatever reason, that didn’t seem to work using the /e/recovery on my device.

Solution: Change the active slot manually
I will keep this brief and generic, as I don’t want (and can’t) write a complete wiki-article on this. But you will need to have installed fastboot on your PC and have some knowledge of how to use the comand line.

  1. When you are in recovery, it will tell you the current active slot (e.g.: Active slot: a) right below the /e/ logo.
  2. Boot your device, so it is loading fastboot and connect it to your PC via USB
  3. run fastboot set_active x where x is the currently inactive slot.
  4. reboot

I am sorry that I cannot provide concrete instructions, but I don’t have a Windows PC at hand right now. I hope this might help you to google some concrete instructions for your OS.


I am sorry that it won’t help you all now but with many fairly modern devices it is necessary, or at least a “good idea”, to have Updater preferences (3 dot menu top right) set to " Update recovery".

Over simplified, recovery contains a map of where things go. If this should (unusually) change with an update then the old recovery could be a cause of trouble; this may especially affect devices where “extra partitions” have to be flashed at new install.

1 Like

In the spirit of error diagnosis:

  • My updater was set to update recovery
  • Recovery did update (showed Version 2.0)
  • My device (OP7Pro, guacamole) does seem to only need extra partitions for versions greater than R, which I am on right now.

I am sorry to hear all these issues on the Oneplus 7 pro and Oneplus 7T.

I am on a Oneplus 7T pro, and the V2.0 update went smoothless.


1 Like

I am still on Android 11 and guacamole. Maybe there lies the difference?
What do you think

You’re on the dev branch and therefore Android 13.
Before 2.0 and Android 13/T, there was the issue that the OnePlus devices (starting from the 7 series) didn’t have touch on Android 12/S, so it was a lucky situation to be on the stable branch (still with Android 11/R). Somewhere in the community, I’ve read that this issue will only be fixed once the device gets to Android 13.

Now, it seems as if the e Foundation just dropped support for the stable branch, therefore bricking all devices that try to update to 2.0 on Android 11, and requiring a complete reinstall/reflash of the dev branch with Android 13.
(I’ve had the same issue and switched to slot b, now without redundancy, since slot a is populated by a non-working /e/OS 2.0 based on Android 11.)

If anyone has tried that without wiping user data (“dirty flash”), and the phone continues to work with Android 13 and 2.0, then this might be an option. Otherwise, it would totally suck to have to factory restore and lose all data in order to get to 2.0 (and incidentally also Android 13), because there seems to be no clear upgrade path from R to T…

1 Like

If you use /e/OS-R, stock firmware Oxygen OS 11 must be installed.

If you want to use /e/OS-S or /e/OS-T, stock firmware Oxygen OS 12 must be installed.

Thank you very much. I used easyinstaller to install e/OS. This is the version it automatically picked. Is there possibility to upgrade to S or T?

/e/ does not specify whether firmware updates are also carried out in /e/ROM. I therefore assume that no Oxygen OS firmware is included.

The user must therefore ensure that the correct basic Oxygen OS firmware is installed on the OnePlus before flashing. An upgrade from /e/OS-R to S or T without data loss is therefore not possible. The /e/asy installer is intended for an initial installation, i.e. “clean install”, whereby all data is deleted.

1 Like