OnePlus 7T 'No Touch Display' after install

I just manually installed 1.10S on a 7T and after 1st boot the screen is non-responsive. I have /e/ working on my OP5 & two OP6T’s. I checked the 7T works with Lineage. I also tried 1.9S but no touch screen either. Latest firmware installed and confirmed with the Lineage manual fastboot flash method using 12.1 final release firmware.

Any thoughts on how to get /e/ working on my 7T much appreciated!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

In this forum search for Oneplus + touch screen since about December 2022, the thing I believe they have in common is the use of inappropriate .img files which are required in addition to the “standard” and recovery.

Looking at for /e/OS Android S we see the instruction

  1. Download the following files from the directory named with the latest date here.

but the files at that location are from Android T, Lineage 20.

My OnePlus 7T Pro experience was equally unpleasant.

I have the same issue with e-1.10-s
Screen non responsive, impossible to shut the phone down, and it is not detected through adb devices
Is there anything I can do?

You might experiment with using dtbo.img + vbmeta.img from the /e/OS image rather than the source I commented on in Post #2.

I produced these by modifying this method OnePlus - 9 Pro - lemonadep - Documentation Suggestions - #8 by bofh666 – using in this case as a “source file” See Method below.

$ md5sum e-1.10-s-2023-04-13-dev-hotdogb_dtbo.img

$ md5sum e-1.10-s-2023-04-13-dev-hotdogb_vbmeta.img

I am not certain how much of the process might have to be repeated, but essentially you would go back to the section titled

Flashing additional partitions

  • Manually reboot into bootloader or download mode.
    With the device powered off
    hold Volume Up + Volume Down + Power.

  • Flash the above image files to your device by typing

fastboot flash dtbo e-1.10-s-2023-04-13-dev-hotdogb_dtbo.img
fastboot flash vbmeta e-1.10-s-2023-04-13-dev-hotdogb_vbmeta.img

If you are lucky you can drop out of fastboot to recovery with

hold Volume Down + Power

If at first it fails you may have to repeat the remainder of /e/ install process.

Edit In light of the inconvenience of “cannot power down”, one would probably best run the whole install procedure starting from the revised Flashing additional partitions

Should you encounter Qualcomm crashdump mode, you could reflash the Android 12 stock ROM

… or use that downloaded ROM to follow this At time of writing, this last link is at Android 12

  1. Download /e/OS ROM to ~/TEMP/
  2. Download to ~/TEMP/
    and extract here → ~/TEMP/payload-dumper-go_1.2.2_linux_amd64
  3. open terminal cd ~/TEMP/ and extract payload.bin: unzip payload.bin
  4. extract payload-dumper-go: tar xzvf payload-dumper-go_1.2.2_linux_amd64.tar.gz payload-dumper-go
  5. run ./payload-dumper-go -partitions dtbo,vbmeta -o . payload.bin
  6. Make shareable
mv dtbo.img e-1.10-s-2023-04-13-dev-hotdogb_dtbo.img
mv vbmeta.img e-1.10-s-2023-04-13-dev-hotdogb_vbmeta.img
md5sum e-1.10-s-2023-04-13-dev-hotdogb_dtbo.img
md5sum e-1.10-s-2023-04-13-dev-hotdogb_vbmeta.img

thank you again @aibd !
I’m definitely going to try your solution, but first I need to turn my phone off. Can’t access it through adb, can’t force the shutdown by pressing Vol - and Power buttons… any idea? Should I just let the battery empty itself?

I guess you already tried Volume down and Power for a full minute, waiting for the battery to exhaust may be the only solution.

Hi @aibd - what is this for exactly? (still waiting on that damn battery to exhaust here)

Why have I shown the method ? Because on reflection I wanted to inform readers or potential users what they were using (rather than just dump random files).

There is no need to perform any of this, but whether the experiment works or not, it is clear to all what we tried – and the same issue may affect other devices.

Good to know you have a strong battery :smile:

1 Like

Hi! My battery finally gave up and I tried your solution but still no luck: no response whatsoever from touch input. At the end of the installation process I don’t get this message

The phone screen will now display some text with a message similar to

Script succeeded result was [1.000000]

Is there a log I can provide that could help?
Many thanks in advance

I am sorry to hear that did not work. One usually sees a quite an active trace on the PC terminal – as said on the install page:

The screen will show the progress percentage

If I want to keep a log of what happened, I would copy the trace from the terminal – here’s an example:

$ ./adb sideload /path/to/
serving: '/path/to/e-1.4-beta-q-20220909217255-dev-a3xelte.serving:
[snip 30 lines]
'/path/to/e-1.4-beta-q-20220909217255-dev-a3xelte.Total xfer:1.01x  

Did you get any feedback at the terminal ?

Yes everything was fine, I got this final message
Total xfer: 1.00x
No error message

The lemonadep issue from which the idea was inspired is a recovery flashing issue - you have managed to flash the recovery each time. Regarding the failure to install it seems that providing specially extracted dtbo.img + vbmeta.img was not useful.

As said for hotdog here OnePlus 7T 'No Touch Display' after install - #3 by Gianna I think we have to assume that the build is flawed. Perhaps you are tempted to Report an issue.

I just had success today with the latest dtbo.img vbmeta.img from
And the LOS recovery - this is the only recovery that flashes successfully for me. EOS and TWRP appear to succeed, but they don’t boot).
And the EOS 1.11-r
Good luck to everyone with a OnePlus and no touch screen!

1 Like

I’m having the same issue on my 7T (hotdogb). I used MSM tool to flash the latest stock Oxygen OS 12 on it. Then I did the Command Line install of Stable /e/ OS S because the Easy Installer downloads R still. Install of Stable S went great but then no touchscreen at the “Welcome to /e/ OS” screen. I also tried dev builds of 1.11 and 1.9. Same issue. I used the latest dtbo.img and vbmeta.img files dated 5/21. @mikefreeman did you get /e/ OS S to work on your 7T or just R? I did report this as a bug here Touchscreen does not work after command line install of /e/ OS S on hotdogb (#6981) · Issues · e / Backlog · GitLab

It might sound a little brainless on my part, but I didn’t realise right away that I had flashed r, not s! Which explains why I ended up with Android 11 on my 7T. I also have a problem with my fingerprint reader. It accepts the setup, but almost never works when I try to unlock the phone. No idea if this is the hardware or firmware. Anyway, I will do my best to correctly flash ‘s’ in the next 24 hours and give feedback regardless of outcome.

The fingerprint issue has been going on for awhile. It was reportedly worked on for R 1.10. But issue still persists. I reported it here Week 18. 2023: Development and Testing Updates - /e/OS Smartphone Operating System / Development Updates - /e/OS community. It happens to my wife’s phone and mine; we both have the 7T. I still need to report the bug in GitLab. As you can see in the Week 21 update the touchscreen issue is a known problem that seems to be caused by the partition files referencing Android 13 and not matching the install files of /e/ OS version S (Android 12). Should be fixed with /e/ OS T (Android 13).
Since /e/ OS S doesn’t work yet on the 7T I decided to install LinageOS 20 on my 7T. LineageOS 20 has Android 13. So far so good. No touchscreen issues and no fingerprint issues. I’ll likely go back to /e/ OS when T is released and the touchscreen and fingerprint reader work as they should.

I also very much regret that /e/OS currently does not work on my OnePlus 7 T Pro and I had to switch to LineageOS 20.0. It is possible that I will find my way back to /e/OS when there should be a working version ‘T’ V1.12 or higher.

Now I 've a very good alternative to LOS 20.0 installed. Since I’ill not make a possibly misunderstood advertising for another ROM, no naming. The ROM is also based on the LineageOS source code like /e/OS and also runs on Android 13 - with the serious advantage that it provides signature spoofing support and thus different variants of microG can be installed - from a microG minimal version (only microG Services Core, Fake Store and Maps API) to the standard edition including Google Play Store. A very seen featrure is also - the microG application can be uninstalled and reinstalled at any time without negatively affecting the overall system. The CustomROM is available for the OnePlus 7 series and its guacamole, hotdog, hotdogb and hotdogg models.

I’ve gone down the LineageOS 20 on my 7T route too. I did it just to check if the problems were EOS specific (Which they clearly are). It’s swings and roundabouts for me. I like them both, but about 60/40 in favour of EOS (when it works!). Now, biometrics works. My touch screen works! I also have advanced restart back again. I use almost entirely F-Droid sourced Apps, so I don’t think I will miss the EOS Store much either. Worth mentioning - I have had much better support experience from /e/ than from LOS. In fact, I have had positively unpleasant experiences with one LOS dev, such that I wouldn’t ever ask them for help again.

1 Like

I forgot that LineageOS does not come with microG so I have to go back to e OS R because there are some apps I need to have that require microG services. I’m looking forward to e OS T which should be released soon according to the Week 22 update I read today.
I’m curious what that ROM is you are using. Is it privacy focused? Can you share the name?

1 Like