OnePlus - 7T Pro - hotdog - Documentation Suggestions

…Enter suggestions to improve documentation in this category. Do not raise bugs or issues here…

1 Like


The WiFi does not work on my HD1917. Enabling it simply times out.

About to install on my new phone… Here are my verbose notes as I meet complications or confusion, or just to refer back to. I will suggest changes to the instructions if I can think of them, particularly to make /e/ more accessible to novice users.
For background, I’ve used /e/ for years as my only phone (also a OnePlus) and successfully installed that myself about 3-4 years ago but I’ve largely forgotten what I learned then. I’m using Linux Mint 21.2

I’m following the instructions for OnePlus 7T Pro here:
Note that these may differ from the 7 Pro and the 7T so realise that they have their own instructions
These notes can be used to update/revise those instructions

Installing adb:

  • Even as a seasoned user of Linux, the syntax of path names and instructions still confuses me. Perhaps I’m not alone, so in install-adb instructions perhaps a couple of examples might make this clearer.
  • Also, the note “here we have assumed you have saved the downloaded files to a folder named platform-tools and this is in your home directory” might be better placed before the instructions that it explains.
  • Instruction 6: Might be better phrased:
    6. Test your installation by checking that you can run the commands below.

Downloads for hotdog

  • The guide to understanding differences between builds does not explain the difference between
    • /e/OS Recovery for dev build
    • /e/OS build : T dev
  • If the user has a wiped phone, how do they check if the phone has a particular firmware? Mine just says ‘Hello’ and wants to start the Android installation. More details here would be helpful. In fact, here is a realisation: the instructions should assess what state the phone is currently in and start from there by signposting the installer… I guess that I will have to first register with the OxygenOS and agree to all of OnePlus and Goolag’s T&Cs.

Unlocking The Bootloader

  • 1.1 If the installer does not have Developer mode, why not tell them how to get it (Go to Settings, search for ‘Build Number’ then tap on the Build Number entry seven times.
  • 2.1 The instruction to connect device via USB does not make it available to adb.
    • Firstly, I needed to change the device’s cable mode from ‘charge only mode’ to ‘Transfer Files/Android Auto’ (by swiping down from the top)
    • The user needs to use the newly enabled Developer Mode to enable ‘USB Debugging’? More instructions needed here for Noobs like me. I’m trying it and allowing my computer, when prompted by the phone. Yes! That was right.
    1. On my device Volume Up and Volume Down and Power do not begin a fast boot, either from powered on or off state.
    1. ‘Try running as Root’ - yes, I think know how, but perhaps include an instruction:
    • Tip: If you see … try running fastboot as root like this: sudo fastboot devices
    • Well, that didn’t work. ‘command not found’ error… Perhaps I need to choose ‘Start’ or maybe ‘Recovery Mode’. I’ll choose Start. For Noobs, it isn’t obvious what constitutes ‘fastboot mode’ this opening screen or the fully rebooted device.
    • No, still no joy. fastboot not recognised as a sudo instruction and the device not found when fully booted until ‘USB mode’ changed. I’m stuck and the instructions generally seem to assume that everything will go well… :-/

A couple of irritating hours pass… then EUREKA!!! I unlocked the bootloader!

  • ‘udev’ rules needed to be set.

    • I ran this command in terminal: apt-get install android-sdk-platform-tools-common and then sudo fastboot devices recognised my phone when it was on the fastboot ‘boot screen’.
      The above need to be incorporated into the instructions
    1. The instruction text ‘If the device…reboot it…’ should read:
      ‘If the device doesn’t automatically reboot, use the volume buttons to select ‘Reload Bootloader’. It should now be allow unlocking using the device’s buttons.’

Flashing Additional Partitions
Again, I needed to know what recovery version I needed… Somehow we are expected to know that R means Android 11 and S means 12, unless I’m wrong…? That idea was just what I eventually found by searching the forum. As this device was on stock Android 12, do I just download the latest recovery file for ‘Android S’ or do I need a stock recovery file? Sadly, the difficulty of experts writing instructions for non-experts means that installing /e/ can be tortuous. They can’t unknow what they know intuitively. Anyway, that’s why I’m doing this; sharing my frustration (it’s not criticism) is part of my experience and contribution. Presumably, the Goolag Labs are full of inexpert testers like me.

Hang on, the eRecovery Zip file I downloaded isn’t an unzippable file, it’s a seemingly unmountable .img file. Why this new hell? Linux Mint’s Archive Manager doesn’t recognise it as a zipped file and Mint’s file manager won’t mount it, though it shows up as a Raw Disk Image. When researching how to do it via Terminal, I’m being told that it’s ‘wrong fs type, bad option, bad superblock on /dev/loop1, missing codepage or helper program, or other error.
I’m convinced that I’m not an idiot but this is making me feel like one. Lot’s of people would surely give up here. I love that @GaelDuval et al have done this so I’ll try and continue, but my enthusiasm is very low. I need to cook and eat, not mess about for hours on a device.

So I don’t know what to do… Do I just ignore ‘Flashing Additional Partitions’? DO I need to ‘Flash additional partitions’? Have I already bricked my new phone? This is confusing and worrying and shit. Do I continue without a Recovery file? Unwise, perhaps, especially as a confusingly worded Warning is issued. I’ve tried downloading other .img mounting software and downloading alternative Recovery files in case that one was faulty (I always check the SHA256 sums) but nothing works. Why so confusingly impossible, even with some vague understanding of what I’m doing and 40 years of computer experience? Wah!

I am clearly getting more verbose, the more I am bewildered by the process. I’m also growing disenfranchised with /e/… this is why I never upgraded from version 0.14 over the last 4 years.

I found a solution to the above with help from @mihi and others
There is a known issue not listed in the installation documentation.
Basically, don’t try to extract anything from the Recovery file; instead download and use payload-dumper-go to extract the files you need from the main ROM that you have downloaded

Instructions are here but make sure that you read the notes below the main article
This issue will disappear and this is a temporary workaround. I wish it was included in the instructions!

So, back to progress: Flashing Additional Partitions continued.

    1. My device doesn’t always like booting into bootloader mode with the 3 button press (both volumes and power).
    1. I have to use sudo to get fastboot to work. It also doesn’t like finding fastboot, despite having tried to tell it the path. Anyway, after changing directory to the one that has my .img files in, I use:
      sudo ~/platform-tools/fastboot flash dtbo dtbo.img
      sudo ~/platform-tools/fastboot flash vbmeta vbmeta.img
  • Easy when you spend hours and hours working out how…

Installing A Custom Recovery Using Fastboot

    1. & 3. Bad instructions. I am already IN Fastboot mode as I am following on from the previous instructions.
      They shoud read something like:
    1. If your phone is not already connected to your computer with a USB cable, do so.
    1. You need to be in fastboot mode. If not already, enter it by pressing Volume up…blah blah
    1. Again, sudo needed: sudo ~/platform-tools/fastboot flash recovery Recovery\ ROM/recovery-e-1.14-s-20230819321663-dev-hotdog.img
    1. Should be instruction 6., not 1.
      Also, as we are in Fastboot mode, entering Recovery Mode can be done from Fastbot mode.

Steps To Install /e/OS from Recovery

  • Perfect! Well written instructions!

Install /e/OS

  • Missing instruction:
    0. Use the arrow to go back to the /e/OS Recovery Main Screen
    1. I am getting Unable to mount HD1911: Unable to open MTP device warnings on my computer but in the terminal, adb can see attached devices.
    1. It’s working, though I received an error the first time, but I just woke the phone’s screen and tried again…
adb: sideload connection failed: no devices/emulators found
adb: trying pre-KitKat sideload method...
adb: pre-KitKat sideload connection failed: no devices/emulators found

HA! It worked! Only took 18 hours or so!

           '       \
          |,.  ,-.  |
          |()L( ()| |
          |,'  `".| |       Shouldn't be that hard
          |.___.',| `
         .j `--"' `  `.
        / '        '   \
       / /          `   `.
      / /            `    .
     / /              l   |
    . ,               |   |
    ,"`.             .|   |
 _.'   ``.          | `..-'l
|       `.`,        |      `.
|         `.    __.j         )
|__        |--""___|      ,-'
   `"--...,+""""   `._,.-' mh

TWRP-3.7.0_12-SFX-16_hotdog.img 2023-12-25 by @steadfasterX