OnePlus 8 fingerprint scanner stopped working

I juste updated to 1.4… Still no fingerprint feature working

Yeah apparently they know about it but still not fixing it… It’s been a while now

1 Like

What a disappointment :face_with_symbols_over_mouth::face_with_symbols_over_mouth::face_with_symbols_over_mouth:

1 Like

Im thinking about going back to stock firmware removing bloatware and gapps. Then doing a fresh microG install. Then reinstalling my personal apps. Ill gain fast charge in the process and the fingerprint sensor will work. If I decide to go this route ill upload the rom and provide a link.

Just a thought … I see that Lineage + MicroG is available.

You might consider installing that … then you might see if this is an /e/ generated issue or whether it is shared with LineageOS. (I have not checked at all for issues filed against LineageOS)

This is a /e/ os issue. Lineage OS is built and maintained by devs that actually show interest in the functionality of all sensors on your device. They find bugs and fix them. I want to go to stock firmware because stock is the only way to have functional quick charge.

I have switched from e-os 1.2 to lineage+microg 20220817 and the fingerprint sensor is working fine. It’s an easy job to switch. I just make a sideload of the los+microg rom image and that’s it. No need to reinstall all apps. You have just to tune the Davx5 app to setup your accounts.


In addition to my previous post, Ijust want to say that it is NOT an advice to switch, especially if you are using services (mail, cloud storage, notes…) and e-os default apps.
Nevertheless it could be useful for those who appreciate a working fingerprint feature.

You can sideload all the e-os apps (mail, cloud, notes). Id probably do a titanium backup of your apps then restore them.

There are not many guides to how to best Upgrade Lineage + microG to “like” /e/, but as /e/ is not working correctly on this device the following thread which at first sight is not exactly on your subject might give some clues on what to install first. Many apps I think you will do better to install the upstream app yourself. Of course you can log in to your /e/ Browser, but not sync with the cloud. It has been found that you do need a certain minimum of sideloaded /e/ apps to get your cloud to work correctly.

When I tried to sideload Advanced Privacy on an own build without it, it failed with some security breach, try by all means, but perhaps leave it till last!

I now build (and run on my devices) a build of LineageOS for Microg (L4M) which does aim to be “like” /e/OS. Details here:

For devices which have an official L4M build (see here), it is pretty straightforward to install the extra apps needed to make it functionally equivalent to /e/OS version 0.23*. These are

Installing them on top of a standard L4M build will mean that you have the new apps in addition to L4M’s versions, but so long as you have anough space, that’s not a big problem.

You also won’t be able to install / use Aurora Services (which needs to be a system app). That just means that updates for apps from Aurora Store can’t be done automatically.

With that lot installed, you’ll have a device which does pretty much everything that /e/OS v0,23 did, and is much more up-to-date in terms of a: bug fixes and new features in the forked apps and b: security updates in LOS and the base Android system .

* In my opinion, v0.23, was the last “good” version, undermined in v1.0 by the introduction of the untested Advanced Privacy, and the barely tested App Lounge


This is what support user Manoj say’s in a other topic.

So there are working 2 new members on it, we will see hope they fix it at the next release… It begins to annoy me that that they just put it on the long track. Especially that more and more people are coplaining about this. But we will see it with the next update or after…

Switching to lineageOS is not a option, at least not for me anymore. I’ve used LOS in the past it’s great nothing to complain about just exept one thing. They still use (like all other ROM’s) some google servers to communicate. I don’t know it in dept anymore, I still try to find the artical but don’t know where to find it anymore. I remember Nick from The Linux Experiment brings it up a few month’s ago.

1 Like

Anything yet? Patiently waiting for a update with a working fingerprint sensor. :crossed_fingers:

I agree with you @petefoth , I made more or less the same (except k9mail, I use FairEmail instead) cause I don’t think e-os dev team is focused on that topic (they have enough to do by improving the “stable” release : S9, Murena one, Oneplus nord…).
But e-os aim to be well suited for everybody, including grandma, and grandma has no skill in android mod…

Anyone tested the 1.5 update?

1 Like

Still not working on op8

1 Like

Is this the same issue

1 Like

Yes, this is the issue. No input on the fingerprint sensor. It won’t recognize anything at all.

We have a developer working on this issue. Should get an update by Monday on what happened to the fix.


Thanks we have been waiting for attention to this issue.

1 Like

Thank you! Where been waiting a long time for this. Hope it’s getting fixed finally