Phone not detected with /e/OS Easy Installer under Ubuntu

Hello, I just bought a used Samsung Galaxy S7 to test e/OS.
I installed /e/OS Easy Installer (v0.20.1v) under Ubuntu 22.04.4 LTS.
I connected the phone with the original delivered USB-cable to the usb-port and did the following setting on the phone:

  • Developer Mode enabled
  • USB debugging on (Debugging mode launches when USB is connected)
  • Under USB configuration: MTP (Media Transfer Protocol) is selected
  • All accounts are removed
    The phone is detected in the file explorer of the laptop under ubuntu (access to “Samsung Android”).
    Having done these steps, the easy installer says “Device Detection. Looking for your device…”. This message keeps there and does not change, for 2 hours. I guess it does not make sense waiting longer.
    Are there suggestions what to do?
    André

check cable and port

…

1 Like

even original one can be faulty one, I woulb say :sweat_smile::grin:

1 Like

Is the USB mode not supposed to be set to “File Transfer”?

You might check or share here the log

Thank you. The Easy Installer says to select “File Transfer” - on some devices it is called “MTP-Mode” (media transfer protocol). In my case it is MTP-Mode instead of File Transfer.

Thank you. Here is the logfile:
https://paste.tchncs.de/upload/monkey-sheep-pig
Logfile
I checked different cables, and I ordered one to test a further one, and I tried different USB-slots.

The log contains 675 matches for

failed to check server version: protocol fault (couldn't read status): Connection reset by peer

also seen as

(debug)adb: failed to check server version: protocol fault (couldn't read status): Connection reset by peer

My first guess would be that this is a problem with Easy Installer. I would be inclined to uninstall Easy Installer. Update and Upgrade Ubuntu, reinstall and try again.

The error starts with the first task, DeviceDetectionTask, and the error seems the response to

adb devices -l

Are you able to confirm that yours is a Samsung Exynos model, that is, not Qualcomm SoC.

Thank you! I guess it is solved. The issue is the following:
I had to install ADB. It is not mentioned anywhere that adb has to be installed under linux.
But the issue is: the adb-server does not start itself. So the error-message “failed to check sever version…” is displayed.
The server has to be started: adb server
Then the command “adb devices” works, and easy installer has access to the device.
Thank you for the hint with the logfile and the hint of the error message!

Summary for people who read this later:
sudo apt update
sudo apt install adb
(I am not sure - maybe this as well): sudo apt install android-tools-adb android-tools-fastboot
adb server

Then adb devices or adb devices -l works and easy installer has access to the phone.

1 Like

Great news :slight_smile:

Also for later readers

This should not be necessary adb comes with Easy Installer, but I have a speculative idea why it worked.

We see from your log where adb should be installed

ADB folder path = /snap/easy-installer/35/easy-installer-linux-x64/bin/adb/

If you have Easy Installer on the machine still you might try to navigate there and run

./adb --version

You might then check the version of your system installed adb.

the less certain bit

Speculative

The part of the fail

Connection reset by peer

might fit with new Debian 12 based systems with late kernel 5.x and some 6.x. It seems from reports that the kernel may react to (perceived) lsusb errors. Mentioned in the course of this issue https://github.com/Benjamin-Dobell/Heimdall/issues/509 and in other parts of the internet when I first tried to debug this.

dmesg revealed this spontaneous disconnect of the device, then reconnecting as a different device. My experience seemed to suggest that changing to a lower platform-tools version resulted in getting an adb connection.

Oddly, without doing an Upgrade, the use of a different version platform-tools allowed the latest version one to work later! It was almost as if the machine would settle down to accept the device, later.

Being fully Upgraded will probably fix the issue in the future,