Pixal 4a OTA to 2.0 seems to not work even though it says it is available

My Pixel 4a running /e/OS 1.21-R from march 23 is giving messages 2.0 is available via OTA. I see the update in available updates, with the option apply update. When I do this, the update is downloading the 1.2GB download, then says it is applying update, preparing for reboot, then seems done and asks to reboot. After I reboot, the update is not applied, the phone is still on 1.21 and keeps giving notices that an update is available. I have done this 3 times now, with cleaning the cache of the update, but the result seems I cannot use the OTA update. Is there something I am doing wrong? I have followed the same procedure for several OTA update before this, and they all worked fine.

Since I noted that the version is 1.21 from march 23rd, I assumed that would be enough information because to my knowledge, there is only one update from that date for this phone. But since you seem to be asking, the e/OS version is 1.21-r-20240323388914-stable-sunfish.

S and T versions are available on dev branch
but you are right there is no e-1.21-r-dev as R was dropped after latest e-1.8.1-r-20230206257804-dev-sunfish

.

anyway you are on the stable branch :

the advice is to clearing cache AND storage in → android settings → applications → show system apps → updater → storage & cache

other way is to apply the update from recovery…

I cleared both the cache and the storage. I am on the stable version, correct.

The phone still tells me there is an update available (e/OS 2.0 from may 6th) but when I try to have the OTA update installed, the same as ever happens. It downloads, goes through all the motions of updating, then when it is time for “first boot” and the “reboot” button is showing, I press reboot, the phone reboots, and then the update seems gone and the whole process starts all over again. Does this mean the OTA update does not work on the Pixel 4A?

I was hoping to somehow get the OTA working since the updater seems to offer it for this phone. Installing from recovery is always a bit risky and since I am on an eSIM that might get wiped if something goes wrong, I would like to not take that risk if at all possible.

the system updater use the recovery to install the new build…

just don’t wipe anything

I might try that if no other options are available. I am just wondering how and why the OTA is not working, and how to get it working. But if no one knows, I would like to update at some point, so if no other solutions are offered, I might just go for the manual recovery option.

wait for any comment from users more skilled than me on this point…

I certainly hope that anyone has an idea. It would be very welcome.

Perhaps unlikely in this case but does the Updater offer Local Update in the top right 3 dot menu?

Interesting thought! Alas, I tried that but it only has the options for preferences (where no local updates is to be selected) and show release notes. The dots behind the available update only say “copy URL”. So unfortunately :frowning:

I briefly checked the v2.0 feedback thread with this search for sunfish.

https://community.e.foundation/search?expanded=true&q=sunfish%20topic%3A57518

Looks like about 4 fails for the 2.0-r-sunfish-stable build.

Sorry I did not check it in sufficient detail to see if anyone already did the apparently necessary Report an issue, but from this search https://gitlab.e.foundation/e/backlog/-/issues/?sort=created_date&state=opened&search=sunfish&first_page_size=20, I think not.

I notice that the stable build does not show on the install page https://doc.e.foundation/devices/sunfish/install, so I would guess that perhaps you should be considering preparing for upgrade to Android 13 (T) and …

Though I’m not an expert I can tell you that OTA for S and T are working fine.
I changed from R to S and from S to T as soon as the new version was available. And for both the OTA works.
Thus I assume that the update problem is somehow connected to R.

Thanks for the information! Did you switch with a manual update? If so, did you suffer any data loss? Normally I am not picky about manual installation except now is different, since I have een eSim from my work and I don’t want to accidently wipe it and making it impossible for people to call me.

Edited (I’m very sorry, but I mixed up my memories! I don’t remember, if there was data loss when upgrading from R stable to S dev):

I manually updated S dev to T dev according to the instruction here. The Easy-Installer wasn’t usable to install a dev-version at that time. I don’t know if it’s now.
I had no data loss, but a backup before upgrading is preferable, of course.

So Manual Upgrade from R stable to S Dev is possible without data loss?! Could you describe how exactly you did that?

I have similar issues with Oneplus8Pro.

Sorry to say, but I mixed up memories. I upgraded only from S dev to T dev without data loss.
When I got the phone, I installed R stable and then S dev and didn’t care about data loss.
But in all cases I followed these instructions.