Pixel 4A, impossible de unlock OEM

I try to install /E/ on a google Pixel 4a.
But impossible de unlock OEM so impossible to continue.

This commande are ok:
adb reboot bootloader
fastboot devices
I precise that i can found the phone on the terminal, so the connexion is ok

After these commands are not working:
fastboot flashing unlock
fastboot oem unlock

On the phone, in the chapter developper, the line OEM is gray

What can I do?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

Is your phone connected to the internet when you try to OEM unlock?

Are you using the easy installer?

Yes, you think i have to disconnect internet?

1 Like

The firt time, i try with easy installer, but it’s stop because impossible to unlock OEM, so after , i try with the commands and i find the same problem.
It’s not the first install for me, i flashed /E/ on 3 différents phones, but now, I don’t have a idea to resolve the problem

Internet connection is necessary, so you acted all right :+1:

I used easy installer about 2 months ago with 4a on a linux machine, it worked without any issues.

Since you did /e/ installations, is it now the exact same setup? We need to figure out if the devicejis the issue or the computer.

My computer is on DEBIAN 11
I flashed the following phones with commands lines in terminal, LEECO le TV, LEECO PRO, and it’s works.
For this time, I used the installer because the pixel 4a is compatible (it’s a friend’s phone).
For me, it’s not working, but it’s not working with the command lines in the terminal too.

Did you go into Developer Options and enable OEM Unlocking?

Yes, but the line is gray, impossible to enable it

1 Like

In the forum I have seen alot of posts about debian issues. I know it worked before but it does not with Pixel 4a. Computers can be very frustrating…

So find the issue with easy-installer:

Or if the isue is Debian:

or maybe way different approach:

After some times to try your advices, I’m always in the same situation.
OEM unlocking is gray and impossible to unlock on the phone, with ADB commands and easy installer.
I learn today that the phone comes from Canada and maybe it’s impossible to unlock.

That sounds odd, I have a baerly blue version which I bought second hand and it was written it is a version sold in America. Yet it still worked…

You could try to reset the device with this:

Please install Android 11 on it so you won’t have issue with to high version.

Thats what I did, stock android and then easy installer with /e/

Thanks, I will try soon, I will tell you if it’s works.

I try on https://flash.android.com/.
I selected android 11 and cannot continue the flashning

And the same problem, i can’t because on the phone the OEM unlocking is not editable
Capture d’écran du 2023-02-25 18-00-06

Maybe it is something like this:

I think you need to try to explore the idea linked by @mihi – that you have a “Carrier locked bootlaoder”.

Can you be sure which was the last carrier ? If you just bought the device can you establish from the vendor if the device is carrier locked ? If carrier locked in a different region from where you live, unlocking could be hard to achieve.

The “greyed out” OEM unlock would be quite unusual in a Pixel (imho) other than some third party lock for instance carrier lock.

We contact the vendor, so we are waiting.
My friend buy the phone in internet, it’s come from Canada

Totay I try this.
1/ wipe data and clean cache in the recorvery mode =no results
2/Try a application to unlock= impossible with pixel and android 13, so maybe i didn’t find the good application.

I found this: OEM Unlock greyed out in Pixel 6A | Cannot Unlock Bootloader [Fix]
Maybe the FIX 2: ADB Sideload Verizon Update can help?
But where to find for the PIXEL 4A?