PostFinance app crashes

I have found the PostFinance application in the /e/ App Store and installed it successfully.
However, when opening the application it crashes. I have also tried to install it from the Aurora store with the same result.
Any suggestion is welcome as I would like to use this banking application (Swiss bank).

Thanks and regards

Hi @Ors you could try the suggestions given here

I am a beginner (hence I bought the phone from the /e/ foundation) and I am not confident doing the flashing described in step 1.
I hope for an easier way to achieve the desired outcome…

Hi @ors, are ypu talking about PostFinanceTWINT ? I have installed that app on my e-pie phone without any hack. I was able to install and I can start it. But I’m not from Switzerland so I can’t go further than here:

Are you also reach this screen or is the app crashing before ?

Thanks @harvey186 for looking into this issue. I would need the other app: PostFinance Mobile. The app does not open at all, it crashes before reaching the screen you have posted.
I have managed to install the PostFinance TWINT successfully, but not the other app.

Ok, I have tried PostFinance Mobile on my e-pie phone without hacks and on my e-pie phone with hacks On both the app is crashing. So it’s the same as on your site.
If this bank does have a web interface, you must use that as a workaround.

And you should write the the bank support, that you app isn’t starting on a googlefree phone

I have contacted bank support, so let’s see what they have to say. Will provide more information once I hear back from them.


Here is the answer from the bank.

Is your smartphone rooted or running on the android 10? Our app does not work on rooted phones. If it is running on android 10: The PostFinance app is not yet compatible with android 10.

Please confirm that my refurbished Galaxy S7 with preinstalled /e/ is not rooted and that it has android 7 OS. Thanks

I think both: Yes
But you can check for your own. Install a ‘root checker’ app and run it. It will show whether your phone is rooted or not.

And android version you can find unter ‘About Phone’

But you have to tell them, that you are uding a phone WITHOUT original Google Play Services. In most cases that’s the issue

Thanks @harvey186 I will follow up on this issue.

Update. The bank informed that a new version of the app was coming and it is now available in the Aurora Store.
I have installed it but crashes the same way as the earlier version.
@harvey186 Could you please check whether it works for you.

Sorry, I can’t, because the app is only working for banking users and I don’t have an account, so I can’t register :frowning:

I only meant that you install it and open it to see that it works. After installation I could not open the app and it keeps crashing.

It works up to this screen

Sorry for bugging you with this @harvey186 I think that this is not the application in question (the photo is of the Swiss Post application not the bank).
The one I am trying to use is: PostFinance Mobile.

No problem. I will try it later

1 Like

What is your actual version ? I have only access via e-apps. And that version is 4.8.1 from 04.08.2019
In Aurora I can’t find the app. Could be it is not shown, because I’m not located in Switzerland

If you have a newer version, you can install ‘apk extractor’ . With it you can save the app and share it with me

The current version is 4.8.2 of 16.09.2019. I have found it in the Aurora Store.
I have saved the file but how do I share it with you?

you know the telegram group ?

I have put the file in the Telegram group. Thanks