Problem with installing /e/os on my fairphone 4

Hey all

I have some issues with the installation of the /e/os on my Fairphone 4. I strugle on the step where i need to unlock the bootloader in this documentation:

The Developer options are enabled and the OEM is unlocked. The command “adb reboot bootloader” runs in the CMD and the phone goes in the bootloader. But is still locked. To unlock I run “fastboot flashing unlock” but ther is the message “waiting for device”. I hear also a disconecting sound from the Windows befor it’s get in the bootloader.

With google i didn’t get a solution. Can someone of you help me with this problem?

thx and have a nice weekend

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @timon welcome to the /e/ forum !

I think you will find an answer in this search

Getting Started on /e/OS

Try with different USB cabel. That helped me…

1 Like

I had the same problem.
It solved itself after I used my repository adb and fastboot instead of the ones from Android website. (some configuration problem maybe ?)
But I would recommend you try with a different cable first.

Debian Bullseye

1 Like

The same is happening to me, also with an FP4.

I am trying different cables and even different PCs. I can get into the Bootloader, it says “FastBoot Mode” in red but when I enter “fastboot flashing unlock”, nothing happens on the phone and the PC says “waiting for devices”

One question, can I just try different cables and ports at this point or do I need to reboot the phone, then get into the bootloader using the different cable?

So far I’ve tried 3 cables and nothing is working.

Yes, no need to reboot at this point.

Even when trying various cables it’s not guaranteed to work. The important thing is that those are data cables and not only cables valid for charging. You can check this when buying them.

You’ll also notice if the cables are USB data cables when connecting the PC while phone is in normal mode. In this case a notification should appear when phone is unlocked which allows you to change to data transfer mode (so you’re able to access internal data from PC then).

Had the same issue and it caused me some nerves. In the end changing the USB port and installing the Bootload USB-driver with permission to install everthing via troubleshooting.
I did a lot of research, unfortunately cannot find the instruction again to share.
Conclusion: Can also be a driver issue.

I also had to change the USB port to get it working. Maybe also changing the USB cable might help.

But please be cautions when locking the bootloader. My info is, that the current guide needs some update: fastboot flashing lock_critical is working fine, however the command fastboot flashing lock would result into a fastboot endless loop, however you can switch back to unlock unless you try to be very accurate:
There was 1 post of a person who did also run oem lock and the fastboot flashing lock. The last info i know is that the phone was “bricked” :frowning:

I tried 3 different cables and 2 different PCs, none seem to work. All of these allow me to copy files to the phone. When I try to unlock the fastboot flashing, my device is not found.

I downloaded the current usb drivers from google, installed them instead of the Fairphone 4 drivers that Windows had chosen. Rebooted, used a usb 2.0 port (was recommended in a manual somewhere), no change.

Sorry, I have no experience with android yet. Bought the fp4 specifically to flash /e/OS and start learning…

Hi @fp4 when you first asked 14 days ago I assumed you would eventually read Post #2 just above yours. 9 results currently show there for Waiting for device + FP4, two are marked solved, and there is plenty of learning potential in reading each thread !

aibd, Thank you!

Your link points to the thread we are in right now, so I looked around some more. Thread number 38806 had the solution:

While the phone is in bootloader mode, check device manager, update phone drivers and let Windows search for new drivers. Look for optional Windows Updates, select the three things, reboot, voilà.

Phone now shows up as fastboot device and I can continue trying to install.

Good ! :smile: The post I mentioned included a Search link but you got the intention, that is the important thing !

The link that worked for you 38806 was *waiting for any device* issue when installing FP4 -> SOLVED

Hello all.
I’ve had the same issue as fp4.
Followingf the link 38806 I was able to unlock the bootloader BUT, I am now stuck with the recovery mode.
Now in fastboot mode, the fastboot devices command works fine, but after doing adb reboot recovery command, the fastboot devices command doesn’t work.
I then cannot continue with the flash of e/OS on my Fairphone4 :confused:

Thank you for your help.


I don’t understand your problem exactly. Which issue do you have? You say fastboot devices command works fine in fastboot mode. So stay in fastboot mode and flash /e/OS. Why do you need an additional “adb reboot recovery”?
Maybe it’s better to add the exact link you’ve followed for the installation than just mentioning “link 38806”.

1 Like

Sorry i it was not clear, I finally managed to flash it.
Just redo the process and it worked this time.


1 Like