Query about installation process

Yes, thank you. it was a wrong TWRP-file.

There is no such thing as not existing. But it is strange: on my “hero2lte” the current TWRP version 3.3.1-0 works perfectly from the beginning. /e/ OTA updates are managed correctly with firmware dev (7-nougat). In combination with /e/ OS dev (8-oreo 8.1.0) I don’t see any problems so far.

The instructions do not tell you where TWRP is? I cannot see an app on the phone home screen or in settings, I have not used an android device in over a decade.

I am up the steps where I need to " Installing /e/ from custom recovery"



Ok I have

  1. Wipe data/factory reset
  2. Wipe cache partition

Now this step is not apparent.

  1. Sideload the /e/ .zip package:
  • On the device, select “Advanced”, “ADB Sideload”, then swipe to begin sideload.
  • On the host machine, sideload the package using:


With the device powered off, hold Volume Up + Bixby + Power. When the blue text appears, release the buttons.

I tried Apply update from ADB and then adb sideload e-0.9-o-2020043052057-dev-star2lte.zip from my Mac.

Is this the right /e/ package? I am going to try e-0.8-o

And it failed on the package verifying as per this screen shot:

The steps are ambiguous. I know I should be in a twrp mode or app. But how?

Your are on the stock recovery, meaning you didn’t install the TWRP recovery successfully.

1 Like

This my console log. Seems to of installed correctly. But how to I find and start TWRP?

TAB101177:Downloads rocke$ heimdall flash --RECOVERY twrp-3.3.1-0-star2lte.img --no-reboot
Heimdall v1.4.2

Copyright (c) 2010-2017 Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:

Initialising connection...
Detecting device...
Claiming interface...
Setting up interface...

Initialising protocol...
Protocol initialisation successful.

Beginning session...

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device's PIT file...
PIT file download successful.

Uploading RECOVERY
RECOVERY upload successful

Ending session...
Releasing device interface...

Indeed it seems successful. After that, you have to directly enter in recovery mode, without booting on the system (because it will replace TWRP by the stock recovery).
Once you are on TWRP, that’s ok it won’t be replaced.

1 Like

Ok thats where it seems to fail or I am not doing something correct.

After that, you have to directly enter in recovery mode, without booting on the system (because it will replace TWRP by the stock recovery).


  • Unplug the USB cable from your device.

  • Manually reboot into recovery, press the Volume Down + Power buttons for 8~10 seconds until the screen turns black & release the buttons immediately when it does, then boot to recovery:

  • With the device powered off, hold Volume Up + Bixby + Power. When the blue text appears, release the buttons.

1 Like

Thats what I did but no TWRP, just the normal recovery screen. This is on a S9+.


You must boot to recovery before your phone restart

You must apply step by step the installation procedure

It is easier with linux but this how to is very clear :
WARNING : Immediately after clicking on “Start”, press the home and volume up buttons simultaneously and for a long time. This allows you to enter in TWRP directly when the phone automatically reboots. If you don’t, Android will start normally but the TWRP installation will be deleted. It will therefore be necessary to repeat the procedure.

1 Like

Quick fingers and I got the TWRP utility to work.

I got to the ADB Sideload

adb sideload e-0.9-o-2020043052057-dev-star2lte.zip

I got through except the dreaded Status 7 Error. I have checked the steps and the asset in the updater-script. I unzipped the file, viewed the file and zipped it again.

  1. I made a test first. Zipped up then added to device
  2. Then removed the no changes then added to device

The issue is the I am getting Invalid zip file format error. I am doing the zip/unzip this via CLI:

rocke$ unzip e-0.9-o-2020043052057-dev-star2lte.zip -d e-0.9-o-2020043052057-dev-star2lte
Archive:  e-0.9-o-2020043052057-dev-star2lte.zip
signed by SignApk

rocke$ zip -r e-0.9-o-2020043052057-dev-star2lte.zip e-0.9-o-2020043052057-dev-star2lte

Not sure what is gong on. I am on MacOS.

Help please. I think this is the last step.

I have checked the SHA256 checksums, the downloaded one is the same as the source. Once I re-zip it, the check sum is different. Let me check if hidden files are getting added.

This procedure is unusual and is not provided in the installation instructions.

If your operation “adb sideload” does not work with your host machine MacOS and your device “star2lte”, although it should and usually does, try an alternative installation via TWRP Recovery.

Copy /e/ OS ROM e-0.9-o-2020043052057-dev-star2lte.zip to a microSD card and make sure it is properly recognized by your device.

Boot your device “star2lte into” TWRP Recovery.

Tap >>> Swipe to Allow Modifications

To be on the safe side, tap > Wipe > Format Data > Write the word yes and confirm the entry.

Go back to > Wipe > and tap > Advanced Wipe and select Partitions to Wipe:
[x] Dalvik / Art Cache
[x] Cache
[x] Data
[x] Internal Storage
[x] System

an than >>> Swipe to Wipe

Now go back to the TWRP menu and …

Tap Install > Select Storage > Micro SD card > OK > select the file e-0.9-o-2020043052057-dev-star2lte.zip

Tip: Do not check-on "Zip signature verification"

and last step > Swipe to confirm Flash.

The updating process is running (the blue progress bar moves to the right). When the display shows
... done
also type Wipe Cache/Dalvik and lastly Swipe to Wipe

If the following is displayed again
... done tap on Reboot System

Now the Samsung logo is displayed first briefly and then the animated e-logo. The initialization is now done and will take some (long) time. Be patient and wait until the black “e” is displayed on a white background.

Now tap on NEXT in the lower right corner and set up the system.

That should be it. Welcome to the /e/ club.

Update & Tip: If you see in TWRP Recovery Install TWRP App? tap button Do not install.

1 Like

I went to test removing the assert in the updater-script as I was getting this error.

Status 7 Error

Thats why I had the zip process.

This was the Error I got.

I found some forum articles here that explain to remove the device and product checking asserts() at the top, which seem odd. I went to add a ui_print() with the device checks. But it then would fail on the Zip file format. So I set out to work out what the issue there was. I use Unix/Linux on my Mac for my job.

ERROR: Vendor image on the device is NOT compatibel.

Expactted version: 27-ARI9

Have you installed VENDOR-27_ARI9.zip as recommended in the /e/ documentation?

On some devices, installation can fail if vendors are not up-to-date. In this case, please:

1 Like

Thanks, that worked. Woot! I wasn’t clear if that was for the previous step. At one stage lets hack through the docs. I do a tonne of technical documents for my role, not enough time doing software engineering these days :frowning:

All’s well that ends well. Again, welcome to the /e/ club, @elliotrock

Congratulations @elliotrock !!!